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QXmlEdit offers you the possibility to view, navigate and edit XML data as few other editors. It is
like a Swiss army knife. It is multi platform and, more, it is Libre Software; that means that it gives
to the user the freedom to adapt it to its needs and it comes with complete source code.

QXmLEdit is an XML editor and its main features are:

Hierarchical customizable view of XML elements.

Fast XML hierarchy navigation.

Handling of base 64 coded text and XML inserted as data.

Powerful search.

XML snippets.

XML compare utility.

XML Schema viewer.

Visual compare of XML schema.

Flex code generation from Balsamiq source.
Session handling.

XSL specialized mode.

Split of big XML files.

Data anonymizer.

QXmLEdit is an XML editor. To use it with proficiency you need to be accustomed with XML. It is a
technical tool oriented toward software developers.

Following this manual you will learn to:

Examine XML data in details.

Applying different views to XML data to examining them under different points of view.

Customize QXmlEdit to ease your work.

Navigate and inspect XML data.
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On the QXmlEdit Internet site you will find the up to date documentation and tutorials. The site
address is: http://gxmledit.org. The link for the source code is:
https.//github.com/Ibellonda/qxmledit.

To get help while using the program you can use the menu Help > Help on QXmlIEdit.

New features: replica of elements, various fixes.
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Overview of QXmIEdit User Interface

The user interface is very simple and consists of a main panel where all the functions of the

program can be controlled.

Copy selected
data into the
clipboard

Recent
sample.xml (1)

Most used
' sample.xml (1)

Most recent folders
2 /Users/lbell/de...dit-manual/data

Sessions
data panel

More...

X QxmiEdit - /Users/Ibell/devel/qxmledit/manual/gxmledit-manual/data/sample.xml

Encoding
indicator

# search... | a

 *Processing Instruction* <?xml  xml(version="1.0" encoding="UTF-8")
1 <class  MainWindow

class="QMainWindow"

v - 2 <widget - 'MainWindow R T

v 1 <property - 'geometry’ name="geometry"

Vv [« 1 <rect
l1<x 0
2<y O
3 <width 906

4 <height 725
Vv - 2 <property - 'windowTitle'
QXmlEdit

v - 3 <property - 'windowlcon'

name="windowTitle"
1 <string
name="windowlcon"
v 1 <iconset resource="risorse.qrc"
1 <normaloff  :/icon/images/icon.png
*text*  :/icon/images/icon.png

class="QWidget"

b4 i = i : " e "
4 <widget - 'centralwidget name="centralwidget

o . class="QHBoxLayout"
v - 1 <layout - 'horizontalLayout' name="horizontalLayout"

v« 1 <item

class="SessionDrawerWidget"
name="sessionTree"
native="true"

v 1 <widget - 'sessionTree'

v 1 <property - 'sizePolicy’ = name="sizePolicy"

Data
modification
indicator

Read only
status

Working
mode
indicator

encoding:UT 8 ; .
(5 Ada il ] Main _edlt
functions
& Append...
/ Edit... ]
% Delete
| 4+ Move Up
¥ Move Down
View as
XSD
viewer
Styles
]
Session
status
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This is a small abstract of the common operations grouped by purpose:

Navigation:

© Go to parent element (menu Navigation, shortcut F12).
o Go to next sibling (Navigation, F10).

o Go to previous sibling (Navigation, F9).
Data modification:

© Insert or append an element.

° Insert or append a comment.

© Insert or append a processing instruction.
o Change the position of a node.

o Paste a node as child or sibling.

o Copy or paste a set of attributes.

o Operation on containers:

= |nsert a parent

= |nsert a child container that enclose all the current children

= Remove the parent on a node.
© Transform a node into a comment and vice versa.
© Insert prolog and namespace declarations.
o Edit base 64 coded text blocks.
o Edit base 64 coded attributes.
o Transform files into base 64 text blocks.
View Data:
© Hide all the siblings of a node.
© Hide all the children of all the sibling of a node.
© Filter the visible attributes.
o Hide all the elements that have no children.
o Show the children count and the size of a node.

© Close all the siblings of a node.

For a complete description of each operation go to the specific section of this document. Here you
will find a small reminder of the commands.
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Menus are divided in main functional groups; the most used commands are kept visible in main
dialog as a button on the right.

The menus are described here:

Menu Functionality

File XML document creation and saving

Edit clipboard handling; find command and configuration options
Bookmarks all about bookmarks

XML XML tree manipulation (insertion, deletion, etc)
Navigation XML tree navigation

View view commands and options

Sessions Session related commands

Tools plugins and tools

Help help

The QXmlEdit goal is to view and edit small XML files. It is not intended to handle data of hundred
of megabytes, since it works completely in memory.

1. Open files using the File > Open menu.

2. In the Open Files dialog choose the file type you are looking for.

This feature lets you override the settings by opening a file in a new window, if open new files in
same window is selected as a global option. If the configured behavior is to open files using new
windows, the option lets you reuse the current editor window.

* Use the menu File > Open in New Window if behavior is to open files reusing same
window.

* Use the menu File > Open in Same Window if behavior is to open files using new
windows.
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This setting can be configured in the preferences dialog.
* Menu Edit > Configure
* Select General tab

* Check "Open in new window" option.

You can save the file using this menu commands:
To save the file with the same name:
* Save the file using the File > Save menu.
To save the file with another name
» Save the file using the File > Save As... menu.
To save a copy of the file with another name, but continue to work in the original file:

* Open files using the File > Save a Copy As... menu.

Note: using this last option you make a copy of the file as it is in its current state. The original
file is not modified and the editor retains the current state.

Sometimes you can create a new file by pasting an XML text from the clipboard. For example you
can cut a block from a database client or a PDF or HTML page.

Use the menu File > New From Clipboard.

Using the File > New Specialized item, you can create new documents of a particular kind.
* XSL-FO
* XML Schema
* XSLT
* Maven POM.xml
The documents are created with the predefined namespaces and declarations.
Creating Documents from Snippets

Using the File > New Specialized > New from Snippet item, you can create new documents from
a previously saved snippet.
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Using the menu File > Reload the last saved version. The modifications to the current file will be
lost.

The following export methods are available from the File > Export menu:
* Copy all to the clipboard
e Export as Java/JavaScript

* Export as C/C++

The document can be put in read only mode using the menu Edit > Read Only

Using the menu File > Recent Files you can load the last edited files.

Usually, working with files, there are some directories that are accessed often. QXmlEdit gives you
the possibility to remember these places and to quick recall them when opening files.

To add the directory of the current open file to the preferred ones:

* Use the menu File > Preferred Directories > Add Current Directory to Preferred Ones
To edit the directory list in a separate window:

* Use the menu File > Preferred Directories > Edit Preferred Directories...

A dialog will open
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Preferred directories

Preferred directories W Ok
Ihomellbellideveligamleditidata

Preferred
directories @ cancel

Insert a new link to
directory
Remove a link

To add a new link to a preferred directory
* Push the Add... button.

To remove a link to a directory
¢ Push the Remove button.

To confirm the directory list press OK.

To open a file into a preferred directory:

Use the menu File > Preferred Directories, then select the directory.

After having loaded XML data, there are many modes to view elements and attributes. The main
view uses a tree representation, mapped on XML data, however you can highlight some data
aspect:

To view one element attribute on a separate line (very readable if you are looking for attribute
values):

* Select the menu View > Show One Attribute per Line
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b layout- vericalLayout'
" item
v layout- farmLayout
w property - fieldGrowthPaolicy'
enum
= item
v widget- 'label’
b property - text
string
7 item

widget- 'editTag’
w iterm

v widget- 'label_2'
b property - e

etrivim

class="QVBoxLayout'
name="vericalLayout"

class="QFormLayout’
name="formLayout’
name="field GrowthPolicy"

row="0"
column="0"
class="GLabel"
name="label"
name="text"
row="0"
column="1"

class="GQLin=Edit"
name="editTag"
row="1"
column="0"
class="QLabel"
name="label_2"
name="text"

To show the ordinal position of each child relative to their parent:

¢ Select the menu View > Show Child Index
1 -layout- vericalLayout'
A 1 -itermn

b 1 -layout- formLayout'

A 1-property - fieldGrowthPaolicy'

1-enum

v 2-jtem

b 1 -widget- label’

hd 1-propery - text’
1 -string

v 3-item
1 -widget- 'editTag’
v 4 -itemn

hd 1 -widget- 'label_2'

hd 1 -property - ‘text'
1 -string

To show a more compact view:

* select the menu View > Compact View

class="0VBoxLay
name="vericalLay

class="QFormLay
name="formLayol
name="fieldGrowt

row="0"
column="0"
class="QLabel"
name="labge/"
name="text'

row="0"
column="1"
class="GLineEdit'
name="editTag"
row="1"
column="0"
class="GlLabel"
name="label_2"
name="text'

row="1"
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File  Edit
b =
Elements

© ui

-

QXmIEdit- home/lbelldevelgamieditidatalelemento.uixml

Bookmarks XML Mawvigation Mew Tools Help

Hdb |

class
widget- 'Dialog’
propery- 'geometry’
v rect
X
v
width
height
property - ‘windowTitle'
string
layout- horizentalLayout'
w item
hd layout - verticalLayout'
w item
v layout- formLayout'

hd property - fieldGrowthPolicy'
enum
v item
@ widget- ‘label’
A property - ‘text'
string
Z item
widget - ‘editTag'
v item
o widget- ‘label_2'
A property - ‘text'
string
2 item
widget - ‘editText'
4 item

@ widget- ‘label_3'
v property- ‘text
string

AftributesiText
version="4.0"
Dialog
class="0Dialog", name="Dialog"
name="geometry’

Tex

0
0
752
423
name="windowTitle"
Edit Element
class="QHBoxLayout', name="horizontalLay....

class="QVBoxLayout', name="verticalLayout'

class="QFormLayout’, name="formLayout’
name="figldGrowthPalicy"

QFarmLayout:AllNonFixedFisldsGrow
row="0", column="0"
class="0Label' name="label"
name="text'

Elemento
row="0", column="1"
class="0Lin=Edit", name="editTag"
row="1", column="0"
class="0Label" name="labe/_2"
name="text'

Testo:
row="1", column="1"
class="QTexdEdit", name="edifText"
row="3", calumn="1
class="QLabel' name="labe/_3"
name="text'

Aftributes

~

encoding:UTF8
Add Child...

Append
Edit...
Delete
4» Move Up

¥ Move Down

To show the attribute length near to their name:

* Select the menu View > Show Attributes Length.

To show attribute contents using a fixed size font, to better discover the presence of spaces:

* Select the menu View > Show Attributes Length.

To show in a separate column the text length of the elements:

e Select the menu View > Show Text Length.

To show the number and size of the children of each element:

¢ Select the menu View > Show Element Size.

To show the text contained into elements as base 64 encoded:

¢ Select the menu View > Show Text as Base 64 Coded.

Note: this option can have an impact on visualization speed.

To expand all the closed branches of the XML tree:

* Select the menu View > Expand

To enlarge or reduce the size of the character used to display the data:

¢ Select the menu View > Zoom In or View > Zoom Out.

or

* Use the Control key while scrolling with the mouse wheel.
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To view only the structural components of the XML (the elements that have other elements as
children):

* Select the menu View > Hide All the Leaf Children

To undo the effect of the previous command:
* Select the menu View > Show All the Leaf Children.

To show or hide on the basis of individual node, first select the node, then, to hide:
* Select the menu View > Hide Leaf Children.

To show:

e Select the menu View > Show Leaf Children.

It is possible to filter the display of the attributes. A profile can show only a set of attributes or
hide a given list of attributes. When an element has some hidden attributes, a filter icon appears.

It is possible to manage the attributes that can be shown or hidden in each element using the menu
View > Filter attributes > Manage Profiles...

In the management section it is possible to create delete or apply profiles.

profile
Description
a new pro
Action: @
Hide the selected
Attribute Names
attrl
attr2
attrEqual

New

Edit

Delete

To apply a temporary profile, based on the current element:

1. Select an element.

2. Use the menu View > Filter attributes > Apply a Temporary Profile.
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Attributes filter (fase profile)

Attributes
¥ elementFormDefault ¥ targetNamespace ¥l xmins
@Cancel

¥ xmins:xs

Select all

Select none

R
2

It is possible to transform the temporary profile into a regular one using the menu Use the menu
View > Filter attributes > Save the current Profile.

Using the XML > XSLT Edit Mode menu item you can switch to XSLT edit mode. When loading a
file with "xsl" extension or containing a reference to XSLT namespace a panel will open.
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x 0¥mlEdit - thomellbellidevaligxmleditixsditestidataleslttemplatefunctions.xslc
File Edit Bookmarks XML MNavigation View Sessions Tools Help
i j i -
S Hd H v - I= & 0N _ e = | /.

encoding:UTF8

Elements Size | Attributes/Text

2B 3 —xsl:if 145  test="/"

ar

Lzl X XLST Made
L
1l

4 —xslic \c\){) It seems that you loaded an X5SL document. Do you want to
" switch to XSLT edit mode?

XSLT mode

Yeg Using the X5LT edit mode you will:

® Use a specialized panel to edit elements.
® Use an enriched context menu.

No Use standard XML edit mode

Automatically enter XSLT mode when loading an X5LT

document.

Do not ask any more this question

Use the configuration panel to change the value of the options

6 —xsl:g :
8 —xsl:template - 'cdbfgfg’ 1(3) 70 name="cdbfgfq"
1-a 1(2) 21

B[ 1 -b 1(1) 14
)

No schema mode: XML

1. To activate the XSLT mode simply answer “Yes" or use the return key.

2. To have the mode always activated without answering the panel any more, select "Auto”.

The settings can be also changed using the preferences.
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x 0XmlEdit - thom devel/gxmleditixsditestidataixsltitemplatefunctions.xslt

File Edit Bookmarks XML MNavigation View Sessions Tools Help
9HH ox e ® _/,E

! Canfiguration

Ele

: - — :
. KGeneral ‘ ‘P?X Style . W Validation | | Sessions . \h/ Edit Modes

XSLT mode
¥| Show the "Switch to XSLT" panel when opening files.

Automatically switch to XSLT edit mode when opening an XSLT file.

SR

No schema mode: XML

1. From the Edit menu choose "Configure”, then “Edit modes".
2. Set if the XSLT edit mode should automatically engage.

3. You can hide the panel if you do not care to enter this mode.

A specific display style will be applied only to XSLT elements. The intermixed non XSLT elements
will not be touched, to reveal the XSL structure at a glance.
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»* Omicdic

File Edit Bookmarks XML Navigation View Sessions Tools Help

PEEADD & ® v

Elements #Ch. | Size Attributes/Text

[+] encoding:UTF8

3 -xshif - T 2(3) 145 test="r"
1 -in-if 0(0) 15
B 2 -xskattribute - ‘attr’ 1(1) 99  name="att"
1 -xskvalue-of = “o0¢ 0(0) 51 select="yuc"
4 -xslkchoose 3(6) 185
& | 1 -xskwhen - ‘pesition()=1' 1(1) 57 test="position()=1"
1 -one 00 11
& | 2 -xskwhen - 'pesition()=2' 1(1) 57 test="position()=2"
1-two 00 11
& | 3 -xshotherwise 1(1) 46
1 —other 0(0) 15
5 -xsl:call-template - ‘one’ 2(2) 195 name="one"

1 -xskwith-param - ‘p1'$varl 0 (0) 70 name="pl", select:

2 -xsh:with-param - 'p2' $var3 0 (0) 70 name="p2", select
6 -xsl:apply-templates - * 0(0) 61 select="+"
8 -xslitemplate - ‘cdbfgfg’ 1(3) 70 name="cdbfgfg"
82 1-a 120 21

g l1-b 1(1) 14

[ |
== Nostyle ==

No schema mod{  predefined
XSD
o XSLT

1- Double click an XSL element in the editor.

2- A special panel will open.

3- When you edit the "select” attribute, the autocompletion function will list the relevant variables.
4- When invoking templates or parameters, you will see their names in the combo.

5- To return to the usual property panel use CTRL-double click.

X

File Edit Bookmarks XML Navigation View Sessions Tools Help
S HEX DL e LI R 4
Elements Size Attributes/Text EhcocingliEs
(2] 5 —out 30 atr="(var2y’ FS add chita
& 6 -xsltemplate - ‘one’ 319 name="one" -_9 T
1 -xskparam - 'p1''def1’ 61 name="p1", select="def1" =
2 -uskparam - ‘p2 der2 61 namesy2r seect=mger2”
3 -xslichoose € Delete
% 00
Path:  /xsl:stylesheet/xsl:template
Element xslvariable
_— S [@a)
select  [var3'| )

Tip: a(ls and attributes names for autocompletion using the main menu command.

e Eye)
1 -xskvalue-of - “oo¢ 0(0) 51 select="xu"
B 4 -xslchoose 3(6) 185
& 1-xslwhen - ‘position()=1' 1(1) 57 test="position()=1"
1-one 0(0)
& 2 -xsl:when - ‘position()=2" 1(1) test="position()=2"

1-two 0(0)

I )

No schema mode: XSLT 4

A new context menu appears on the editor elements. The menu propose to you the most used XSL
elements giving you the choice to append them to the current element as sibling, or to insert them

as a child.

The proposed elements are sync with the context, that is in a "call-template”, the only "with-

parameter” element is proposed as a child.
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X

File Edit Bookmarks XML Navigation View Sessions Tools Help

a2 DN ov =/ H

Elements.

“apply-templates’ append as sibling

5-out
“attribute insert as child
& 6 -xsktemplate - ‘one’

1 -xsh:param - 'p1'‘def1’

2 -xsliparam - 'p2*'def2’ “call-template’ append as sibling

{~[) 3 ~xskchoose “choose' insert as child
L 4 -style - ‘XSLT “choose append as sibling

‘comment’ insert as child
I cut culax

Copy. G ‘copy-of insert as child

Copy Element Path in the Clipboard e e I

| Paste Cut+V. ‘element insert as child
Edit Inner Text as One Node.
Edit inner Base 64 Text...
Edit Inner XML...
Edit Inner XML Base 64 Coded.

*for-each' insert as child

Transform in Snippet.
“function’ insert new.
@ “if insert as child

¥ Move Down Ct#M | e append as sibling

*sequence’ insert as child

R Y *sequence’ append as sibling

‘template’ insert new
“value-of" insert as child

‘value-of' append as sibling

‘variable insert as child

Using names for auto-completion

“apply-templates' insert as child

“attribute’ append as sibling

“call-template" insert as child

‘comment append as sibling

‘element’ append as sibling

“for-each’ append as sibling
“for-each-group' insert as child
“for-each-group’ append as sibling

% pelete
*

)

a mode: XSLT

(] encoding:UTF8

S s cnia. |

1€ append...
/ Edit..

& Move Down

When XSTL mode is acting, you can scan the target XML file to extract names to be used with the
auto-completion feature of the edit panel.

Use the menu XML > Target XML

X
File Edit
3 B

Elements

QXmiEdit -

Bookmarks XML Navigation View Sessions Tools

H 2 D PRV

vl

#Ch. Size Attributes/Text

5 —out 0(0) 30 attr="(varl)"

6 -xsl:template - "one’ 4(4) 319 name="one"

1 -xslparam - 'pl''defl’ 0(0) 61 name="pl" select="def1™

2 -xsl:param - 'p2''def2"’ 0(0) 61 name="p2", select="def2"™

3 -xsl:choose 0(0) 25

encoding:UTF8

K Delete

X%

Path: fxs|

XSLT Element.

|:stylesheet/xsl:template

Element xsl:variable

i

.

r3

select  [af

svarl [~

$var2
@

@a2 %) | 1 -xslvalue-of - e’ select="xxx"

slichoose

1 -one

—xsiatcripute - ater name= atr

~xsl:iwhen - ‘position()=1" test="position()=1"

2 -xslwhen - ‘position()=2' test="position()=2"

1 -two

No schema mode: XSLT

Using the menu Navigation > Show XSL Navigator you can access a panel listing all the
templates and functions existing in the file. A double click will lead you to the template or function

definition in the editor.
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X oxmlEdit -

File Edit Bookmarks XML Navigation View Sessions Tools Help

;’ul—l-ﬁf”a ® v = i

XSIT Navigator

& Templates (5)
one
template2
- template3
templated
“template5
- Functions (4)
- functl
- funct2
- funct3
functd

No schema mode: XSLT
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Xml Schema management
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It is possible insert references to an XML Schema set of files. Using the menu XML > Schema
Instance > XML Schema References the “Insert Xml Schema References” dialog will appear.

® 06 XML Schema References
™ Elements without namespace: http://www.w3.org/1999/X5L/Format © | select. | [ oK |
Namespaces: . Annulla_|
Namespace Location

I8 http://www.w... | http://www.w3.org/MarkUp/SCHEMA/xhtml11.xsd | Add |

| Modify |

| Delete |

In this dialog you can insert
* aschema reference for elements without namespace
» for each namespace, a schema reference

The references will be inserted in the root element using the xsi namespace defined as
http://www.w3.0rg/2001/XMLSchema-instance namespace. If the namespace is already
declared in the root element, it will be used, else the namespace declaration will be inserted. If the
prefix xsi is already used, a new prefix will be created.

There is a facility for edit XML Schema documents in the editor a set of menu commands:

XML Schema > Insert No Namespace Schema Reference Attributes : insert a no namespace
attribute for the target schema to complete.

XML Schema > Insert Schema Reference Attributes : insert a namespace attribute for the target
schema to complete.
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Editing or inserting a type, attribute or element

Using the XML Schema menu items it is possible to edit or insert XSD types.

Operations in the dialog:

Choosing the type
* Reference: will set a reference to a type.
* Simple: inner simple type.
¢ Complex: inner complex type.

When choosing a complex type, it is possible to choose the content type.
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If it is an update of existing data, the existent children that are not compatible with the selected
type will be deleted, but the children that are compatible will be preserved.

The annotation of XSD objects can be edited using the menu:
XML > XML Schema > Edit XSD Annotation

If the element has no annotation one annotation is automatically created and the edit panel is open.
From this panel is it possible open the complete edit annotations panel where more than one
annotation can be inserted for the given element. If the element has already more than one
annotation item, the full annotation panel is open.

This panel configures a single annotation item.

| % e XSD Annotation 2 @ @ @ |

® documentation

| applnfo
||
1
| Source: source -
Cancel
Language: (en |~
| 1
| Comment:
|
Text XML
simple cu:umment-cinner_item>a<fﬁnner_item>
Advanced...

The panel can show the inner contents of the annotation when containing XML mixed to text.
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Available options:

Type Switch the type of the annotation item between documentation
and appinfo.

Source Set the source of the item.

Language Valid only for documentation type.

Comment/text Edit field for the annotation item

Comment/XML XML view of the annotation item. This view is read only.

Advanced When the panel opens and the parent element has no items or only
one, this button opens the advanced edit panel.
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This panel shows a list of annotation items. Form here the items can be created, edited and deleted.

([~
(<
8
=

l &/ Manage annotations

Type Language Source Annotation QK

1| documentation version 300+

2| documentation description | The &lt;code>&amp;ltproject& amp;gt;&lt;/code> element is the root of the descripto... |
Cancel

Mowve up

Mowve down

Available options:

Command Functionality

New Create a new item.

Modify Edit the selected item. This option can be triggered also by a
double click on the list.

Delete Delete the selected item.

Move Up Move the item one position up in the list.

Move Down Move the item one position down in the list.
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Select an element and use the menu “XML>Schema Instance>Insert “nil” Attribute” to insert
the Schema Instance (XSI) “nil” attribute. If the namespace “xsi” is not present, it will be inserted in
the element, changing the prefix if the same prefix is already used; after that the attribute is
inserted.

Select an element containing the Schema Instance “nil” attribute and use the menu “XML>Schema
Instance>Remove “nil” Attribute” to remove the XSI “nil” attribute. If the XSI namespace is
declared in the elements and it is not used in the same element or its children, the namespace is
removed too.

Select an element and use the menu "XML>Schema Instance>Insert “type” Attribute” to insert
the Schema Instance (XSI) “type” attribute. If the namespace “xsi” does not exist, it will be inserted
in the element, changing the prefix if the same prefix is already used; after that the attribute is
inserted. The type can be chosen using a dialog.

Select an element containing the Schema Instance “nil” attribute and use the menu “XML>Schema
Instance>Remove “type” Attribute” to remove the XSI “type” attribute. If the XSI namespace is
declared in the elements and it is not used in the same element or its children, the namespace is
removed too.
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The preferences panel can be opened using the menu Edit > Configuration.

The panel allows the configuration of the following categories:

Information Description

General General options.

Style Management of display style in the editor.

Editor Colors The name says all.

Validation Option related to XML and XML Schema validation.
Sessions Management of sessions data.

Edit Modes Activation of special modes in the editor (e.g. XSLT).
XML XML management.

Here a detailed explanation of the options:
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Option

Description

Show welcome page

Shows the welcome page at program startup.

Enable experimental features for
test purpose

Enables experimental feature in development editions.

Default font bold

Use bold font weight for elements.

Override the font for elements
display

Use an user chosen family in the editor.

Override the font for fixed
spacing attributes

Use a custom font when rendering attributes with mono spaced
font.

Enable Logs

Enable logging.

Automatically expand editor tree
when loading data

Expands (open) the wijole tree after loafing a new file.

Autoscroll in the elements tree

Enable autoscroll when dragging items

Open files in new window

A new window is used each time a file is loaded.

¥ Configuration Py @
/\‘)‘: General P?X Style ?’g;( Editor Colors “\7// Walidation Sessions \../ Edit Modes XML
Behavior
Show welcome page

¥ | Autoscroll in the elements tree
v | Enable experimental features for test purpose

Appearance

| Default font bold
Override the font for elements display <Mot Set> change font...
Override the font for fixed spacing attributes Courier 10 Pitch size 9

| Enable Logs Level: | error b
V| Automatically expand editor tree when loading data

¥ | Open files in new window

Warning: changes will be applied only after 2 program restart.

OK
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Style

This panel lets you choose the location for user defined styles files.

Use the program directory Use the installation folder

Use the standard Operating System |Use the default location for data.
location

Use the following directory Use a user defined folder.
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Editor colors

This dialog is described in details in the Style section. You can customize the colors of the editor.

tags
processing instruction

anonymized element in preview
anonyrmized text in preview
anonymized attribute in preview anonymized attribute in preview

‘Q *Processing Instruction® <?xml  xrl{version="1.0' encoding="UTF-8')
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Validation

Enable automatic loading of XML Automatically loads referenced XML schema files in the
Schema associated to file edited background at the XML file loading.

Enable disk cache (maximum size: 1 |Enable cache for XML schema files to avoid unnecessary network
Mega) traffic.
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Sessions

Session options described in the Session section.
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Edit Modes

Automatically switch to XSLT edit |When loading a new file, if it is recognized as a XSLT documents,
mode when opening an XSLT file. XSLT edit mode is automatically enabled.

Show the "Switch to XSLT" panel When loading a new file, if it is recognized as a XSLT documents,
when opening files. open the XSLT edit mode panel.
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XML management options

Option

Description

Automatically insert prolog with
encoding

When creating new files, insert XML prolog with optional
encoding specification.

Automatically update metadata as
processing instruction if found
when saving data

Enable the update of QXmLEdit specific metadata in the file when
saving.

XML indentation on save

Enable or disable XML indentation when saving. A value of O still
saves on element per row. You have to disable it explicitly if you
want only one output text line.

Save using stream instead of DOM

Enabled by default. Allow a finer control on input and output.
DTD declarations are not handled if this option is unchecked.

Sort alphabetically the attributes

On saving the attributes will be sorted alphabetically on their
name.

QXmlEdit user manual, page 36 of 99.




QXmlEdit user manual, page 37 of 99.



QXmLEdit can use a different display style, the font used, its dimensions and the color, to represent
different XML structures. The style description can be created by the user and applied on demand.

QXmLEdit comes

with some predefined styles.

The style can display the value of some attribute near to the element tag to highlight the element

type.
To apply a style:

* In the main window, click the styles popup (| £%,, ), then choose the desired style.

To remove a style:

* In the main window, click the styles popup ( £ ), then choose the “== No Style ==" item

The style files location can be configured using the menu item Edit > Configure.

In the appendix there is the complete style reference.

An example of style applied to an XML Schema file is represented in the following screenshot:

The style can be

P EE N DL

Elements
¥ item
v layout - wvericalLayout'
v item
¥ layout- ‘formLayout’

b propery - fieldGrowthPolicy'

enum
v item
w2 widget- label'

v property- ‘text'

string
© item
widget- 'editTag’
v item

hd widget- 'label_2'

v propery- ‘text

string
v item
widget - ‘editText'
v item
w2 widget- 'label_3'
v property- ‘text'
string
v item
b layout - ‘horizontalLayout_1'
v item
hd layout- verticalLayout_2'
v iterm
widget- 'listWidget'
v item
hd layout- 'layBox1'
e item
v widget- lineEdit_2"

w

-

used to highlight the elements.

property - 'sizePolicy’
sizepolicy

#Ch.
1(79)
2(79)
1(19)
6(18)
1M
0(0)
1(3)
1(2)
1(1)
0(0)
1(1)
0(0)
1(3)
1(2)
1(1)
0(0)
1M
0(0)
1)
1(2)
1
om
1(87)
2 (56)
1(33)
2(32)
T
00
1(29)
4(28)
1(5)
104)
1)
2(2)
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* kd 4 -event 21 2] 266 ogger="loggerl”, tim¢
0 (0) 28 <html><body bgcolor...
C(0) 122 file="Testjava", line='
v @ 5-even 2(2) 265 logger="loggerl”, time

The Style can be based on rules, in the appendix there is the full detail.

Basically you can use the tree view to insert child nodes or append nodes as brothers of the current
one. There is a separate input panel for each node type you can manipulate: elements, comments,
processing instructions.

To insert an element as a child of some other node:
* Select the XML > Add a Child Element menu.
or
* Click the button Add Child... on the main window.
To append a node as brother of the current selection:
* Select the XML > Append a Brother Element menu.
or
e  Click the button Append... on the main window.
To work with attributes:
* open the element edit panel and start editing
To insert a processing instruction as a child of some other node:
* select the XML > Add Processing Instruction as a Child menu
To append a processing instruction as a brother of some other node:
* select the XML > Add Processing Instruction as Brother menu
To remove a node of any type (element, attribute, comment, processing instruction):

¢ click the button Delete on the main view

There are some shortcuts to move from one element to another one using the relationship between
the two. These shortcut are handful especially when the data tree is very tall, and avoid you the
necessity to continually scroll the window while examining data.

To rise from an element to its parent:
* select the element, then press F11

To jump to the next element at the same level of the current one:
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e select the element, then press F10
To jump to the previous element at the same level of the current one:
* select the element, then press F9

To close all the children of an element and all the children of their brothers (it gives you a compact
view of the tree level in one operation):

* select the element, then press F12

To edit the selected object:
* double click on the selected element
or
* press the Edit... button in the main window

When editing elements a panel will open. In the panel the current element path is shown; it is
possible to manage namespaces by recalling a library of user defined data. It is possible to manage
base 64 coded attributes.
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Edit Element

» o Edit Element PP ®

Path: foroot/follayout-master-set/fosimple-page-master
Tag: [fo:simple-page»master ]
Text Nodes:

| CDATA Section Text Content | +(t)
1| L] ** element: <fo:region-body>
; [] ** glement: <forregion-afters
Up
Attributes [+—(_b)]
Name Value

1 master-name [0S ERERT

: page-width 21cm

: page-height 29.7cm

T margin-right | 5mm

; margin-left 5mm

: margin-top 5mm

7 margin-bottom | 5mm

In the panel you can insert the following information:

Name Information

Tag The tag of the element

Text Nodes You can insert or remove text nodes as element children
Attributes You can edit the element attributes

To insert a text node:
* press the + button in the text nodes section
To insert a CDATA text node:

* press the + button in the text nodes section then activate the CDATA check box on the text
nodes table

To modify text node content:

* select the text node, then press the Mod... button. A panel will open.

QXmlEdit user manual, page 41 of 99.



Note: you cannot edit child element nodes in this panel, only text nodes.

Edit Text Node

The selection can be always copied using usual shortcut keys or the Edit menu items,
butwhen selecting an element there is the possibility to copy only the element or the ¥ 0K

aftribute name orvalue using the copy button located in main window 1 @ = ;
ance

+'| wrap text

Base 64 Text
From Base 64
To Base 64
Binary to Base 64

 Load From File...

Sawve to File...

To insert a base 64 coded text:
* insert the text, then press To Base 64 button, then save the text
To modify a base 64 coded text:

* press the From Base 64 button, the text will be decoded, modify the text, then press To
Base 64 button, then save the text

To view the text on more lines even it is a single line:

* Activate the wrap text check box.
To load a binary file as base 64 coded text:

* Press the Load from file... button, then browse to the file in the file dialog.
To save current base 64 text into a binary file, decoding the values:

¢ Press the Save to file... button.

The selection can be always copied using usual shortcut keys or the Edit menu items, but when
selecting an element there is the possibility to copy only the element or the attribute name or value
using the copy button located in main window:

QXmlEdit user manual, page 42 of 99.



Copy Element Text ‘xs:anyAttribute
Copy Element Tag <xs:anyAttribute>
Copy Attribute Name 'namespace’

1 Copy Attribute Value='namespace'

[ Copy Attribute Name 'process Contents'
Copy Attribute Value ='process Contents'

to copy the selected element tag:

* click the Copy Element Tag item
to copy the selected element content:

* click the Copy Element Text item
For each attribute of the selected element:
to copy the attribute name:

* click the Copy Attribute Name item
to copy the selected attribute value:

* click the Copy Attribute Value item

In the edit element window it is possible to recall the namespaces mana

gement dialog.

% o Namespaces SINCIRCIR®.I
~Element « OK
Prefix: lfo ] Clear @ Cancel
Namespace: [http://www w3.0rg/1999/XSL/Format |'] l Select ]
Description: -----
(0 Declare namespace in the element itself
® Do not declare the namespace
Warning: the namespace chosen is not declared
~ Other namespace declaration
Prefix Uri Description | | Add |

Delete

1| xsd http://www.w3... | XML Schema (xsd or xs)

Namespace management dialog
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In this dialog it is possible insert namespace references recalling the namespace selection dialog.

html http://www.w3... | XHTML 1.1 (html)

xsi http:// w3, ch (xsi)

fo http://www.w3... | XSL-FO 1.0 (fo)

xsl http://www.w3... | XSL 1.0 (xsl)

local http://www.w3... | xquery local functions (local)

xsd

http://www.w3.0org/2001/XMLSchema
http://www.w3.0rg/2001/XMLSchema
Namespace list dialog

| n this panel it is possible to select a system defined namespace or choose a user defined
namespace. The user defined namespaces are managed in a separate dialog, stored permanently
and are available to successive sessions of QXmlEdit.

QXmlEdit user manual, page 44 of 99.



» o Edit Mamespace

Mame: | Userl W OK

Description: [ User2

(~
(<
O
(>

@ cancel

Tags (comma separed): [ w,a,b,#fa a}

Created on: Tue Sep 22 15:25:42 2015
Last modified on: Thu Sep 24 09:57:36 2015

Default prefix: [ abc ]

XML Schema definition (XSD)

[ http:/ftest

Schema location

[ http://test

Other prefixes:

prefix
prefix
prefix Add

Modify

Delete

You can mark the elements with bookmarks for easy retrieval and navigation.
To set a bookmark:
* select an element, then use the menu Bookmarks > Toggle Bookmark (CTRL-F2)
To remove a bookmark:
* navigate to the bookmark, then use the menu Bookmarks > Toggle Bookmark (CTRL-F2)
To remove all the bookmarks:
* use the menu Bookmarks > Remove All Bookmarks
To move to the next bookmark:
* PressF2
or

¢ use the menu Bookmarks > Go to Next Bookmark
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To move to the previous bookmark:
* Press Shift-F2
or

¢ use the menu Bookmarks > Go to Previous Bookmark
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Basic information about the file can be shown using the menu Edit > Info

The information is relative to:

Encoding.

XML Schema references embedded into the file.

Declared name spaces.
DTD.

File information.

Here an “Info” panel:

® 0 06 Information

Encoding: UTF-8
No file information.
DTD

| Annulla |

XML Schema references
There are no XML Schema references

Namespaces

Prefix Namespace URI

1 fo http://www.w3.0rg/1999/XSL/Format ‘

role

Please note that some namespace prefix can be used in more than one place with different
references.

The “role” column will list well known namespaces.

The DTD of the document can be edited in this panel if the file is not read only. The manually edited
DTD is not checked against syntax errors.
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Sometimes the data of an element are text nodes or binary data base 64 coded. QXmlEdit can
display decoded base 64 coded text near to the literal content in the main window, and permit you
to edit directly the content.

To edit directly the base 64 coded text of an element:

1. select the element, then right click to make the context menu appear and select Edit Inner
base 64 Text.

2. Write directly the text into the edit box of the panel that appears.

The text will be automatically encoded and decoded as needed.

Sometimes the data of an element is an XML payload registered as text, or a base 64 coded XML.
QXmLEdit can edit directly both the types of contents.

To edit directly the XML data stored as payload of an element:

1. select the element, then right click to make the context menu appear and select Edit Inner
XML.

2. Another QXmlEdit Window will appear; you can use it to edit the inner XML.
The XML will be automatically encoded and decoded as needed.
To edit directly a base 64 coded XML used as element payload:

1. select the element, then right click to make the context menu appear and select Edit Inner
XML Base 64 Coded.

2. Another QXmlEdit Window will appear; you can use it to edit the inner XML.

The XML will be automatically encoded and decoded as needed.

You can insert a XML prolog XML using the menu XML > Insert prolog. You can insert automatically
a prolog on document creation using an option in the configuration panel. In the panel you can also
select the encoding to be used.

An XML Schema validation option is available, but it uses the Qt XML validation facility, that is
rather limited at the moment. The validation is made by default using schema references contained
in the XML document, if any. You can use an external XML Schema file; after this assignment the
validation is performed using the assigned file until an explicit command to use the document
references is given.

If an external schema file is used, its path is visible In the tool tip of the toolbar “Validate"
command.
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To validate using the last assigned schema:

* select the menu XML > Validate
To validate a document using self referenced XSD, if any:

* select the menu XML > Validate Using Document References
To use a different an XML Schema file:

* select the menu XML > Validate Using New Schema File

N B: the validation option is available only if compiling at least with the Qt 4.4. It uses the Qt
XML validation facility, that is rather limited at the moment.

It is possible to display the sum of the number of elements children and the element total size,
calculated on the canonical element form ( i. e. counting stating and ending tags ). The size
calculated is only an approximation of the real value, given that there are many modes to write the

same XML data.
To activate the option:

¢ select the menu View > Show Element Size

It is possible to execute searches in the editor. To open the search panel:
* use the Edit > Find menu
or

* press Control+F
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File Edit Bookmarks XML MNavigation Wiew Sessions Tools Help

G ; = y " x50,

& H 7 1. & 8 o IS A= ’,/: /' E

Search
€) Textto Search |width| - | Q| H’V 0 | Fina Al | ; .Prefv Next 1] .L.':ount : XPath A‘.ivanced.
scope: . + | Search in: | Element Tag - Match Exact Value Case Sensitive Only in Children

Found 1 occurrence. size: 0 | Wrap around |V Close Unrelated || Selection to Bookmarks || Show Size

Flaar encoding:UTF-8
\ *Processing Instruction® <?xml  xml(version="1.0' encoding="UTF-8') € Add Child...
w* leui version="4.0" &) Append...
| <class EditProcessing -
_ _ _ _ _ _ / Edi.
- 2 <widget - 'EditProcessing’  class="QDialog", name="EditProcessing"
1 < - lodality'  name="windowModality” # Delete
- 2 <property - 'geometry’ name="geometry” £+ Move Up
A 1 <rect
e ¥ Move Down
<X
2w D View as XSD...
(3 <width 610
4 <height 174
» 3 <property - 'sizePolicy’ name="sizePolicy”
» 4 <property - ‘'windowTitle' name="windowTitle"
» <property - 'auvtoFillBackground'  name="autoFillBackground®
» perty - ‘modal’  mame="modal’
3 - 'verticallayout_2'  class="QWBoxLayout’, name="verticall ayout_2"
3 f- -
No schema mode: XML T o gifiable o

In the panel you can do the following operations:
To start a search:
* insert the text in the edit box and press Enter key or press the Find button
To limit the search to a particular kind of XML components, use the Search In option box:
* Al the types of components
* Element tags only
* Attribute names only
* Attribute values only
* Text nodes

¢ Base 64 coded text

The elements that match the search rules will be highlighted, but you can act on the display in the
following manners:

Name of the Option Information
close unrelated close all the branches that does not contain any occurrence of the search text.
selection to bookmarks adds all occurrences found to the bookmarks collection.
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match exact value

executes the search of the exact value of text (opposed to regard the text as a
substring)

case sensitive

the search will be case sensitive

find all

mark all the occurrences of the search pattern with a background pattern to
ease the reading, elsewhere the search will stop to first match.

only in children

the search can be limited only to children of the selected item or to the whole
tree.

scope

can limit the search to a set of elements or attributes. This field can contain a
path in XPath like syntax. For example to search a value in the “id” elements
children of “resource”, the field must contains “resource/id”. If the search has to
be performed only on “name” attribute of the “window” element, write
“window/@name"”. To include any elements between “"window" and “widget”
tags, simply omit it as in "window//widget”

XPath

Activates the XPath syntax (see below for details). If unchecked the text
entered in the search box is used as pure text.

The number of matches is reported in a box at the bottom of the search panel.

It is possible to find the next occurrence starting the search from the selected item. You can use the
command buttons in the panel or activate it using the following command:

¢ use the Edit > Find Next menu

or

e UsethekeyF3

The matching items are highlighted and, in combination with other options, non matching items are

closed.
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File Edit B ks XML MNavigation View Tools Help
- _
|DeE.s
—acuu.h
6 Text to Search |appinfo Ql Find | Search in: IAII VI
scope: |
[¥ Close Unrelated | Selection to Bookmarks |~ Match Exact Value |~ Case Sensitive [v Find Al [~ Only in Children [V Show Size
searchResults: Found 14 occurrences. Size: 0
Elements IAttributeszext H| S
\ *Processing Instruction* <7 ? xml{version="1.0") Add Child... |
[=}- xs:schema targetNamespace="http:'www.example test/", version="1.0", xmInstm:
= Append...
[ xs:aftribute - 'code’ use="required", name="code" _
[ xs:complexType - 'someComplexType' name="someComplexType" Edt...
B xs:attribute - 'code’ name="code"
E- Xs:@annotation Ll |
xs:documentation documentation 4} i "
B xs:appinfo appinfoappinfo b SOVE R
a ’ appinfo
Xs:notation - ‘txt’ public="text/txt", name="txt", system="gedit" & il 228
e xs:import namespace="http:/'www.qxmledit.org
(£33 xs:group - ‘topLevelGroup' minOccurs="1", maxOccurs="unbounded", name="topLevelGroup"
Et- xs:element
=} Xs:annotation
i ¥s: documentation sample annotation
= xs:appinfo sample annotationsample annotation
a appinfo
xs:complexType
B xs:complexType - 'complexSimpleRestriction’ name="complexSimpleRestriction"
- xs:complexType - '‘aComplexType' name="aComplexTyps"
G- xs:complexType - ‘typeWithGroup' name="typeWithGroup"
- xs.complexType - ‘typeWithGroup' name="typeWithGroup"
xs:element - ‘testElement2' minOccurs="4", maxOccurs="8", name="testElement2" _ILI
4 | » <y |

Matched items

In the panel you can do the following operations:

To start a search:

¢ select the "XPath” check box

* insert the text in the edit box using XPath syntax and press Enter key or press the Find
button

A small note will indicate the XPath mode activation.

If “Only in Children” check box is selected the root of the search is the current element, if not the
search starts at the document root.

Some of the options available to the text search are hidden because their operation can be carried
on using XQuery and XPath.

The elements that match the search rules will be highlighted, but you can act on the display in the
following manners:
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Name of the Option

Information

close unrelated

closes all the branches that does not contain any occurrence of the search text.

selection to bookmarks

adds all occurrences found to the bookmarks collection.

only in children

the search can be limited only to children of the selected item or to the whole
tree.

scope

can limit the search to a set of elements or attributes. This field can contain a
path in XPath like syntax. For example to search a value in the “id” elements
children of “resource”, the field must contains “resource/id”. If the search has to
be performed only on “name” attribute of the "window” element, write
"window/@name"”. To include any elements between “"window” and “widget”
tags, simply omit it as in “window//widget”

The number of matches is reported in a box at the bottom of the search panel.

The matching items are highlighted and, in combination with other options, non matching items are

closed.

The following screen shot shows a search using XPath:

View 5Sessions Tools Help

n v v

a search

F, '/.

@] e ][ comt |

« XPath

Q - |//* [/bi@attrd eq ‘four]

searchResults: Found 1 occurrence. Size: 117

¥ Close Unrelated ¥/ Selection to Bookmarks Only in Children ¥ Show Size

Eort . encodingUTF&

Elements #Ch. | Size | Attributes
A *Processing Instruction* <? ?> xml(version="1.0" encoding="UTF-8") Fé Add Child..
=] root 1({2) 130 eﬁpper‘ld...
attrl="one"
BE = 1{1) 117 attr2="two"
attrEqual="equal"
0(0) 46
4+ Move Up
6 Move Down
View as X5D..
[y |

Mo schema

You can open a search results panel using the button “Open panel” in the find panel.
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The new panel will show only the search results, giving the possibility to browse directly the XPath
queries elements or the text search results.

Replace uses the search feature to find text that can match and replace it all at once or one at time.
Replace is triggered by the menu Edit > Replace.

Search
€) Textto Search | xs:complexType ~ ||| & ﬁ Find All Prev Next Count XPath | Advanced
scope: ~ | Search in: | Element Tag ~ | [ Match Exact Value | | Case Sensitive | | Onlyin Children

size: - ¥ Wrap around |V Close Unrelated |v Selection to Bookmarks v/ Show Size

Replace with: |xs:simpleType| <[ B[ 4] »]| Replaceatt

Elements encoding:UTF-8

The following commands are available:

Command Behavior

Replace All Replaces all the occurrences of the search pattern.

Replace and find next If there is a selection, a replacement is applied if there is a match; then the next
element that matches is selected. If no selection was existing, the next match is
selected.

Replace and find previous If there is a selection, a replacement is applied if there is a match; then the

previous element that matches is selected. If no selection was existing, the
previous match is selected.

Skip and find next If there is a selection then the next element that matches is selected. If no
selection was existing, the next match is selected.

Skip and find previous If there is a selection then the next element that matches is selected. If no
selection was existing, the previous match is selected.

Note: replace operation cannot use XQuery search.

The purpose of the comparison as implemented is to give a compact view of changes, comparing
the current editor content with another file. The sense of the comparison is to show what
transformations are needed to the chosen file to become the current loaded one.

To compare a file against the current:
1. select the menu File > Compare with...
2. choose afile
In the panel that opens you have the following information:

¢ The current file in XML format with elements and attributes that are different between the
files with highlighted colors (Synthetic View).
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* A structure comparison side by side of the two files (Analytical view).
* The list of the differences with the path of elements (Difference list).

The following options can be set:

Option Meaning

Compare text Compare even the text nodes

Compare comments Take into account the comments

Denormalize EOL In CDATA nodes do not transform the CR LF sequences into LF as stated
by specs.

In the panel that opens you have the following options:
e Compare only elements or comments and mixed content too.
* Copy the comparison result to the clipboard.
* Retry the comparison, after changing some option.

To start a comparison, load a recent file from the relative combo box or select another one using
the browse button.

User interface Browse file
Recent files

Camparing Thama/lbellidevaligsmlsditisdicestid atalc ompare/rafarance Lxml with

Compare with: | /homl ell/devel/qxmledit/xsd/test/data/compare/comparel xml| > l o r

Synthetic view Analytical view Differences list

"three" attr4="four"/>

Zoom Options Legend
& T =) Copy Text to Clipboard Equals
Status: |Files are different. ¥ Compare Text
Options, Go to difference
Dump on stdout ¥ Compare co ts iR

Status

Compare options

Analytical view
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-

Compare with: [ihomeilbeII."deveI."qu\editixsditestldataicompare."cnmpare1 xml

Synthetic view | Analytical view

Differences list

Nodes
<? xml version="1.0' encoding='UTF-8&' 7>
=l <root>
-l <ax
=" Attributes:
@ attr2 = "two"
/ attrl = "one"
attrEqual = "equal”
- 0 <b>

= Attributes:
@ attr3 = “three”
@ attrd = “four”

=1 Attributes:

/ attrl = "one_c"
attrEqual = "equal”
® attr2l = "two"

B = 8 <c>
= Attributes:
® attr3 = “three"

4]

[«

Zoom: Options

Status: |Files are different

4] <

Copy Text to Clipboard
¥ Compare Text

o difference:

Legend

Equals
Deleted

Different
Added

Differences list

Compare with IIhcmellbel\ldeve\qum\EdltlxsdltEstidatafcumparelccmparel.xml

Synthetic view | Analytical vi

ew Differences list ‘

lcon  Status = Element

XPath

Optonsi[ |

1 Q Added  Attribute /<root>/<a>fAttributes://@attr2 = "two"
2|/ Madified Attribute |/<root>/<a>/Attributes://@attrl = "one"
3[R Deleted Attribute /<root>/<a>/Attributes//@attr2l = "two"
4|Q Added |Element |/<root>/<a>/<b>
5% Deleted Element | [<root=/<a=/[2]<c>
T Options Legend
Status ¥ Compare Text Deleted

Go to difference:
Dump on stdout ¥ Compare comments DL

i4) @

Added
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The menu Tools > Anonymize recalls a dialog to anonymize the data contained in attributes and
text of the XML.

This feature can be useful if the XML file should be sent to technical staff for debugging purposes
avoiding the disclosure of personal information.

Using this feature the text and the attributes can be altered using a fixed character or using a
different letter for each input character by preserving the case of the original letters.

The original data structure is preserved replacing only letters and digits with altered text,
preserving the case of the letters and the reserved XML attributes. The tags and attribute names
are not changed.

Often the files contain not only personal information, but also data for business rules. Modifying all
the contained text or attributes will end in a useless file transporting no information at all.

To avoid that result, manipulating the parameters that belong to the business rules, two features
can be used:

* A filter to avoid the anonymization of values consisting of less than 4 characters (the length
of many codes).

* The use of exceptions.

The exceptions can be bound to any element, attribute or text node and force the subject to be
anonymized or not; if anonymized, a user defined value can be used to replace the original one.

The exceptions can be hierarchical and extended to the children of the subject. It is possible to
isolate data from business rules from personal data. When applying more expressions, the more
specific wins; for example if an element has been forced to be anonymized with children, and one of
its children has another exception of reverse meaning, the child exception is applied.

Each time an exception is modified, the anonymization operation results are shown in a preview
pane. The original values can be seen in the tooltips of the elements of the preview.

category=" =

incategory
path: /sitefregions/africafitem/incategory

Attributes:
category (anon . )="x0000001 1" org:" category12"

Since creating rules and exceptions is a time expensive process, it is possible to save them using a
profile and recall them later in other anonymization processes.
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8 006 Anonymize

Profile Name:

This feature will destroy your data | Cancel |

Options

() All text
(e) All text with more than 3 letters or numbers

 Mask the text using a fixed pattern

: Save Profile
Preview
Elements
\ *Processing Instruction* <?xml  xml(version="1.0")
% *Processing Instruction* <?qxmledit  gxmledit(type="info" creationUse
M <rss  version="zzz", xmins:atom="http://www.w3.0rg/2005/Atom", x
¥ 1 <channel
1 <title  Xxo0oo¢ XXX
| Edit Profile |
Add Exception: | Element... | Attribute... | | Text..
Exceptions
Rule | Transform Path
[rss/@version
| Profiles... |

Delete

The options are:
e All text: all the text will be changed.

¢ Text with more than 3 letters or digit: only the text that is composed by more than 3
letters or digits will be changed. This to skip codes that usually have a limited length.

The check box “fixed pattern” determines how the text is transformed.
* If checked: letters are replaced by 'x" and numbers by '1".

* If unchecked: the letters and the numbers are replaced by a succession of letters or
numbers in alphabetical order.

The exceptions can be entered selecting the element and using the contextual menu.
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~ All text
= All text with more than 3 letters or numbers

| Maskthe text using a fixed pattern

Elements
\ *Processing Instruction* ml  xmllversion="1.0' standalone="yes'}
v site
v 1 <regions
N 1 <africa Add Exception for Element

v 1 <item - item0  id="itemQ" 5 _ —
Add Exception for Attributes &

1 <location  United States

Add Exception for Text
2 <quantity 1

3 <name dutecus nine eighteen

v 1 <listitern
v 1 <text

“text*  page rous lady idle authority capt professes stabs monst

2 <keyword  officer embrace such fears distinction attires
Lo
Information in the panel:
Name Information
Profile Name Name of the profile (read only)
Options Options to anonymize data:

* anonymize all the text
* anonymize only the text with more than 3 letters or numbers
As an option it is possible to use a fixed pattern to replace the text.

Preview It shows the final result of the operation on the current data

Add Exception You can add exceptions when an element is selected in the preview.
Exceptions The list of the exceptions

Save Profile Saves the current profile data. If the profile has not been created, a creation

panel will appear.

Edit Profile Edits the profile data.

Profiles Manages the profiles.

Import Import a list of exception in CSV format (see below for details)
Export Export the exception list to the clipboard in CSV format

To insert an exception:

1. Select an element in the preview pane

2. Use one of the buttons in the "Add exception” row
To remove an exception:

1. Select an exception in the exception list

2. Press "Delete” in the exception group.

To save the exception list in a profile:
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* Press "Save profile”
If the profile has not be created, a profile creation panel will appear.
To mange profiles:

» press "Profiles..."

A list of profiles, grouped by tags will appear. Selecting a profile and exiting with “Ok” will load the
profile in the caller dialog. It is possible also creating and deleting profiles.

Configuring the anonymization

The colors of anonymized items can be configured using the “Editor Colors” panel.

Configuration @a @ ﬁ

tags tags

processing instruction processing instruction
attribute names attribute names
attribute values attribute values
comments comments

info info

text text

anonymized element in preview anonymized element in preview
anonymized text in preview anonymized text in preview .
ancnymized attribute in preview anonymized attribute in preview b.

A *Processing Instruction® <7xml  xmilversion="1.0" encoding="UTF-8')
V—Ea <server  xmlns="urn:abcdef"
«» 1 <properties  path="a property", relative-to="config.dir"

Comment, this is a comment
second line

m*cnmmmt*

v—lenl 3 <test

test="value", test1="valuel", test2="value2", test3="value3", testd="value4"

V—I <test-interface s

Format of the CSV for importing and exporting the exceptions
The CSV fields used to exchange the exception list are:
1. The XPath of the exception.
2. The inclusion criteria as integer:
[. O: exclude (default)

II. 1:exclude with children
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3.

4.

[ll. 2:include

IV. 3:include with children
Type of data mask used:

I.  Use default.

Il. Use a fixed value.

A string value if the fixed value replacement is chosen.

A numeric flag for processing namespaces.
I.  O: do not process namespaces

[I. 1: process namespaces
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When a profile has been created in the interactive anonymized dialog the profile can be used to
process a file without loading it into the editor.

To activate the function use the menu Tools > Anonymize File...

&

» o Anonymize a Fle & &

| Apply |

Source file: | fhome/lbell/devel/qxmledit/wiki/doc/tutorial/anon/data orig.xm | Browse... |

Close |
Profile: |Anon Change...

Anonymized file: |ﬂmpﬂ xml | | Browse... '|

In the anonymize panel you have the following options:

Name Option

Source file Name of the source file to anonymize. Use the “Browse...” button to
select it

Profile The name of the anonymizing profile. Use the “Change..."” button to

select it among the previuosly saved profiles.

Anonymized file Name of the anonymized file. Use the “Browse..." button to select it.
Note that this function will overwrite the file.

At the end of the operation the destination folder can be opened by the panel.

» o QXmiEdit @ &

‘Operation terminated.
Do you want to show the result folder in the browser?

(= ) =
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It is possible to insert a progressive number or alphabetic sequence selecting an element and
triggering the menu "Tools > Fill Serie...". A dialog box will allow to choose the attribute name
that will contain the progression index.

This is the dialog and below each option is explained:

-

x|

Format:

I o — T —

Apply to the children too

Options:

et e

Start number: | 1 i)

v | Overwrite existing values

~
4

(>}

=

Insert Index in Attribute

Attribute: | name|

Unpadded number -

Cancel

+

Insert value at end of existing data
Separator:

Replace existing value

Name

Information

Attribute Name

Name of the attribute that will contain the progression index. If the
attribute does no exists in the element, it will be created.

Start number

The index of the series fill. For the alphabetic enumeration '0" is equivalent
to ‘A

Format

The format of the index. The possible predefined formats are:
Unpadded number (1,2,3)

Padded number (01, 02, 03)

Padded alpha (AA, AB, AC)

Unpadded Alpha (A, B, C)

Overwrite existing values

This option allow the modification of an existing attribute. Without this
authorization, the existing attributes are left untouched.

Insert values at the end of existing
data

If the attribute for the index is existing and overwrite is enabled, the index
will be written before or after the current data.

Replace existing value

Replaces an existing value of the attribute.

Separator

This separator is used when inserting the index into existing data.

Apply to the children too.

Apply recursively the index. Each series restarts from O.
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Cloning Elements

Cloning or replicating elements in the editor using an existing sample is activated by using the menu
Tools > Clone Elements in the 0.9.2 version. Any element can be used as a sample except the
root one.

The only options available to this feature is if to clone only the selected element or even its
children recursively, the number of cloned objects and the use of a counter.

The counter that can be insert in an attribute, existing or created while cloning, is the same that can
be recalled by the “Fill Serie” dialog,

‘ e Clone Element & g

MNumber of clones:

D ook | Cancel

Iﬁdd an index... | | Rermove index|

This picture shows the result of the clone operation with the insert of an index using the "“id”
attribute:

» o QxmlEdit - ~No file-—# RSO XS QXmiEdit - ~No file--# oG e
File Edit Bookmarks XML Navigaton View Sessions Tools Help Fie Edit Bookmarks XML Navigaton View Sessions Tools Help

PHEMADL & Y gt/ -l DEH XD o n Vgl /Y

»

X *Processing Instruction® <?xml  xmi(version="1.0" encoding="UTF-8" encoding:UTF-8 \ *Processing Instruction® <?xml  xml(version="1.0" encoding="UTE-8" encoding:UTF-8
B B
v . <xsdischema  xelnsxsd="http:/fwww.w3.0rg/2001/XMLSchema", elementl [0 Add Child... v . <usdischema  xminsisd="http/www w3.0rg/2001 /XMLSchema”, element [0 Add Child...

- 1 <xsd:annotation 0 T - 1 <xsd:annotation 0 Append

1 <xsd:documentation Sample document. 1 <xsd:documentation  Sample document.

B 2 <xsd:element - 'sample’ name="sample” /Editm - 2 <xsd:element - 'sample’ name="sample" l'/*Edlt—J
- 1 <xsd:complexType # Delete = 1 <xsd:complexType IWLJ
- - = =

1 <xsd:all 1 <xsd:all
1 <xsd:element - 'sample-inner' name="sample-inner", * Move Up i 1 <xsd:element - 'sample-inner' name="sample-inner", * Move Up i
2 <xsd:attribute - 'attribute’ name="attribute”, type="xsd:s |G TP — ‘ I 2 <xsd:attribute - 'attribute’ name="attribute”, type="xsd:s |G Bl Phcunra | 1
e M = ]
—_— ] 3 <xsd:element - 'sample’ name="sample”, id="1" _—
View as XSD... i View as XSD...
|| » 4 <xsd:element - 'sample’ name="sample”, id="2"

t ] 5 <xsd:element - 'sample’ name="sample”, id="3"
B 6 <xsd:element - '

S —

hema/xsd:element

il | oaf ) 4 | o )

Noschema mode:XML = Modifiable I1 Noschema mode:XML = Modifiable I1
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Snippets are pre-configured XML fragments that can be categorized and inserted in the main XML
text. A snippet example can be a resource reference in a J2EE component.

To create a snippet:

select an XML element, then:

* select Transform in Snippet from the context menu

or

* select the XML > Transform in Snippet menu

To insert a snippet in the XML you are editing:

select an XML element that will be the father of the snippet, then:

select the menu XML > Insert Snippet.

in the panel that will appear chose the snippet category from the left, then choose the snippet to

Snippet to insert I

insert.
MName Description | | Ok I
=2
¢ i Context Parameters  web.xml Context Parameters Cancel |
E-a
&b
-c
[=1- web.xml
“ serviet declares a serviet in web.xml
i serviet mapping serviet mapping
i resource-ref declares *source-ref in web.xml
i servie@ servlet definition
i jap fitter jsp fitter
Snippet - fitter mapping JSP filtter mapping
[#- j2ee
category o
=

- jposs-web xml
- resource-ref-jboss
- jhoss

declares a resource-ref in jhoss-web . xml

To edit the snippets and their categories:

1. Select the menu Edit > Configure Snippets
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2. In the panel that will open, insert, modify or delete a snippet at time.

To assign snippets values:

In the edit snippet panel you can supply the following informations:

Name

Information

Name

The name of the snippet

Description

snippet

The description that will be shown when choosing a

Tags

Mame:

Iservlet mapping

Description:

Set of comma separated values that will be used as snippet
categories. A snippet can have more than one category

|servlet magping

Tags (comma separed:)

|j2&ejava,web.xml

created on: Fri Sep 10 21:52:41 2010

Snippet

last modified on: Fri Sep 10 21:53:55 2010

=zerviet-mapping:=
=url-pattern=/ADDRESS=/servlet-class=>
=gerviet-name=SERVLET=/serviet-class=
=zerviet-mapping=
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The metadata records carry information about the data in which it is located without modify the
data itself. QXmlEdit supports descriptive metadata implementing it using an XML processing
instruction whose target is “gxmledit”.

There are two types of metadata: updatable and static.

This kind of metadata carries information about the current state of the document and it can be
automatically updated at each document modification if the relative option is enabled. The data that
can be automatically updated consists of: document creation user and date and the document
revision.

The values contain semantic information and cannot be automatically updated without explicit user
intervention. Some data are predefined, others can be inserted by the user when needed.

The metadata lives on the root level of the XML document. Each metadata record consists of a
Processing Instruction composed by pseudo attributes. The first attribute is always “type“and
denotes the metadata role. The updatable metadata is composed by pseudo attributes that live all
together in a single “info” type. Other metadata uses a single processing instruction having the
attribute “value” for the real data. No entities will be resolved in a metadata pseudo-attribute
except the characters “double quote”, “single quote”, “greater than” and “minor than”, that are
escaped using usual XML entities notation.

The updatable metadata record is inserted manually via menu command. The editable ones are
inserted using a command that insert the updatables ones too.

No metadata is automatically inserted on read.
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When saving, if the option is active, the updatable data are modified. If the metadata record does
not exist in the XML document, it will be inserted if the user gives permission. If only partial
compiled metadata exists, QXmlEdit will complete it. Other unknown metadata information in the
same processing instruction will be preserved for future compatibility. If no creation data exists,
the data will be taken from the file data if available, else they will be created anew.

The metadata can be inserted in an XML document using a menu command or by using a dialog. The
user defined metadata can be handled using the dialog user interface. Malformed data inserted by
hand will be overwritten.

Name Value

creationUser The login name of the user
creationDate The date of the creation
updateUser The login name of the user
updateDate The date of the modification

A progressive value incremented at each

revision o .
writing operation

The values have no special meaning respect to the user defined metadata, however they can be
presented to the user in a configuration dialog.

Predefined data:

Name Value
project

name

copyright

domain

version

Using the menu Edit > Edit Metadata you can open the metadata edit panel. Only updatable
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metadata whose check box is selected will be written into the document.

» Descriptive Metadata ) ()
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When the file in editing declares itself as a XML Schema (XSD) through the root element and its
namespace, the button View as XSD in the main window is enabled. This button leads to a window
that display a graphic view of the file contents.

Alternatively you can display the current XSD file in this manner:

1. Load the XSD file as a normal XML file.

2. Use the menu Tools > Plugins > XsdPlugin

A window will open with the graphical representation of the data:

Search box I

Navigation bar I

(

== all

=/ annotation

= any ‘
= anyAttribute
== appinfo

= attribute

== attributeGroup
= choice

== complexContent
= complexType
= documentation
= glement

= field

= group

= import

=™ include

= key

== keyref

=/ notation

= redefine

=/ schema

== selector

= sequence

= simpleContent
= unigque

ok al

W allNNI

ol annotated

o anyType

‘ attribute

‘ attributeGroup

‘ attributeGroupRef

B blockSet

‘ complexR.. tionType

ol complexType

B derivationSet
element

Ei\'.n Reference to xs:group ﬂ

&\»n Reference to xs:atiributeGroup ”

-

formChoice

simple

( OreducedDenvatlonControI

w

simple

# explicitGroup

Tuna

ext
B for
! ful

'Shows or hides the
navigation bar

W derivationSet
simple

+ | G

g

ﬁ

‘ qruuDRef

\iwleumm\\

n

Graphical view of XSD

types and elements
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The symbols denote:
e E:element
* T:type
e A:attribute

The icons in the elements represent:

lcon ‘ Description
6 There are annotations relative to the element that will be shown in the tooltip.
EI The object is a reference to another one.

In the tools button there is the menu command to open the diagram background inspector. The
settings are immediately applied and saved.

To open the inspector:
Tools button > Configure aspect...

Diagram backgraund sattings

T

alternate: |

Direction: |- Vertical j

Gradient type:

Repeat each: |lOO :‘ |Pi>ce|s j

=TT W TTTT

T

Reset Close
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In the window there are buttons that permit to export the view as PDF or SVG file.

QXmlEdit is targeted to files with dimensions not too big ( < 100 MB). If you need to explore files
very big files, you can enter “Explore Mode” where only the element structure is loaded, without
data and attributes. In this mode, denoted by this icon in the status bar: Q . You cannot edit the

XML document, but you can search in it as usual.
To activate Explore Mode:

e Select the menu File > Explore Structure...
To exit from Explore Mode:

¢ Load another XML file or start a new document.

It is possible to search in external files the occurrences of a given pattern using a fast parser or
group and count elements.

The occurrence count will simply count how many of the elements stated in the search pattern
exist in the file. The grouping show the aggregation occurrences of the elements.

Let's do an example; if the input XML file is like that:

C

K

the number of elements "a’ will be 1, 'b* 2 and 'c’ 3, but if we look at the groups they form, we will
have 1 group composed of one ‘a’ element (the root one), one group of ‘b’ elements (the children of
a ) and two groups of 'c’ elements: one composed by one item (indicated by the green color), and
the other one composed by two items (red color).

To search in files:
¢ Select the menu Tools > Search in Files...

The search window will open:
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Pattern to search

Search in files

Pattern to search infiles:

lalblc

hint: the pattérn to search is like this: la/bic
Eile path: | /homedbellideveligxmiedithsdi

(=)

ountxml .\

Start

File to look into

Start the search

@ Close

| Grouping
Item OCCUTences

Aggregation T 1

2(Tob 7

3| TC ¢ 10

4 g Gr.0-/ahaving count: 1

5 W Gri-/alb having coun i

6 W@ Gr2-/alblc having cgunt 0 i

7 W Gr2-/lalblc having fount 1 <

8 W@ Gr2-/alblc having count 3 2

Results

In this window you can insert the following informations:

Information

Description

Pattern to search

The pattern as XPath (elements only) for example: /a/b/c

File Path Path of the file to search into.
Grouping The scan operation will calculate element groups too.
Start Starts the search operation.

The icons in the result grid have these meanings:

lcon

Description

The item is an occurrence count.

The item is an aggregation report.
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There is the possibility to split a XML file in smaller fragments and/or to examine the fragments
directly in the editor. This feature is handy mainly to explore very big files that does not even fit in
memory.

P i ;
Welcome to GXmlEdit

Welcome to QXmIEdit

You can choose a task clicking the icon:
Examine a XML Schema [XSD) Splita XML file Choose arecent file L7

o

lingiaty
Examine a XML Schema file showing itin a Split a XML file in smaller fragments or Select one of the recentfiles shown in the "Bi
graphical editor. You can printthe schema simply browse it, a fragment at time. list. s

or export it as an image.

Recentfiles list:

~lgxmleditksdiest/dataitest split_badxml 1=
~/gxmleditDeskiop/pom.xml o
~/gxmleditxsd/data/te sipom.xm|

~/gxmleditksd/datafte stimaven-4.0.0 xsd

| Show this window nexttime (you can reactivate this option using the preferences dialog).

@ Close |

When starting, the program will open a welcome dialog leading to the most common operations.
Choose “Split a file". If you choose to hide the dialog next time the program restart and change
your mind, you can reactivate it in the configuration panel. You can access this feature also from the
menu Tools.

Extract Fragments from a XML File

IZI Extract Documents (or scan the file and broswe the single documents)

If you want only navigate the data without creating any file, do not check 'Extract Documents'.
Even if you don't extract the XML fragments into smaller file, QXmLEdit scans the file and records
the information for an interactive review.

Parameters

Source file path: I'ﬁomeilbe\iibeskiopﬂeé{xmiféiandarﬁ.xmi

Split documents using this path | /site/regions/africafitem/n e.g.: felement/child

Browse to the file to examine, the insert the XPath that identifies a fragment. Insert a string of the
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form /ROOT/DATA and so on.

_, Eutract all the documents

* Exfractarange from: 1 'C to: 50000 o

Selecting a range permits to extract only a small subset of the original file. You are not obliged to
waste space on your disk if you want only a single fragment.

Extraction

Extract in the following directory: ’rtmp.iy =

iew in browser
+'| Make subfolders

each: 50 2 files
Subfolder name pattern hdate% v o v | %time% v "_ v | %number% v
File name pattern | %date% v | [ %timess v _ v | [ senumberss v [ v

Enter the location where write the extracted fragments and decide if you want to create a folder
each N files. Decide also how to name the files and the folders. The combo boxes have some
predefined values to ease the task, like a timestamp, or a progressive counter.

encoding:UTF8

T
¥

Current fragment
& |[173 £]| Go

] e——
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After the start of the operation, in the the main window a navigation box appears. The fragments
found in the input file are accessible directly with a random access using the information collected
in the previous phases. If you choose to split the file in fragments, you can examine them in the

extraction directory.

o

Extract Fragments from a XML File

Parameters

Source file path:  testxml

Split documents using this path  /sitefitems/item

e Extract all the documents

__ Extractarange from: 2 to: |
Extraction

Extract in the following directory: |/output

+| Extract documents (or scan the file and broswe the single documents)

| Speed up the processing. No informations will be shown in the user interface.

e.g.: /element/child

=

+| Make subfolders each: 100 | files

Subfolder name paftern = %timestamp% v

File name pattern = %counter% v

View in browser

%counter% v v v

Elements enclosed between '%' characters are system fields

Folder names are like:'1320570825203_1', files like: '1' xmi

¥ 0K @ cancel

lllustration 1: The Extraction Panel

Information in this panel:

Information

Description

Extract documents (or scan the file and browse
the single documents)

If selected the fragments found in the input file will be
written to files as XML documents, one per fragment

Speed up the processing. No information will be
shown in the user interface.

If selected, the extraction process will be faster, but after
the extraction, it will not possible to browse the input file
fragments in real time using the user interface.

Use it if you need the output files only.

Source file path

The path of the input file

Split documents using this path

The XPath used to find the XML fragments in the input file.
The path must be entered using a syntax like this:
/root/element/element

Split using the depth

Use the depth of the element as criterion. Root element
has depth one. Note: the elements will be extracted
independently from their tag.
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Information

Description

Extract all the documents

If selected causes the extraction of all the documents
found in the input file.

Extract a range

If selected, only the documents that fall in the specified
range will be extracted.

Extract in the following directory The destination directory for the fragments.

Make subfolders

With this option the extracted files are created in a
subdirectory when their number exceeds the configured
threshold. Use it when the input file contains thousand of
fragments that will make impossible the browse of the
destination directory if all the files are in a single place.

Subfolder name pattern

The naming to assign to the subdirectories created in the
extraction process.

You can use a predefined token that will be expanded at
run time or any other thing you like.

File name pattern

The naming to assign to the files created in the extraction
process. The files will have a ".xml' suffix automatically
apposed.

You can use a predefined token that will be expanded at
run time or any other thing you like.

Token that can be used in the name pattern section:

Information Description Example Output
scounters The counter of the object created. This is an 1

unique number that can be used to identify the

object
"sdate%s" The current date in the YYYY_MM_DD format 2011_10_-07
"%time%" The current time in HH_MM_SS_millis format 10-43_30_560
"%timestamps" The current date and time in a numeric format 123456789
"%sspaces" A blank space used a separator "

Since 0.6 version.

Flex Code Generation From Balsamiq Source

There is a plugin to generate Flex code from Balsamiq mockup program source. You can choose a
set of source files that will be transformed to a Flex application in the output directory.

Only a subset of Balsamiq controls are supported, controls not supported are converted to

mx:Label

List of supported controls:

* Button

* Label

* LinkBar
* DataGrid
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e List

e TabBar

*  Vrule

*  Hrule

e Textlnput

* ComboBox
* TextArea

e Paragraph

* CheckBox

* RadioButton

e Tree

‘Warning: only a subset of Balsamig objects are supported

Files to translate

homelbelideveligxmledit/gxmledt Ampimytube bmml

homelbelideveligxmledit/igxmleditAmpbownce brmml
homelbelideveligxmledit/igxmledit Ampiribbonla brmml
homelbelideveligxmledit/gxmledt Amp/Comments_List bmml

homelbellideveligxmledit/gxmleditimp/BlogEngine bmml
homelbelideveligxmledit/gxmledittmphres_table brnml

| Qverwrite files

COutput directory:

F.l'ho|neJ1beII.fdevel.l'qx|nIed'rt.l'|na1:en-flex.l'proua.l’srcnnain.l‘flex

Open destination directory

% Apply

E} Close

Sessions are information about a set of files and access dates, related to a work or an activity than
can be recalled if needed. A file can be shared among different sessions, with different accesses.
The sessions can automatically collect information of the files that the program access. Only one
session can be active at time and there is no need to have a session active for QXmlEdit to work.

A session can be active (collecting information), paused or closed.

When sessions are active, there is the possibility to view the most used or recent files or folders in

a list in the main view.

In the main menu the following commands are available:

Command

Information

QXmlEdit user manual, page 79 of 99.




New Creates a new session. The current one, if existing, is closed.

Pause Pauses the current session when active. Paused sessions does not collect informations.
Resume Resumes a paused session.

Close Closes the current session. No session is active, then.

Details Opens a dialog with information on the current session.

Manage Opens a dialog where have information about all the sessions.

The session panel can be shown or hidden using the toolbar button or the command in the View
menu.

The following lists are shown:

* Recent: the most recent files accessed in the session. Double clicking a file opens it in the
editor.

* Most used: the most used files of the session. Double clicking a file opens it in the editor.

* Most recent folders: the most recently used folders containing session related files.
Double clicking a folder entry shows the open file dialog on that folder.

QxmlEdit - thomellbellrdeve iqxm| editixs ditesud ataisdroracle xml m
File Edit Bookmarks XML Navigation View Sessions Tools Help
. - =1 o]l » v 57 |F=E A H
Show or hide ‘
the browser || ==#" € Elements ‘4 Ch. * Size * Attributes ‘Text p encoding:UTF8
X *Processing Instruct xml{version="1.0") Al
Recents v birthdate 3(3) 75 @
oracle.xml (1)
month 0(0) 22 January rd

test_mixed.xml

day 0(0) 13 21 ®

Most used year
oracle.xml (1)
test_mixed.xml (1)

Clicking on the files
opens them in the editor

Most recent folders
= /home/lbell/devel/qxmledit/xs...
L L1 B LEIREAE] /home/Ibell/devel/qxmledit/xsd/test/data/xsd

last access: mercoledi 29 febbraio 2012 21:43:13 CEST

browser
L

— Clicking on the folder,

opens it in the open file dialog

More... [ o LI

No schema ol

Sessions Management Dialog
In this dialog you can view the sessions list. From here you can activate a session or manage
sessions, creating, deleting or editing them. When a session is selected, its accesses and files are
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shown in the lower half of the dialog. The list of files can be copied in the clipboard. Double clicking
on a file loads it in the editor.

The following commands are available:

Command Information
Activate Activates the selected session, closing automatically the current one, if any.
New Creates a new session.
Edit Opens the session detail dialog of the currently selected session.
Delete Delete the currently selected session.
Edit file Loads in the editor the file selected in the lower pane.
Export file data Put in the clipboard the path of the files.
o mmTERT o0 O
Session list
Id Name ¢ Description Created i Last Access ¢ Count! Activate
2 4 | Sessiontwo 27/02/12 20:17 0 Edit...
% 3 |three 21/02/12 22:13 0 Delete
4 2 |uno 20/02/12 21:18 0
Name: one Description: the first session
Files || Accesses |
Path ~ Description Count
/home/lbell/Desktop/test xml/test_mixed.xml 1
/home/Ibell/devel/gxmledit/xsd/test/data/xsd/oracle.xml 1
| Edit file || Export file data |
| €@ Close |

In this dialog you can set the session properties and examine its accesses to files. The name and the
description of a session can be changed and saved.
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Name: one

Description: test on xsd

Last access: 29/02/12 21:42

Files | Accesses

Path ~ Date

1 /home/lbell/devel/qxmledit/xsd/test/data/xsd/oracle.xml| 28/02/12 21:43

Edit file Export file data

¥ OK || @ Cancel

You can set or change the session name and description. The list of files can be copied in the
clipboard. Double clicking on a file loads it in the editor.

Sessions data are stored in the user data folder as indicated by the operating system using a sqlite
database file. To reduce sessions data file dimensions use the configuration dialog. The cleaning
procedure operates as follows:

* Completely erase the data.

¢ Erase sessions data on date criteria.

The following table explains in detail the options:

Option Operation
Delete all sessions data Completely erase the sessions data.
Delete data older than... Delete the data older than the specified date. The data are deleted as follows:

- all the accesses to a file registration older than the specified date.

- all the sessions that have last access date older than the specified date and
have no access data.

If the delete files information is selected, the files information without
access data are deleted. The file themselves are not altered, the operation is

done only on session registration inside QXmlEdit.
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Administraton
v' Enable session management
Delete sessions data

*  Delete data older than one month
_ Delete data older than six maonths
_/ Delete data older than the specified date | 01/01/00 ~
| Delete information on files (the files will not be touched)

Delete sessions data

Delete all sessions data

The session configuration panel allows to enable or disable session handling. There is the
possibility to clean session data as explained in details in the paragraph “Managing sessions data”.

Use the Visualization feature to graphically visualize the composition or the structure of an XML
file. The file can be view as a map; only the summary data are loaded in the program main memory,
so the consumed memory is of the order of magnitude of the data itself.

The data that can be shown are:

1.
2.
3.
4.
5.

Size: size of the elements, attributes and text nodes.
Elements: number of children elements.

Attributes: number of attributes.

Structure: the data can be split on their depth from the root.

Payload: the size of the text nodes children of the elements.

The data values can be cumulative or relative. The cumulative measuring shows the sum of the
quantity associated with a given element and all its children. This kind of measurement gives an
idea of how the hierarchy is structured. The non cumulative measurement spots what elements
have the most relevant values.

The data relevance is underlined using a color map, shown in the dialog itself.
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) Options for Calucation
Load XML file

Measure type

-

XML Data visualization

File: |/homefibell/Desktop/testxml/standard_smal Load Slice at level: | 5 v Cumulative values View as: | Elements v

Data Map

P, Measure i Data

e

Fragments 38

(=]

Size 7148

w

Levels 1

iy

Elements 96

Attributes 20

Lo

Een

Max attributes 1

=)

Max children 16

/s‘: size 1140

v

Zoom: 1 U'i? 100 Export Stats.. Extract fragment Color map; _

€ close ‘

Zoom . Color Map
Numeric values

To access to the Visualization use:
1. The welcome dialog.
2. The Tools > View Data menu.
The operation sequence is as follows:
1. Load a file using the Load file... button.
Choose the measurement type from the View as combo box.
Select the Cumulative values if you want to display cumulative values.
The data are now show.

Select eventually the zoom level.

o vk W N

Explore data hovering with the mouse on the interest points, a tool tip will appears.
7. Use the context menu (right mouse button) to export data.

Checking the “Analyze relations” button will give access to the relations explorer dialog.
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The following measurement types are available:

The size is the size in bytes of the element, its attributes and its text nodes. The cumulative
measurement is the sum of the size of the element and all its children. The root element in the
cumulative mode has the maximum size of all the tree.

To activate the size measurement select Size in the View As combo box.

Note: the calculated size can differ from the physical file because when the data are loaded, the
formatting is discarded.

The payload size is the size in bytes of the text nodes children of an element. The cumulative
measurement is the sum of the payload size of the element and all its children. The root element in
the cumulative mode has the maximum size of all the tree.

To activate the size measurement select Payload in the View As combo box.

The attributes counting is the number of the attributes of each element. The cumulative
measurement is the sum of the number of the attributes of the element and all its children. The
root element in the cumulative mode has the maximum total of all the tree.

To activate the attributes count measurement select Attributes in the View As combo box.

The children element counting is the number of the children of each element. The cumulative
measurement is the sum of the number of the children of the element and all its children. The root
element in the cumulative mode has the maximum total of all the tree.

To activate the elements count measurement select Elements in the View As combo box.

The structure view shows how the elements are divided in blocks using the depth from the root
information independently from the element tag. It shows the relative width of each element at a
given level. There is no cumulative option.

To activate the structure measurement select Structure in the View As combo box.

To change the depth level, use Slice At Level combo box.
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The map exposes the following features in the contextual menu or with mouse hovering.

Command

Information

Copy Data to Clipboard

Copies the current measurement data, relative to the portion of the visible map to
the clipboard. The data consist of an header and the values ordered by row.

Extract this fragment

Opens the extraction dialog with depth and fragment numbers information relative
to the current point.

Copy Path to the Clipboard

Inserts into the clipboard the current element XML path.

Show current element
information

Implemented as a tool tip that appears hovering with the mouse on a point of the
map.

The relations panel shows in graphical form and using a table, the relationship between the nodes.

Graphic view: show the elements existing in the file and their relationships. The elements that
are in relation father-child are connected by a line.

The elements are disposed on the canvas in random position at each invocation. The nodes are
subject to a repulsive force and tend to be distribute evenly in the view.

Data view: show a table of nodes and the number and the type of connected elements.
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Relations

File: fhome/lbell/Desktop/test xml/standard_small.xml

Graphic view | Data view

Force

Force

=C]:I
Radius
I=(::I

Springs
Length

|=C]:l

|| Center selected

Options:
Panel Option Description
Force Force The value of the repulsive force between the nodes.
Force Radius The effective radius of the force.
Spring Length The length of the spring.
Reset Reset the position of the nodes.
Zoom Zoom in Execute a zoom in
Zoom Zoom 1:1 Restore the view to the default size.
Zoom Zoom out Executes a zoom out

The relation panel can be accessed in the following modes:
* To show the data relative to the file loaded in the editor: View->View Relations...

¢ To show the data relative to a file: Tools->Relations...

* To show the data in the map view: check "Analyze relations”, load a file then “View
relations”

QXmlEdit user manual, page 87 of 99.



This dialog permits to encode and decode text from and to base 64 coding, using one of the
common character encodings.

To access Base 64 Explorer:
Menu > Tools > Base 64 Tools...
* To encode text in base 64:
o Write text into the “text” panel. The base 64 coding will appear in the base 64 panel.
* To decode from base 64:
o Choose an encoding using the “encoding” combo box.

o Write or paste the base 64 coded text in the “Base 64" panel. The text will
automatically appear using the selected encoding.

This dialog will permit to see how the text is transformed from unicode to different encodings.

To access the dialog:

Menu > Tools > Encoding Tools...

To explore how a string will be coded in different encodings:
1. Select the tab "String Explorer”.
2. Write the text into the Source Text box.

The encoded text will be displayed in the grid, character by character along its Unicode
value.
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X o

Sourcetext: | jp 4

String Explorer

Character Explorer

Chains Explorer Character Info

Encoding Explorer

@ & e &

Paste here the text
to be examined

1

2

Show how the source text is encoded using different codecs. You can add or remove encodings

3

4

Source text

Unicode value

I150-8859-15

UTF-8

windows-1250
windows-1251

windows-1252

a (LATIN SMALL LETTER A ) | b (LATIN SMALL LETTER B ) ¢ (LATIN SMALL LETTER C ) |d (LATIN SMALL LETTER D)

00061

1: 61

T: 061

1: 061

T: 061

1: 061

00062

1: 62

1: 062

1: (62

1: 062

1: 062

00063

1:0x63

1: 063

1: 0x63

1: 0x63

1: 0x63

00064
1: Ox6d
1: Oxéd
1: Ox64

1: Ox6d

1: Oxéd Remoave

Add an encoding: | Adobe-5Standard-Encoding

~||

Add encodings to the table selecting an encoding from

fod the combea, then triggering "Add™.

| Hexadecimal nurmeric values

| Show character names

To add an encoding to the grid:

Code Pages Detail... ‘

Close

* Select an encoding in the encoding combo box, then trigger add button.

To remove an encoding:

» Select the encoding row, then press Remove button.

You can insert numeric values and examine how they are interpreted by different encodings.

To access this feature:

* Select the “"Character Explorer” tab.
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» Encoding Explorer & @ e &

Source text: | Paste here the text
to be examined

String Explorer Character Explorer Chains Explorer Character Info

Insert numeric values and see how they are interpreted using different encodings.

Hexadecimal values are prefixed by Ox, octals by 0, use a space as separator

Sample: Ox61 98 99 (b4

Nurmeric values: |Oxa3 Oxad Oxa5 0x36| ! Sequence 128.255

Textual representation in different encodings:
1

150-8859-15 | £5¥°

windows-1250 toA;

windows-1251 | ™"

7 i
e £
— Gl

This feature uses the encodings defined in the "String Explorer” tab.

v | Hexadecimal numeric values | v| Show character names Code Pages Detail... Close |

A

Insert the numeric values in the input box, using the prefix “0x" for hexadecimal numbers, “0” for
octal.

To add or remove encodings, use the "String Explorer” tab.

Use “Sequence” button to insert a sequence of 128-255 characters; if you press the Control key
with the “"Sequence” button, the characters from range 32-127 will be inserted.

Select the Chains Explorer tab, select an encoding (up to three are available), then write the
string into source text box.
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The grid will show the string transformation up to three steps.

asdéé
0x61, 0x73, Ox64, Oxe8, Oxe8

asd@
0x61, 0x73, Ox64, Oxef, Oxbf, Oxbd

asddz”™

0x61, 0x73, 0x64, Oxef, Oxbf, Oxbd
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Get information about a character

Select the Character Info tab, select a character using one of the methods:
* Literal character typed in a box.
* Unicode code point written in decimal or hexadecimal.
* Avalue of a given encoding.

You can change the character display using the “Change Font" button.

Ox20ac

Symbol_Currency [ informative 5c)

<unknown>

isPrint
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Using the menu “Tools” > “Code Pages” you can open the code page explorer where you can
examine the code pages supported by QXmlEdit.

The possible operations are:
Change the encoding using the “Encoding” combo box.
Search a character using:
e The literal value.
* The Unicode code point.
The search result will be highlighted in the table and reported in a box.
Option for display of the characters:
Show the UTF-8 encoding.
Show the Unicode name of the character.

Show the value of the character.

» o Code Pages [ORONENE]
&’ Encoding: ‘wmdows'1252 - ‘ { Close
0x01 ox02 0x03 0x04 0x05 [+]
1 (0x1) 2(0x2) 3 (x3) 4 (0xd) 5(0x5)
0x00 Uxx1 U2 Ux3 Uxd U5
<control> START OF HEADING <conirol> START OF TEXT <control> END OF TEXT <conirol> END OF TRANSMISSION <control> ENQUIRY ca
0x01 02 Ox03 0x04 0x05
17 (0x11) 18 (0x12) 19 (0x13) 20(0x14) 21 (0x15)
0x10 Uil Ux12 Ux13 Ux14 Ux15
<control> DEVICE CONTROL ONE | <control> DEVICE CONTROL TWO <control> DEVICE CONTROL <control> DEVICE CONTROL FOUR <control> NEGATIVE <conty
0x11 0x12 THREE 0x14 ACKNOWLEDGE
! . Oy s
33 (0x21) 34(0x22) 35 (0x23) 36 (0x24) 37 (0x25)
0x20 Ux21 Ux22 Ux23 U:x24 Ux25
EXCLAMATION MARK QUOTATION MARK NUMBER SIGN DOLLAR SIGN PERCENT SIGN Options
0x21 022 0x23 0x24 0x25
1 2 3 4 5 UTF-8
49 ((x31) 50(0x32) 51 (0x33) 52 (0x34) 53 (Ix35) Value
0x30 Un31 Ux32 Ux33 U:x34 U35
DIGIT ONE DIGIT TWO DIGIT THREE DIGIT FOUR DIGIT FIVE Name
0x31 32 33 0x34 0x35
A B c D E
65 (0x41) 66 (0x42) &7 (0x43) 68 (0x44) 69 (0x45)
Oxd0 Unxdl Unxd2 U:xd3 U:x44 U:xd5
LATIN CAPITAL LETTER A LATIN CAPITAL LETTER B LATIN CAPITAL LETTER € LATIN CAPITAL LETTER D LATIN CAFITAL LETTERE LA
0x41 042 0x44 045
Q R S T U
81(0x51) 82 (0x52) 83 (0x53) 84 (0x54) 85 (0x55)
0x50 Ux51 U:x52 Ux53 U:x54 Ux55 Saarch a chatacter
LATIN CAFITAL LETTER @ LATIN CAPITAL LETTER R LATIN CAPITAL LETTER § LATIN CAPITAL LETTER T LATIN CAPITAL LETTER U 14
0x51 52 053 0x54 0x55 Q =
b e d e '7‘
98 (0x62) 99 (0x63) 100 (0x64) 101 (0x65) |
U:x62 Uix63 U:x6d4 Ux65 ) Unicode numeric code (hex)
LATIN SMALL LETTER B LATIN SMALL LETTER € LATIN SMALL LETTER D LATIN SMALL LETTER £ L -
062 Ox64 0x65 | ‘
q r s t u Search result:
113 (x71) 114 (0x72) 115 (0x73) 116 (0x74) 117 (0x75) 5
0x70 U1 Ux72 Ux73 Ux74 Ux75
LATIN SMALL LETIER Q@ LATIN SMALL LETTER R LATIN SMALL LETTER 5 LATIN SMALL LETTER T LATIN SMALL LETTER U 4 Position:97 (61)
0x71 0x72 073 074 0x75 Uni :mm
£ ~ | |Name:LATIN SMALL LETTER A
1 1 ! il L4
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The compare operation is started loading a XML Schema file, then selecting the menu operation.
After the compare a window will open, showing the elements with different colors depending on
their state. The comparison can be done taking into account the annotations or not. Even the single
items of restriction enumerators values are shown.

To start the compare operation:
Menu > File > Compare XSD...

Options available: exchange source and reference and compare annotations or not.

Root w =
___|namespacePrefix="xs"

[_|Elements=qualified

stid atabesd/difffe] xsd

L &

Attributes=unqualified

namespace: test string)
namespace: http//www w3 org/2001/XMLSchema

Enumeration:

- "four” (Dele

Extension of 'xsistring’

L8 & 4 & & & & 4 & & & & L LK E L L4

=l
Compara Summary Extension of 'xs:string'
Reference: /home/lbell/devel/gxmledit/xsd/test/d:
Target: /home/lbell/devel/qxmledit/xsd/test/d: ®rsme e

Type |Name = Extension of 'xs:string’
+ {Added
# Modified

restriction

extension

restriction

union

element xxx3

element
notation

LT %” | o

Double click on an iten} to select it in the diagram

Simple type restriction (xs:string) ‘

Enumeration:

=]
Compare

[% <] =] 9]=] Legend: @ Choice £ Sequence (T) ype (E) Element (A) Attribute Legend.  Equals M Deleted  Different M Added | B[] cose

W Compare annotation;

Tools menu

Items, with different colors depending on state

Differences report
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Using the menu Tools > Binary files viewer you can view the raw data of a file. The data can be
decoded in text using one of the supported encoding, but each row of 16 bites is decoded
separately. The input file is divided in pages to not overloading the memory. In this panel you can:

* View the raw data using a text encoding.
* Search text using the selected encoding .

¢ Go to an offset into the file.

x - Binary files viewer o & &

|."mnt."rarndiska’nonamespace.xsd - | |E| | Chiudi

File infarmation

. Search box _

Size: 313 bytes Last updated on: 2:25:35 CET Encoding: | 1SO-8859-15 - |
Page 1 of 1 <@ ||
Search: | | Previous Next
Offset Binary values Characters |
1] 3C 3F 78 6D &6C 20 74 65 72 73 69 &F 6E 3D 22 31 | <?xml version="1

. Select encoding

2E 30 22 20 65 &E &3 &F &4 69 EE 67 3D 22 75 74 | .0" encoding="ut

32 a6 2D 38 22 3F 3E QA 3C 68 &5 60 | f-B"?r.<xs:schem
Raw value
48 &1 20 &5 &6C 65 6D &5 44 &5 &6 |a elementFormDef
&4 41 75 &C 74 3D 22 71 75 &1 &C 49 &4 &9 &5 464 22 | ault="gualified"
80 20 78 6D 6C 6E 73 3A 78 73 3D 22 68 74 74 70 3A xmlns ixs="http:
Q6 2F 2F 77 77 77 2E 77 33 2E 6F 72 67 2F 32 30 30 S w3.0rg, /200
112 31 2F 58 4D 4C 53 43 4B &5 4D 461 22 3E QA 20 20 |1/XMLSchema"=.
128 3C 78 73 3A 65 6C 65 &D 65 6E 74 20 6E 61 4D 65 | <xs:element name
144 3D 22 41 22 3E QA 20 20 20 20 3C 78 73 3A 63 6F |="a"=. <XKS:ICO
140 &0 70 &C 65 78 54 79 70 &5 3E lexType>.
Jump to offset £

/4 Warning: the character representation misleading if the selected encoding is not 8 bit.
o
Go to address: V | ] Hexadecimal value Go
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The single application mode is enabled by default, but can be disabled using an option in the
Options panel.

It consists in opening a local server when starting, After that, if a command line argument is used

by the shell (e.g. the “Open With"” in Windows Exlporer), the arguments are sent to the existing
instance via the local socket.

This section describes the structure of a style file.

A style file is an XML file with the following structure:

Tag name Attributes Child elements
style: *  "name” style name as shown in the *  "keywords”
user interface *  styles”
*  "description”: a description *  "ids"
*  "namespace”: an optional namespace

This element is simply a collection of “style” elements plus one optional “default” that will be used
as default style, if existing.

It contains one “style” element.

Tag name Attributes Child elements

style *  "id" unique identifier of the style. It is
a string

* "color”: hexadecimal representation
of a color used to paint the text.
Example: “FFO000”

*  "backColor": optional, the background
color in hexadecimal format with
optional alpha at the end.

Example: FFOOOO or FFOO0080

*  "family”: font family if different from
default.

* "size": font size if different from
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default.

"bold” set to 'true’ or a numeric value
different from zero to force bold style
on font

“italic”: same of bold, but for italic
style

The only mandatory attribute is id, the others
are activated if set.

This element is simply a collection of “keyword” and “rule” elements

A keyword, with associated style. Each element tag in the data file that is enrolled in this section
will be printed with the indicated style

Tag name Attributes Child elements
keyword *  "keyword"” the name of the element to
mark
*  "idStyle": the identifier of the
associated style

Contains a set of “rule” and “ruleSet” using implicit AND connector

Tag name attributes Child elements
ruleSet *  "connector” the connector of the “rule”, “ruleSet”
children
o and (default)
° or
*  "idStyle": for a top level rule identify
the style to be used
Tag name attributes Child elements
rule * "entity”: denotes and attribute or an | none

element, default: attribute

o attribute

°© element

"name”: if attribute, the name of the
attribute or element
"op”: denotes the comparison
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operator

o EQ:equals

©  NE: not equals

o EX: value exists

©  NX: value non existent

©  GT: greater than

© LT: less than

o  GE: greater or equal

© LE: less or equal

©  SS:substring (string only)
o ST: starts with (string only)

*  "type": type of comparison, optional,
default: string
© s:string
© n:number
©  p: position

*  "value”: the comparison value. If
position, the value should be:
©  numeric
o first (literal)

o last (literal)

*  "case": if the comparisons take the
case of the strings into account,
default: true
© true: case sensitive
o false: not case sensitive

This element is simply a collection of “id"” elements

This element contains the name of attributes whose content will be printed next to element tag

Tag name attributes Child elements

id *  "id" name of the attribute that is
considered as an identifier.

* "alpha”: if true, force the enclosing of
the value between quotes.

This is a complete sample style file:

<?xml version="1.0" encoding="UTF-8"?>
<!-- this is a sample QXmlEdit style file -->
<style name="Log" description="1log test style">

<keywords>
<keyword keyword="resource" idStyle="1"/>
<ruleSet idStyle="2">

<ruleSet connector="and">
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<rule entity="element" op="eq" type="s" value="event"/>
<rule entity="attribute" name="level" op="eq" type="s" value="fatal" case="false" />
</ruleSet>
</ruleSet>
<ruleSet idStyle="3">
<ruleSet connector="or">
<rule name="level" op="eq" type="s" value="ERROR" />
<ruleSet connector="and">
<rule entity="attribute" name="level" op="eq" type="s" value="INF0" case="true" />
<rule name="pri" op="gt" type="n" value="12"/>
</ruleSet>
</ruleSet>
</ruleSet>
<ruleSet idStyle="4">
<rule name="level" op="eq" value="WARNING" case="true" />
</ruleSet>
<ruleSet idStyle="5">
<rule name="level" op="eq" type="s" value="INF0" case="true" />
</ruleSet>
</keywords>

<styles>
<style id="1" color="2080FF" />
<!-- fatal -->
<style id="2" color="FF0000" size="12" family="Arial" bold="true" italic="false" icon=":E:" />
<!-- error -->
<style 1d="3" color="FF4080" size="10" family="Arial" bold="true" italic="false" icon=":E:"/>
<!-- warning -->
<style id="4" color="C0C080" size="10" family="Arial" bold="false" italic="false" icon=":W:"/>
<!-- info -->
<style id="5" color="000000" size="8" family="Arial" bold="false" italic="true" icon=":I:"/>
<default>

<style id="default" color="C0COCO" size="8" family="Arial" bold="false" italic="true"/>
</default>
</styles>

<ids>

<id id="name" alpha="true"/>
<id id="id" alpha=""/>
</ids>

</style>

Installation of new styles

Given that styles are so simple, they can be created by the user with a simple text editor. Styles
are searched in a directory configured via ‘Configure..." menu.
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