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Part I. Using JEdit

This part of the user's guide covers jEdit's text editing commands, along with basic usage of macros and plugins.

This part of the user's guide was originally written by Slava Pestov and is maintained by the jEdit core development
team.




Chapter 1. Conventions

Several conventions are used throughout jEdit's user interface and this manual. They will be described
here. Macintosh users should note how their modifier keys map to the terms used in the manual.

View>Scrolling>Scroll to Current Line

The Scroll to Current Line command contained
in the Scrolling submenu of the View menu.

Edit>GotoLine...

Menu items that end with ellipsis (...) display
dialog boxes.

Cc

The primary modifier key in jEdit. On MacOS
X, thisis actualy the key known as “Command”.
On most other keyboards, thiskey islabelled
“Control”.

The secondary modifier key in jEdit. On MacOS
X, thisis actually the key labelled “ Control”. On
most other keyboards, this key islabelled “Alt”.

The standard “ Shift” key.

C+o

Refersto pressing and holding the Cont r ol key,
pressing and releasing O, and finally releasing the
Control key.

Cre CHj

Refers to holding down Cont r ol , pressing E,
pressing J, and releasing Cont r ol .

Default buttons

In many dialog boxes, the default button (it has a
heavy outline, or a special border, depending on
the current Swing look and feel) can be activated
by pressing Ent er . Similarly, pressing Escape
will usually close adialog box.

Al t -key mnemonics

Some user interface elements (menus, menu
items, buttons) have a certain letter in their label
underlined. Pressing this letter in combination
withthe Al t key activates the associated user
interface widget. The "F10" key can also be
pressed to put focus on the menu bar, it has the
same functionality as the Alt key in Windows.
Note that this functionality is not available on
MacOS X with the “MacOS Adaptive’ look and
feel. See the section called “ The Appearance Pane”
for information on changing the look and feel.

Right mouse button

Used in jEdit to show context-sensitive menus.
If you have a one button Macintosh mouse, a
Cont r ol -click has the same effect.

Middle mouse button

Used by the quick copy feature (see the section
called “Quick Copy”). True 3-button mice are rare
these days. If you have awheel mouse, press down
on the wheel without rolling it. On a Macintosh
with a one-button mouse, Opt i on-click. On other
platforms without a three-button mouse, Al t -
click.




Chapter 2. Starting jEdit

Exactly how jEdit is started depends on the operating system. For example, on Unix you can run “jedit”
at the command line, or select jEdit from a menu; on Windows, you can double-click on the jEdit icon
or select it from the Start menu.

If jEdit is started while another copy is aready running, control is transferred to the running copy,

and a second instance is not loaded. This savestime and memory if jEdit is started multiple times.
Communication between instances of jEdit isimplemented using TCP/IP sockets; the initial instanceis
known as the server, and subsequent invocations are clients.

If you find yourself launching and exiting jEdit alot, the startup time can get a bit bothersome. If the

- backgr ound command line switch is specified, jEdit will continue running and waiting for client
requests even after al editor windows are closed. When run in background mode, you can open and
close jEdit any number of times, only having to wait for it to start the first time. The downside of thisis
increased memory usage.

When running on MacOS X, the - backgr ound command-line switch is active by default, so that
jEdit conforms to the platform convention that programs should stay open until the Quit command is
explicitly invoked by the user, even if al windows are closed. To disable background mode on MacOS
X, usethe- nobackgr ound switch.

For more information about command line switches that control the server feature, see the section called
“Command Line Usage”.

jEdit remembers open buffers, views and split window configurations between editing sessions, so you
can get back to work immediately after starting jEdit. This feature can be disabled in the General pane
of the Utilities>Options dialog box see the section called “The General Pane”.

The edit server and security

Since Java does not provide any interprocess communication facility other than TCP/IP, jEdit
takes extra precautions to prevent remote attacks.

Not only does the edit server pick arandom TCP port number on startup, it also requires that
clients provide an authorization key; a randomly-generated number only accessible to processes
running on the local machine. So not only will “bad guys’ have to guess a 64-bit integer, they will
need to get it right on the first try; the edit server shuts itself off upon receiving an invalid packet.

In environments that demand absolute security, the edit server can be disabled by specifying the -
noser ver command line switch.

Command Line Usage

On operating systems that support a command line, jEdit can be passed various arguments to control its
behavior.

When opening files from the command line, aline number or marker to position the caret on can be
specified like so:

$ jedit MyApplet.java +line: 10
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$jedit thesis.tex +marker:c

Command-line switches begin with a"-". Some take a parameter. A file whose name begins with "-" can
be opened like so:

$jedit -- -nmyfile

Miscellaneous Options

Option Effect

-1 og=l evel Set the minimum log level to an integer between 1 and 9. Default is 7. Has
no effect when connecting to another instance viathe edit server.

- usage Show a brief command line usage message without starting jEdit. This
message is also shown if an invalid switch was specified.

-version Show the version number without starting jEdit.

- nospl ash Don't show the splash screen on startup.

-- Specifies the end of command-line processing. Further parameters are treated
as file names, even if they begin with adash.

Configuration Options

Option Effect

- pl ugi ns Enable loading of plugins. Has no effect when connecting to another instance
viathe edit server. See Chapter 9, Installing and Using Plugins.

- nopl ugi ns Disable loading of plugins. Has no effect when connecting to another
instance viathe edit server.

-restore Restore previously open files on startup. Thisisthe default. This feature can
also be set permanently in the General pane of the Utilities> Options dialog
box; see the section called “ The General Pane”.

-norestore Do not restore previously open files on startup.

-run=script Run the specified BeanShell script. There can only be one of these
parameters on the command line. See the section called “ Running Scripts
from the Command Line”.

-settings=dir Store user-specific settings in the directory named di r , instead of the default
user . hone/ . j edi t . Thedirectory will be created automatically if it
does not exist. Has no effect when connecting to another instance via the edit
server. See the section called “ The jEdit Settings Directory”.

-nosettings Start jEdit without loading user-specific settings.

-startupscripts |Runstartup scripts. Thisisthe default. Has no effect when connecting to
another instance via the edit server. See the section called “ Startup Scripts’.

- Disable startup scripts. Has no effect when connecting to another instance via
nost artupscri pts |theedit server.

Edit Server Options

See Chapter 2, Sarting jEdit for a brief description of the edit server.
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Option

Effect

- backgr ound

Run jEdit in background mode. In background mode, the edit server will
continue listening for client connections even after all views are closed. Has
no effect when connecting to another instance viathe edit server.

- nobackgr ound

Disable background mode. Thisis the default. Has no effect when
connecting to another instance viathe edit server.

-gui Open aninitial view. Thisisthe default. Has no effect when connecting to
another instance via the edit server.
- nogui Do not open an initial view, and instead only open one when the first

client connects. Can only be used in combination with the - backgr ound
switch. Y ou can use this switch to “pre-load” jEdit when you log in to your
computer, for example. Has no effect when connecting to another instance
viathe edit server.

- newpl ai nvi ew

Opens the specified filesin anew plain view. For more information about
views, see the section called “Multiple Views'.

-newi ew Opens the specified filesin anew view.

-reusevi ew Opens the specified filesin an existing view.

-quit Exits the currently running editor instance.

-server Store the server port info in the file named ser ver inside the settings

directory.

-server =nane

Store the server port info in the file named nane. File namesfor this
parameter are relative to the settings directory.

- hoserver Do not attempt to connect to a running edit server, and do not start one
either.
-wai t Keeps the client open until the user closes the specified buffer in the server

instance. Does nothing if passed to the initia jEdit instance. Use this switch
if jEdit is being invoked by another program as an external editor; otherwise
the client will exit immediately and the invoking program will assume you
have finished editing the given file.

Java Virtual Machine Options

To enable AntiAliasing in the TextArea, see the section called “ The Text Area Pane”.

Itis possible to pass command line options to the Java Virtual Machine (JVM). These options can
change certain things about how Java runs, such as the maximum heap size, or whether antialiasing is

used in certain places.

For operating systems such as Linux where jEdit is started via a shell script, you can easily edit the

j edi t script and place VM arguments in the correct place. If you are using the - j ar command line
option with thej ava command to run jEdit (which is how the default shell scripts do it), remember that
the-j ar parameter must bethelast j ava option, followed immediately by the pathtoj edi t . j ar
and then any jEdit command line options.

On aWindowsinstall that usesj Edi t . exe, the VM options are located in a separate file, called
j Edit.14j.ini.Createoreditthisfileinthe samedirectory asj Edi t . exe and place one VM

option per line.

On Mac OS X, the jEdit.app bundle gets VM options from afile called Cont ent s/ | nf 0. pl i st
which can be edited with atext editor.
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There is no complete list of optionstoj ava, sinceit can vary from one platform to another. Some of
can be found by typing the commandsj ava - ? or man j ava. Common JVM options that are used

with jEdit and work on all

platforms are:

Option

Effect

Antialias the text in AWT components.

Dawt . useSyst emAAFpnt Set ti ngs=on

Dswi ng. aat ext =t rug

Antialias the text in Swing components.

-Dj edit. home=/
path/to/jedit

Sets/overrides the java System property j edi t . hone to be the path to the
jEdit install. ThistellsjEdit where to find its site properties, default keymaps,
macros, edit modes, and documentation. Y ou can override this setting to
create a custom install that is shared by multiple users. See the section called
“Site Properties’ for more information.

-nNK768m

Sets maximum heap size to 768 megabytes. Adjust this value depending on
your own personal needs/ plugins. On at least one platform, - Xmx768m
works when - mx768mdoes not (or vice-versa).
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Interface Overview

A View isthe jEdit term for an editor main window. It is possible to have multiple views open at once,
and each View can be split into multiple panes. jEdit remembers the state of open views between editing
Sessions.

An open fileisreferred to as a Buffer. Unlike some editors where each buffer getsits own View, jEdit
completely separates the two concepts. A buffer might be visiblein several views, or none at al.

A TextAreais an editor for abuffer. An EditPane contains a TextArea plus optional buffer switcher. A
View contains one EditPane by default, and additional panes are created whenever the View is split.

The drop-down buffer switcher list at the top of each EditPane shows a BufferSet, or a set of open
buffers (see the section called “Buffer Sets’). Selecting a buffer on thislist will make it visible in the
TextArea. Different emblems are displayed next to buffer namesin the list, depending the buffer's state;
ared disk is shown for buffers with unsaved changes, alock is shown for read-only buffers, and a spark
is shown for new buffers which don't yet exist on disk.

With the new Tango icon theme, these symbols are dlightly different, ared square is shown for buffers
with unsaved changes, alock is shown for read-only buffers, and ayellow square is shown for new
buffers which don't yet exist on disk.

Aswith most other graphical applications, thereisatool bar at the top of the View which provides quick
access to frequently-used commands. Also, clicking the TextArea with the right mouse button displays
a popup menu which also facilitates quick access to various commands. Both the tool bar and the right-
click menu can be completely customized to suit your tastes in the Utilities>Options dialog box; see the
section called “ The Context Menu Pane” and the section called “The Tool Bar Pane”.

Most of the View istaken up by the TextArea. If you've ever used a graphical user interface before, the
TextAreawill beinstantly familiar. Text can be inserted simply by typing. More details on text insertion
and deletion can be found in the section called “Inserting and Deleting Text”.

The strip on the left of the TextAreais called agutter. The gutter displays marker and register locations,
aswell asfolding arrows; it will also display line numbersif the View>Line Number s (shortcut: C+e
C+t ) command is invoked. Note this menu toggle action has the side-effect of changing the persistent
jEdit properties for the Gutter, which can aso be set from the Gutter pane of the Utilities>Options
diaog box.

The gutter is divided into two sections. Right-clicking on the |eft side gives you a context menu, while
right-clicking on the right side (where line numbers might be) toggles a marker at that position. Text can
be selected by left-clicking and dragging on right side of the gutter, over the range of lines you wish to
select.

Multiple Views

As documented at the beginning of this chapter, multiple Views (main windows) can be open at once.
View>New View creates anew View, or main window.

View>New Plain View creates anew View but without any tool bars or dockable windows. This can be
used to open a small window for taking notes and so on.
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View>Close View closes the current View. If only one View isopen, closing it will exit jEdit, unless
background mode is on; see Chapter 2, Sarting jEdit for information about starting jEdit in background
mode.

View>Split Horizontally (shortcut: C+2) splitsthe View into two TextAreas, placed above each other.
View>Split Vertically (shortcut: C+3) splitsthe View into two TextAreas, placed next to each other.
Macr os>I nterface> Splitpane Grow grows the size of the currently focused TextArea.

View>Unsplit Current (shortcut: C+0) removes the split containing the current TextArea only.
View>Unsplit All (shortcut: C+1) removes all splits from the View.

When aView is split, editing commands operate on the TextAreathat has keyboard focus. To give a
TextArea keyboard focus, click in it with the mouse, or use the following commands.

View>Go to Previous Text Area (shortcut: A+PAGE_UP) shifts keyboard focus to the previous
TextArea.

View>Goto Next Text Area (shortcut: A+PAGE_DOWN) shifts keyboard focus to the next TextArea.

Switching Buffers

Each EditPane has an optional drop-down BufferSwitcher at the top. The BufferSwitcher shows the
current buffer and can also be used to switch the current buffer, using menu item commands and their
keyboard shortcuts.

View>Go to Previous Buffer (keyboard shortcut: C+PAGE_UP) switches to the previous buffer in the
list.

View>Go to Next Buffer (keyboard shortcut: C+PAGE_DOWN) switches to the next buffer in the list.

View>Go to Recent Buffer (keyboard shortcut: C+BACK _QUOTE) flips between the two most recently
edited buffers.

View>Show Buffer Switcher (keyboard shortcut: A+BACK QUOTE) has the same effect as clicking on
the buffer switcher combo box.

If you prefer an aternative graphical paradigm for switching buffers, take alook at one of these plugins:
+ BufferList

» BufferSelector

» BufferTabs

If you decide to use one of these plugins, you can hide the popup menu buffer switcher in the View pane
of the Utilities>Options dialog box.

A number of plugins that implement fast keyboard-based buffer switching are available as well:
» FastOpen
* Openlt

» SwitchBuffer
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Buffer Sets

The buffer sets feature helps keep the buffer lists local and manageable when using jEdit in amultiple-
View and multiple-EditPane environment.

As mentioned in the previous section, each EditPane can show a Buffer Switcher, which displays the
contents of a BufferSet. In jEdit 4.2, al EditPane buffer switchers showed the same BufferSet: a global
list of all buffersthat were opened from any EditPane in any View. When using many Views and
EditPanes, thisresulted in large lists of buffers, and made the next/previous buffer actions useless with
many Views, EditPanes and Buffers.

Since jEdit 4.3, it is possible to have more narrow scopes for the BufferSets of an EditPane. This makes
the 'next-buffer' and 'previous-buffer' actions switch between buffers that are local to the view or pane.

The three BufferSet scopes are:
1. Global: Includes al buffers open from any EditPane.

2. View: EditPanesin the same View share the same BufferSet. Opening a buffer in one View will not
affect the other views.

3. EditPane: Each EditPane can have its own independent BufferSet.
Bufferset scope can be set from Utilities >Options > View > Buffer Set scope:.

File > Close removes the current buffer from the EditPane's BufferSet only. If it was the last BufferSet
to contain that buffer, the buffer is also closed.

The File > Close (global) action closes the buffer in al EditPanes, asthe jEdit 4.2 File > Close action
did before.

When Exclusive Buffer sets are enabled, any time abuffer isvisited in one EditPane, it should be
automatically closed in other EditPanes which use a disjoint (non-intersecting) BufferSet.

Close Otherswill clear the BufferSet of the current EditPane by performing a Close on all items except
those buffers which are displayed in another active EditPane.

Switching Bufferset Scopes

The statusbar shows you which BufferSet scopeis active (look for the letter "G", "E" or "V"). Double-
clicking on that will allow you to change the scope without going into global options. The BufferSet
Scope can also be changed from View>Buffer Sets> (Global|View|EditPane) Buffer Set. A changeto
the bufferset scope affects all editpanesimmediately.

Sorting of Buffer Sets and Buffer Switchers

Buffer Switchers and Buffer Sets can be sorted independently. Both can be sorted by name or by path.
Both can be left unsorted. Possibly the most useful combination isto sort the Buffer Switchers and leave
the Buffer Sets unsorted. In this caseg, it is easy to find the buffer to work with in the Buffer Switcher
since the buffer names are sorted alphabetically, and leaving the Buffer Set unsorted means the "go

to previous' and "go to next" actions follow the order in which the buffers were last used rather than

by name. However, some users prefer Buffer Sets to also be sorted by name or path, so jEdit supports
multiple sorting methods.
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Window Docking Layouts

A docking layout is similar to an Eclipse "Perspective” in that it describes a set of dockable windows
that are visible to the user at any given time, hiding the rest.

Various jEdit and plugin windows can be docked into the View for convenience. Dockable windows
have a popup button in their top-left corner. Clicking this button displays a menu with commands for
docking the window in one of four sides of the View.

On each side of the TextArea where there are docked windows, a strip of buttonsis shown. Thereisa
button for activating each docked window, as well as a close box and a popup menu button, which when
clicked shows a menu for moving or undocking the currently selected window. The popup menu also
contains a command for opening a new floating instance of the current window.

The commands in the View>Docking menu move keyboard focus between docking areas.

After you have customized the layout of your dockables and wish to save it for export/import, use the
actions View - Docking - Save/L oad Docking L ayout.

It is possible to configure a Dockable layout for just one or a handful of edit modes. This makes it
possible to save or load your dockable layout with the same keyboard shortcut (or automatically) based
on the edit mode of your current buffer.

It is also possible to save/load alayout for a particular edit mode. The loading and saving can be done
automatically, as configured in the global options docking pane when the mode of the buffer changes, or
manually in response to invoking View - Docking - Save/L oad Docking L ayout for current mode.

Dockable windows can be further configured in the Docking pane of the Utilities>Global Options
dialog box. See the section called “The Docking Pane” for details.

For keyboard/power users

Each dockable has three commands associated with it; oneis part of the menu bar and opens the
dockable. The other two commands are:

» Window Name (Toggle) - opens the dockable window if it is hidden, and hide it if its already
open.

» Window Name (New Floating I nstance) - opens a hew instance of the dockable in afloating
window, regardless of the docking configuration. For example, this can be used to view two
different directories side-by-side in two file system browser windows.

A new floating instance can also be opened from the dockable window's popup menu.

These commands cannot be invoked from the menu bar. However, they can be added to the tool
bar or context menu, and given keyboard shortcuts; see the section called “ The Global Options
Dialog Box”.

The Status Bar

The status bar at the bottom of the View consists of the following components, from left to right:

* Caret position information:

e The offset of the caret from the beginning of the file
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The line number containing the caret
The column position of the caret, with the leftmost column being 1.

If the line contains tabs, the file position (where a hard tab is counted as one column) is shown first,
followed by the screen position (where each tab counts for the number of columns until the next tab
stop).

The percent offset of the caret from the start of the file. Thisis based on the line number of the
caret and the total number of linesin thefile, so thisis the same as the relative position of the right
scroll bar in the main text area.

Double-clicking on the caret location indicator displays the Edit>Go to Line dialog box; see the
section called “Working With Lines’.

» A message area where various prompts and status messages are shown.

» The current buffer's edit mode, fold mode, and character encoding. Double-clicking one of these
displays the Utilities>Buffer Optionsdialog box. For more information about these settings, see:

the section called “ The Buffer Options Dialog Box”
the section called “Edit Modes”
the section called “Folding”

the section called “ Character Encodings’

» A set of flags which indicate various editor features and settings. Clicking each flag will toggle the
feature in question; hovering the mouse over aflag will show atoal tip with an explanation:

Word wrap - see the section called “Wrapping Long Lines’.

Multiple selection - see the section called “Multiple Selection”.
Rectangular selection - see the section called “Rectangular Selection”.
Overwrite mode - see the section called “ Inserting and Deleting Text”.
Line separator - see the section called “Line Separators’.

Buffer Set Scope - see the section called “Buffer Sets”.

» A Task Monitor widget, which spins with activity when a background task is running, and also lists
how many tasks are running. Clicking on thiswill open the Task Monitor dockable (the section called
“Task Monitor, and background I/O tasks”).

» A Java heap memory usage indicator, that shows used and total heap memory, in megabytes. Double-
clicking this indicator opens the Utilities>Troubleshooting>M emory Status dialog box.

The order and visibility of each of the above items can be controlled in the Status Bar pane of the
Utilities>Options dialog box; see the section called “ The Status Bar Pane”.

The Action Bar

The action bar allows amost any editor feature to be accessed from the keyboard.

11
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Utilities>Action Bar (shortcut: C+ENTER) displays the action bar at the bottom of the View and gives
it keyboard focus. The action bar remembers previously entered strings; see Appendix C, History Text
Fieldsfor details.

To use the action bar, input a command and press Ent er . The following commands are supported:

Action invocations

Each menu item and tool bar button is bound to an action. To find out the name of an action, invoke the
menu item or click the tool bar button, and look in the action bar's history.

If asubstring or an action name is entered, pressing Tab shows a popup listing matching actions. An
action can be selected using the Up and Down arrow keys, or by entering more characters of its name.

Pressing Ent er with an incomplete substring invokes the action that would be first in the completion
popup's list.

For example, entering d- o will invoke conbi ned- opt i ons, which has the same effect asinvoking
Utilities> Options.

Buffer-local properties

Entering buf f er . pr opert y=val ue setsthe value of the buffer-local property named pr operty
toval ue. Buffer-local properties are documented in the section called “Buffer-Local Properties’.

For example, entering buf f er . t abSi ze=4 changes the current buffer's tab size to 4.

See the section called “Buffer-Local Properties’ for information about buffer-local properties.

Global properties

Entering pr oper t y=val ue setsthe value of the global property named pr operty toval ue. This
featureis primarily intended to help plugin developers, since the properties jEdit usesto store its settings
are not currently documented.

Command repetition

To repeat acommand multiple times, enter a number in the action bar, then press the key-combination
that invokes the command. For example, “C+ENTER 1 4 C+d” will delete 14 lines; “C+ENTER 9 #”
will insert “##HHAHHA#" in the buffer. Note: The space characters in these examples should not be typed;
they are only here to visually separate the keys to be typed.

If you specify arepeat count greater than 20, a confirmation dialog box will be displayed, asking if you
really want to perform the action. This prevents you from hanging jEdit by executing a command too
many times.
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Creating New Files

File>New (shortcut: C+n) opens a new, empty, buffer. Another way to create anew file isto specify a
non-existent file name when starting jEdit on the command line. A new file will be created on disk when
the buffer is saved for the first time.

Opening Files

File>Open (shortcut: C+o) displays afile system browser dialog box and loads the specified fileinto a
new buffer.

Multiple files can be opened at once by holding down Cont r ol while clicking on them in the file
system browser. The file system browser supports auto-completion; typing the first few characters of a
listed file name will select thefile.

More advanced features of the file system browser are described in the section called “ The File System
Browser (FSB)”.

The File>Recent Files menu lists recently viewed files. When arecent fileis opened, the caret is
automatically moved to its previous location in that file. The number of recent files to remember can be
changed and caret position saving can be disabled in the General pane of the Utilities>Options dialog
box; see the section called “ The General Pane”.

The Utilities>Current Directory menu lists all files and directories in the current buffer's directory.
Selecting afile opensit in abuffer for editing; selecting a directory opensit in the file system browser
(see the section called “The File System Browser (FSB)”).

Note

Files that you do not have write access to are opened in read-only mode, where editing is not
permitted.

Tip
jEdit supports transparent editing of GZipped files; if afile begins with the GZip “magic
number”, it is automatically decompressed before loading and compressed when saving. To

compress an existing file, you need to change a setting in the Utilities>Buffer Options dialog
box; see the section called “ The Buffer Options Dialog Box” for details.

Saving Files
Changed made in a buffer do not affect the file on disk until the buffer is saved.

File>Save (shortcut: C+s) saves the current buffer to disk.

File>Save As renames the buffer and savesit in a new location. Note that using this command to save
over another open buffer will close the other buffer, to stop two buffers from being able to share the
same path name.
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File>Save a Copy As saves the buffer to a different location but does not rename the buffer, and does
not clear the “modified” flag. Note that using this command to save over another open buffer will
automatically reload the other buffer.

File>Save All (shortcut: C+e C+s) saves all open buffersto disk, asking for confirmation first. The
confirmation dialog can be disabled in the General pane of the Utilities>Options dialog box.

Two-Stage Save

To prevent dataloss in the unlikely case that jEdit should crash in the middle of saving afile, filesare
first saved to atemporary file named #f i | ename#save#. If this operation is successful, the original
fileisreplaced with the temporary file.

However, in some situations, this behavior is undesirable. For example, on Unix this creates a new
i-node so while jEdit retains file permissions, the owner and group of thefile arereset, and if it isa
hard link the link is broken. The “two-stage save” feature can be disabled in the General pane of the
Utilities>Options dialog box; see the section called “ The General Pane”.

Autosave and Crash Recovery

The autosave feature protects your work from computer crashes and such. Every 30 seconds, all buffers
with unsaved changes are written out to their respective file names, enclosed in hash (“#") characters.
For example, pr ogr am c will be autosaved to #pr ogr am c#.

Saving a buffer using one of the commands in the previous section automatically deletes the autosave
file, so they will only ever be visible in the unlikely event of ajEdit (or operating system) crash.

If an autosave file is found while a buffer is being loaded, jEdit will offer to recover the autosaved data.

The autosave interval can be changed in the Autosave and Backup pane of the Utilities>Options
dialog box; see the section called “ The Saving and Backup Pane”.

Backups

The backup feature can be used to roll back to the previous version of afile after changes were made.
When abuffer is saved for the first time after being opened, its original contents are “backed up” under a
different file name.

The behavior of the backup feature is specified in the Autosave and Backup pane of the
Utilities>Options dialog box; see the section called “ The Saving and Backup Pane”.

The default behavior isto back up the original contents to the buffer's file name suffixed with atilde
(“~"). For example, afile named paper . t ex isbacked up to paper . t ex~.

» The Max number of backups setting determines the number of backups to save. Setting thisto zero
disables the backup feature. Settings this to more than one adds numbered suffixes to file names. By
default only one backup is saved.

« If the Backup directory setting is non-empty, backups are saved in that location (with the full path
tothe original file under it). Otherwise, they are saved in the same directory asthe original file. The
|atter is the default behavior.

» The Backup filename prefix setting is the prefix that is added to the backed-up file name. Thisis
empty by default.

» The Backup filename suffix setting is the suffix that is added to the backed-up file name. Thisis*“~"
by default.
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» Backups can optionally be saved in a specified backup directory, instead of the directory of the
origina file. This can reduce clutter.

» The Backup on every save option is off by default, which results in a backup only being created
the first time a buffer is saved in an editing session. If switched on, backups are created every time a
buffer is saved.

Line Separators

Unix systems use newlines (\ n) to mark line endingsin text files. The MacOS uses carriage-returns
(\ r ). Windows uses a carriage-return followed by anewline (\ r \ n). jEdit can read and writefilesin all
three formats.

The line separator used by the in-memory representation of file contents is always the newline character.
When afileis being loaded, the line separator used in the file on disk is stored in a per-buffer property,
and al line-endings are converted to newline characters for the in-memory representation. When the
buffer is consequently saved, the value of the property replaces newline characters when the buffer is
saved to disk.

There are several waysto change a buffer'sline separator:
 Inthe Utilities>Buffer Options dialog box. See the section called “The Buffer Options Dialog Box”.
By clicking the line separator indicator in the status bar. See the section called “The Status Bar”.

» From the keyboard, if a keyboard shortcut has been assigned to the Toggle Line Separator command
in the Shortcuts pane of the Utilities> Options dialog box. By default, this command does not have a
keyboard shortcut.

By default, new files are saved with your operating system's native line separator. This can be changed
in the Encodings pane of the Utilities>Options dialog box; see the section called “ The Encodings
Pane’. Note that changing this setting has no effect on existing files.

Character Encodings

A character encoding is a mapping from a set of charactersto their on-disk representation. jEdit can use
any encoding supported by the Java platform.

Buffersin memory are always stored in UTF- 16 encoding, which means each character is mapped to an
integer between 0 and 65535. UTF- 16 isthe native encoding supported by Java, and has alarge enough
range of characters to support most modern languages.

When abuffer isloaded, it is converted from its on-disk representation to UTF- 16 using a specified
encoding.

The default encoding, used to load files for which no other encoding is specified, can be set in the
Encodings pane of the Utilities> Options dialog box; see the section called “The Encodings Pane”.
Unless you change this setting, it will be your operating system's native encoding, for example
MacRonan on the MacOS, wi ndows- 1252 on Windows, and | SO 8859- 1 on Unix.

An encoding can be explicitly set when opening afile in the file system browser's
Commands>Encoding menu.

Note that there is no general way to auto-detect the encoding used by afile, however jEdit supports
"encoding detectors", of which there are some provided in the core, and others may be provided by
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plugins through the services api. From the encodings option pane the section called “ The Encodings
Pane’, you can customize which ones are used, and the order they are tried. Here are some of the
encoding detectors recognized by jEdit:

* BOM: UTF- 16 and UTF- 8Y files are auto-detected, because they begin with a certain fixed
character sequence. Note that plain UTF-8 does not mandate a specific header, and thus cannot be
auto-detected, unlessthefilein questionisan XML file.

e XML-PI: Encodings used in XML fileswith an XML PI like the following are auto-detected:
<?xm version="1.0" encodi ng="UTF-8">

» html: Encodings specified in HTML fileswith acont ent = attribute in amet a element may be
auto-detected:

<ht ml ><head><meta htt p-equi v="Cont ent - Type" content="text/htm ; charset=utf-8">
» python: Python hasits own way of specifying encoding at the top of afile.
# -*- coding: utf-8 -*-

 buffer-local-property: Enable buffer-local properties’ syntax (see the section called “Buffer-Local
Properties’) at the top of the file to specify encoding.

# :encodi ng=I SO 8859- 1:

The encoding that will be used to save the current buffer is shown in the status bar, and can be changed
in the Utilities>Buffer Options dialog box. Note that changing this setting has no effect on the buffer's
contents; if you opened a file with the wrong encoding and got garbage, you will need to reload it.
File>Reload with Encoding is an easy way.

If afileis opened without an explicit encoding specified and it appearsin the recent file list, jEdit will
use the encoding last used when working with that file; otherwise the default encoding will be used.

Commonly Used Encodings

While the world is slowly converging on UTF-8 and UTF-16 encodings for storing text, awide range of
older encodings are still in widespread use and Java supports most of them.

The simplest character encoding still in useis ASCII, or “ American Standard Code for Information
Interchange”. ASCII encodes L atin letters used in English, in addition to numbers and arange

of punctuation characters. Each ASCI| character consists of 7 bits, thereisalimit of 128 distinct
characters, which makesit unsuitable for anything other than English text. jEdit will load and save files
as ASClI if the US- ASCl | encoding is used.

Because ASCI| is unsuitable for international use, most operating systems use an 8-hit extension of
ASCII, with the first 128 values mapped to the ASCII characters, and the rest used to encode accents,
umlauts, and various more esoteric used typographical marks. The three major operating systems all
extend ASCII in adifferent way. Files written by Macintosh programs can be read using the Mac Rorman
encoding; Windows text files are usually stored aswi ndows- 1252. In the Unix world, the 8859 1
character encoding has found widespread usage.

On Windows, various other encodings, referred to as code pages and identified by number, are used to
store non-English text. The corresponding Java encoding nameiswi ndows- followed by the code page
number, for examplewi ndows- 850.
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Many common cross-platform international character sets are also supported; KO 8 R for Russian text,
Bi g5 and GBK for Chinese, and SJ| S for Japanese.

The File System Browser (FSB)

Utilities>File System Browser displays the file system browser. By default, the file system browser
is shown in afloating window. This window can be docked using the commands in its top-left corner
popup menu; see the section called “Window Docking Layouts’.

The FSB can be customized in the Utilities>Options dialog box; see the section called “ The File
System Browser Panes’.

Navigating the File System

The directory to browse is specified in the Path text field. Clicking the mouse in the text field
automatically selectsits contents allowing a new path to be quickly typed in. If arelative path is entered,
it will be resolved relative to the current path. Thistext field remembers previously entered strings; see
Appendix C, History Text Fields. The same list of previously browsed directoriesis also listed in the
Utilities>Recent Directories menu; selecting one opensit in the file system browser.

To browse alisted directory, double-click it (or if you have a three-button mouse, you can click the
middle mouse button as well). Alternatively, click the disclosure widget next to adirectory to list
its contents in place. To browse higher up in the directory hierarchy, double-click one of the parent
directoriesin the parent directory list.

Files and directoriesin thefile list are shown in different colors depending on what glob patterns their
names match. The patterns and colors can be customized in the File System Browser >Color s pane of
the Utilities>Options dialog box.

The Path: Text Box can be used to navigate to a specific directory. Environment variables are expanded
here, allowing for both $VARNAME or %/ARNAMEYGsyntax.

A+Up is akeyboard shortcut that brings you to the parent directory.

A+Left and A+Ri ght navigate back and forward through the visited directory stacks, in a Netscape/
Kongueror/IE like fashion.

To see a specific set of files only (for example, those whose names end with . j ava), enter aglob
pattern in the Filter text field. Thistext fields remembers previously entered strings. See Appendix D,
Glob Patterns for information about glob patterns.

Unopened files can be opened by double-clicking (or by clicking the middle mouse button). Open
files have their names underlined, and can be selected by single-clicking. Holding down Shi f t while
opening afilewill openit in anew view.

Clicking afile or directory with the right mouse button displays a popup menu containing various
commands.

Tip

Thefilelist sorting algorithm used in jEdit handles numbersin file namesin an intelligent
manner. For example, afile named secti on10. xm will be placed after afile named
secti on5. xm . A conventional letter-by-letter sort would have placed these two filesin the
wrong order.
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The Tool Bar

Thefile system browser has atool bar containing a number of buttons. Each item in the Commands
menu (described below) except Show Hidden Files and Encoding has a corresponding tool bar button.

The Commands Menu

Clicking the Commands button displays a menu containing the following items:

Parent Directory - moves up in the directory hierarchy. The Alt+Left arrow keyboard shortcut
achieves the same thing.

Reload Directory - reloads the file list from disk. F5 does this al so.

Root Directory - on Unix, goesto the root directory (/ ). On Windows and MacOS X, listsal
mounted drives and network shares. The forward slash (/) achieves this too.

Home Directory - displays your home directory. Keyboard shortcut: ~

Directory of Current Buffer - displays the directory containing the currently active buffer. Shortcut:

New File (Ctrl+N) - opens new, empty, buffer in the current directory. The file will not actually be
created on disk until the buffer is saved.

New Directory - creates a new directory after prompting for the desired name.
Search in Directory - displays the search and replace dialog box set to search al filesin the current
directory. If afileis selected when this command is invoked, its extension becomes the file name

filter for the search; otherwise, the file name filter entered in the browser is used. See the section
called “ Search and Replace” for details.

Show Hidden Files - togglesif hidden files are to be shown in thefile list.

Encoding - amenu for selecting the character encoding to use when opening files. See the section
called “ Character Encodings’.

The Plugins Menu

Clicking the Plugins button displays a menu containing plugin commands. For information about
plugins, see Chapter 9, Installing and Using Plugins.

The Favorites Menu

Clicking the Favorites button displays a menu showing all files and directoriesin the favorites list. The
Add to Favoritesitem adds the currently selected file to the favoriteslist. If nothing is selected, the
current directory is added. To remove afile from the favorites, invoke Edit Favorites, which will show
the favoriteslist in the file system view, then select Delete from the right-click menu of the entry you
want to remove.

Keyboard Shortcuts

Completion behaves differently in file dialogs than in the stand-alone file system browser window.
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In the file dialog, keyboard input goesin the file name field by default. Pressing Ent er opensthe
file or directory path that is either fully or partially entered in the file name field. Typing the first few
characters of afile's name selectsthat file. If the file namefield is empty and nothing is selected, /
lists the root directory on Unix and the list of drives on Windows. There are two handy abbreviations
that may be used in file paths: ~ expands to the home directory, and - expands to the current buffer's
directory.

For example, to open afile/ hone/ sl ava/ j Edi t / doc/ TODO. t xt , you might enter ~/ j / d/ t 0.

In the stand-al one file system browser, keyboard input is handled dlightly differently. Thereisno file
name field, instead shortcuts are active when the file tree has keyboard focus. Additionally, pressing / ,
~ or - awaysimmediately goes to the root, home and current buffer's directory, respectively.

Reloading From Disk

When aview is brought to the foreground, jEdit checks if any open buffers were modified on disk by
another application. All affected buffers are listed in adialog box. By default, buffers without unsaved
changes are automatically reloaded. This feature can be disabled, or changed to prompt if files should
be reloaded first, in the General pane of the Utilities>Options dialog box; see the section called “The
Global Options Dialog Box”.

File>Reload can be used to reload the current buffer from disk at any other time; a confirmation dialog
box will be displayed first if the buffer has unsaved changes.

File>Reload All discards unsaved changesin all open buffers and rel oad them from disk, asking for
confirmation first.

Task Monitor, and background I/O tasks

To improve responsiveness and perceived performance, jEdit executes all buffer input/output tasks
asynchronously. Plugins should do the same. When atask such asthisisin progress, the status bar
should display the number of running tasks and an icon that spins. If you do not see this, you can add the
widget from the the section called “ The Status Bar Pane”.

The Utilities>Troubleshooting> Task Monitor command displays awindow with more detailed status
information and progress meters for each task. By default, the Task Monitor is shown in afloating
window. Thiswindow can be docked using the commands in its top-left corner popup menu; see the
section called “Window Docking Layouts’. Tasks can be aborted in this window, however note that
aborting a buffer save can result in dataloss.

Printing

File>Print (shortcut: C+p) prints the current buffer.

File>Page Setup displays adialog box for changing your operating system's print settings, such as
margins, page size, print quality, and so on.

The print output can be customized in the Printing pane of the Utilities>Options dialog box; see the
section called “The Printing Pane”. The following settings can be changed:

* Thefont to use when printing.

« If aheader with the file name should be printed on each page.
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« If afooter with the page number and current date should be printed on each page.
* If line numbers should be printed.
« If the output should be color or black and white.

e Thetab size to use when printing - thiswill usually be less than the text area tab size, to conserve
space in the printed output.

* |If folded regions should be printed.

Closing Files and Exiting JEdit

File>Close (shortcut: C+w) closes the current buffer. If it has unsaved changes, jEdit will ask if they
should be saved first.

File>Close All (shortcut: C+e C+w) closes al buffers. If any buffers have unsaved changes, they will
be listed in a dialog box where they can be saved or discarded. In the dialog box, multiple buffersto
operate on at once can be selected by clicking on them in the list while holding down Cont r ol . After
all buffers have been closed, a new untitled buffer is opened.

File>Exit (shortcut: C+q) will completely exit jEdit, prompting if unsaved buffers should be saved first.
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Chapter 5. Editing Text
Moving The Caret

The simplest way to move the caret isto click the mouse at the desired location in the text area. The
caret can also be moved using the keyboard.

The LEFT, RI GHT, UP and DOWN keys move the caret in the respective direction, and the PAGE_UP
and PAGE_DOWN keys move the caret up and down one screen-full, respectively.

When pressed once, the HOVE key moves the caret to the first non-whitespace character of the current
screen line. Pressing it a second time moves the caret to the beginning of the current buffer line. Pressing
it athird time moves the caret to the first visible line.

The END key behavesin asimilar manner, going to the last non-whitespace character of the current
screen ling, the end of the current buffer line, and finally to the last visibleline.

If soft wrap is disabled, a“screen line” isthe same as a“ buffer line”. If soft wrap is enabled, a screen
lineis asection of anewline-delimited buffer line that fits within the wrap margin width. See the section
called “Wrapping Long Lines’.

C+HOVE and C+END move the caret to the beginning and end of the buffer, respectively.

More advanced caret movement is covered in the section called “Working With Words”, the section
called “Working With Lines” and the section called “Working With Paragraphs”.

The Home and End keys

If you prefer more traditional behavior for the HOVE and END keys, you can reassign the
respective keyboard shortcuts in the Shortcuts pane of the Utilities>Options; see the section
called “ The Shortcuts Pane’.

By default, the shortcuts are assigned as follows:

» HOME isbound to Smart Home.

» ENDisboundto Smart End.

+ S+HOME is bound to Select to Smart Home Position.
+ S+ENDisbound to Select to Smart End Position.

However you can rebind them to anything you want, for example, various combinations of the
following, or indeed any other command or macro:

» Goto Start/End of White Space.

+ Goto Start/End of Line.

+ Goto Start/End of Buffer.

» Select to Start/End of White Space .
» Select to Start/End of Line.

» Select to Start/End of Buffer.
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Selecting Text

A selection isablock of text marked for further manipulation. Range selections are equivalent to
selections in most other text editors; they cover text between two pointsin a buffer. In addition to the
standard text-sel ection mode, jEdit also allowsrectangular selections that cover arectangular area
(some text editors refer to these as “ column selections’). Furthermore, several chunks of text can be
selected and operated on simultaneously.

Range Selection

Dragging the mouse creates a range sel ection from where the mouse was pressed to where it was
released. Holding down Shi f t while clicking alocation in the buffer will create a selection from the
caret position to the clicked location.

Holding down Shi f t in addition to a caret movement key (LEFT, UP, HOVE, etc) will extend a
selection in the specified direction.

Edit>Select All (shortcut: C+a) selects the entire buffer.

Edit>M or e Selection>Select None (shortcut: ESCAPE) deactivates the selection.

Rectangular Selection

Dragging with the Cont r ol key held down will create arectangular selection. Holding down Shi f t
and Cont r ol whileclicking alocation in the buffer will create arectangular selection from the caret
position to the clicked location.

Alternatively, invoking Edit>M or e Selection>Rectangular Selection (shortcut: A+\ ) toggles
rectangular selection mode. In rectangular selection mode, dragging the mouse always creates a
rectangular selection, and keyboard commands that would normally create a range selection create a
rectangular selection instead. A status bar indicator is shown when this mode is enabled.

It is possible to select arectangle with zero width but non-zero height. This can be used to insert a new
column between two existing columns, for example. Such zero-width selections are shown as a thin
verticd line.

Inserting text into a rectangular selection repeats the text going down as many times as necessary, and
shifts the selection to the right. This makesit behave like a“tall” caret.

Rectangles can be deleted, copied, pasted, and operated on using ordinary editing commands. If
necessary, rectangular selections are automatically filled in with whitespace to maintain alignment.

Rectangular selections can extend beyond the end of aline into “virtual space”. Furthermore, if
keyboard rectangular selection modeison or if the Cont r ol key isbeing held down, clicking beyond
the end of aline will insert the appropriate amount of whitespace in order to position the cursor at the
clicked location.

Note

Rectangular selections are implemented using character offsets, not absol ute screen positions,
so they might not behave as you might expect if a proportional-width font is being used or if
soft wrap is enabled. The text area font can be changed in the Text Area pane of the Utilities>
Optionsdialog box. For information about soft wrap, see the section called “Wrapping Long
Lines’.
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Multiple Selection

Edit>M or e Selection>M ultiple Selection (keyboard shortcut: C+\ ) turns multiple selection mode
on and off. In multiple selection mode, multiple fragments of text can be selected and operated on
simultaneously, and the caret can be moved independently of the selection. The status bar indicates if
multiple selection mode is active; see the section called “ The Status Bar”.

Various jEdit commands behave differently with multiple selections:

» Commands that copy text place the contents of each selection, separated by line breaks, in the
specified register.

» Commandsthat insert (or paste) text replace each selection with the entire text that is being inserted.

» Commandsthat filter text (such as Spacesto Tabs, Range Comment, Replace in Selection, and so
on) behave asif each block was selected independently, and the command invoked on each in turn.

 Line-based commands (such as Shift Indent L eft, Shift Indent Right, and Line Comment) operate
on each line that contains at least one selection.

» Caret movement commands that would normally deactivate the selection (such as the arrow keys,
while Shi f t isnot being held down), move the caret, leaving the selection as-is.

» Some older plugins may not support multiple selection at all.

Edit>M or e Selection>Select None (shortcut: ESCAPE) deactivates the selection containing the caret, if
there is one. Otherwise it deactivates all active selections.

Edit>M ore Selection>I nvert Selection (shortcut: C+e C+i ) selects a set of text chunks such that all
text that was formerly part of a selection is now unselected, and all text that wasn't, is selected.

Note

Deactivating multiple selection mode while multiple blocks of text are selected will leave the
selectionsin place, but you will not be able to add new selections until multiple selection mode
is reactivated.

Keyboard Focus

When the cursor disappears, that means the text area no longer has focus, and when you type, your
keystrokes are probably going somewhere else, such as a dockable. To ensure that the keyboard is
focused in the textarea, you can aways use the mouse and click in it, but a more keyboard-friendly way
is preferred when you are just about to start typing anyway. For this reason, a number of jEdit's actions
have a side-effect of focusing on the text areaaswell. View - Toggle Full Screen is one example.
Some others are listed below:

From the View - Scrolling submenu:
» Scroll and Center Caret

+ Scroll toLine

From the View - Docking submenu:

e Toggle Docked Areas
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e Closecurrent docking area

In general, jEdit is a keyboard-friendly editor that is also mouse-friendly, so you should never be forced
to use amouse to do anything.

Inserting and Deleting Text

Text entered at the keyboard is inserted into the buffer. In overwrite mode, which can be toggled by
pressing | NSERT, one character is deleted from in front of the caret position for every character that
isinserted. The caret is drawn as a horizontal line while overwrite modeis active. The status bar aso
indicates if overwrite mode is active; see the section called “ The Status Bar” for details.

Inserting text while there is a selection will replace the selection with the inserted text.

When inserting text, the TAB and ENTER keys might not behave entirely like you expect because of
various indentation features; see the section called “ Tabbing and Indentation” for details.

The simplest way to delete text is with the BACKSPACE and DELETE keys. If nothing is selected, they
delete the character before or after the caret, respectively. If a selection exists, both delete the selection.

More advanced deletion commands are described in the section called “Working With Words”, the
section called “Working With Lines” and the section called “Working With Paragraphs’.

Undo and Redo

Edit>Undo (shortcut: C+2z) reverses the most recent editing command. For example, this can be used to
restore unintentionally deleted text. More complicated operations, such as a search and replace, can also
be undone.

If you undo too many changes, Edit>Redo (shortcut: C+e C+z) can restore the changes again. For
example, if some text was inserted, Undo will remove it from the buffer. Redo will insert it again.

By default, the last 100 editsis retained; older edits cannot be undone. The maximum number of undos
and whether undos are reset when a buffer is saved can be changed in the Editing pane of the Utilities>
Options dialog box; see the section called “ The Editing Pane”.

Working With Words

C+LEFT and C+RI GHT move the caret aword at atime. Holding down Shi f t in addition to the above
extends the selection aword at atime.

A single word can be selected by double-clicking with the mouse, or using the Edit>More
Selection>Select Word command (shortcut: C+e w). A selection that begins and ends on word
boundaries can be created by double-clicking and dragging.

C+BACKSPACE and C+DELETE delete the word before or after the caret, respectively.

Edit>Complete Word (shortcut: C+b) locates possible completions for the word at the caret, first by
looking in the current edit mode's syntax highlighting keyword list, and then in the current buffer for
words that begin with the word at the caret. This serves as a very basic code completion feature.

If there is only one completion, it will be inserted into the buffer immediately.

If multiple completions were found, the longest common prefix isinserted into the buffer, and a popup
is shown below the caret position listing the completions.

24



Editing Text

To insert acompletion from the list, either select it using the UP and DOWN keys and press ENTER, press
adigit to insert one of the first ten completions (1 isthe first completion; 9 is the Sth; 0 isthe 10th), or
click the desired completion with the mouse. To close the popup without inserting a completion, press
ESCAPE.

Typing while the popup is visible will automatically update the popup and narrow the set of completions
as necessary.

The default word completion uses the visible buffers (buffers being shown in an EditPane) to find
completions. The set of possible words can be expanded by enabling the Global Options- Text Area
- Complete words from all open buffers option. Setting this option will use all open buffersto search
for possible completions. Note, this can degrade completion performance if many buffers are open.

Edit>Word Count displays a dialog box with the number of characters, words and lines in the current
buffer.

What's a Word?

The default behavior of the C+LEFT, C+RI GHT, C+BACKSPACE and C+DELETE commandsis to stop
both at the beginning and the end of each word. Normally, aword is a sequence of a phanumerics, but
you can add other characters as part of what jEdit considersto be a'word', set on aglobal or mode basis
from Global Options- Editing - Extra Word Characters. In addition, this behavior can be changed
by remapping these keystrokes to alternative actions whose names end with (Eat Whitespace) in the
Shortcuts pane of the Utilities>Options dialog box; see the section called “The Shortcuts Pane”.

Working With Lines

An entire line can be selected by triple-clicking with the mouse, or using the Edit>More
Selection>Select Line command (shortcut: C+e | ). A selection that begins and ends on line
boundaries can be created by triple-clicking and dragging.

Edit>Go to Line (shortcut: C+l ) prompts for aline number and moves the caret there. A relative offset
can be used here, if it is prefixed by a+ or a- sign. So for example - 5 moves the caret up by 5 lines.

Edit>M or e Selection>Select Line Range (shortcut: C+e C+l ) prompts for two line numbers and
selects al text between them.

Edit>Text>Delete Line (shortcut: C+d) deletes the current line.

Edit>Text>Deleteto Start Of Line (shortcut: CS+BACK SPACE) deletes all text from the start of the
current line to the caret.

Edit>Text>Delete to End Of Line (shortcut: CS+DELETE) deletes all text from the caret to the end of
the current line.

Edit>Text>Join Lines (shortcut: C+j ) removes any whitespace from the start of the next line and joins
it with the current line. The caret is moved to the position where the two lines were joined. For example,
if you invoke Join Lineswith the caret on thefirst line of the following Java code:

new W dget ( Foo
. creat eDef aul t Foo()) ;

It will be changed to:

new W dget ( Foo. cr eat eDef aul t Foo() ) ;

25



Editing Text

Working With Paragraphs

Asfar asjEdit is concerned, “paragraphs’ are delimited by double newlines. Thisisalso how TeX
defines a paragraph. Note that jEdit doesn't parse HTML filesfor “<P>" tags, nor does it support
paragraphs delimited only by aleading indent.

C+UP and C+DOWN move the caret to the previous and next paragraph, respectively. Holding down
Shi f t inaddition to the above extends the selection a paragraph at atime.

Edit>M or e Selection>Select Paragraph (shortcut: C+e p) selects the paragraph containing the caret.

Edit>Text>Format Paragraph (shortcut: C+e f) splitsand joinslinesin the current selection to
make it fit within the wrap column position. If nothing is selected, the paragraph containing the caret is
formatted instead. See the section called “Wrapping Long Lines’ for information about word wrap and
changing the wrap column.

Edit>Text>Delete Paragraph (shortcut: C+e d) deletes the paragraph containing the caret.

Wrapping Long Lines

The word wrap feature splits lines at word boundaries in order to fit text within a specified wrap margin.
A word boundary, for the purposes of word wrap, means whitespace. Long lines without whitespace

are currently not wrapped by jEdit. The wrap margin position isindicated in the text are as afaint blue
vertical line. There are two “wrap modes’, “soft” and “hard”; they are described below. The current
wrap mode is shown in the status bar; see the section called “ The Status Bar”. The wrap mode can be
changed in one of the following ways:

* Onagloba or mode-specific basisin the Editing pane of the Utilities> Options dialog box. See the
section called “The Editing Pane”.

* Inthe current buffer for the duration of the editing session,
« By clicking the status bar indicator.

« Inthe Utilities>Buffer Options dialog box. See the section called “ The Buffer Options Dialog
Box”.

« From the keyboard, if a keyboard shortcut has been assigned to the Built-in Command for Toggle
Word Wrap in the Shortcuts pane of Global Options. By default, this command does not have a
keyboard shortcut, or appear in any menu.

* Inthe current buffer for future editing sessions by placing the following in one of thefirst or last 10
lines of the buffer, where node iseither “none”, “soft” or “hard”, and col umm isthe desired wrap
margin:

:wr ap=node: maxLi neLen=col umm:

Soft Wrap

In soft wrap mode, lines are automatically wrapped when displayed on screen. Newlines are not inserted
at the wrap positions, and the wrapping is automatically updated when text is inserted or removed.

If the margin is set to 0, then the width of the text areawindow is used to determine where to wrap lines.
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If end of line markers are enabled in the Text Area pane of the Utilities>Options dialog box, a colon
(“:") is painted at the end of wrapped lines. See the section called “ The Text Area Pane”.

Hard Wrap

In hard wrap mode, inserting text at the end of aline will automatically break the lineif it extends
beyond the wrap margin. Inserting or removing text in the middle of aline has no effect, however
text can be re-wrapped using the Edit>Text>For mat Par agraph command. See the section called
“Working With Paragraphs’.

Hard wrap isimplemented using character offsets, not screen positions, so it might not behave like you
expect if a proportional-width font is being used. The text areafont can be changed in the Text Area
pane of the Utilities>Options dialog box.

Scrolling

If you have a mouse with a scroll wheel, you can use the wheel to scroll up and down in the text area.
Various modifier keys change the action of the wheel:

e Shi ft - movesthe horizontal scrollbar. time.
e Control -scrollsasinglelineat atime.

* Al't - movesthe caret up and down instead of scrolling.

CTRL+SHI FT - scroll apage at atime.
* Al t+Shi ft - extendsthe selection up and down instead of scrolling.
Keyboard commands for scrolling the text area are also available.

View>Scrolling>Scroll to Current Line (shortcut: C+e C+j ) scrollsthe text areain order to make the
caret visible, if necessary. It does nothing if the caret is already visible.

View>Scrolling>Center Caret on Screen (shortcut: C+e  C+n) moves the caret to the linein the
middle of the screen.

View>Scrolling>Line Scroll Up (shortcut: C+QUOTE) scrolls the text area up by one line.
View>Scrolling>Line Scroll Down (shortcut: C+SLASH) scrolls the text area down by one line.
View>Scrolling>Page Scroll Up (shortcut: A+QUOTE) scrolls the text area up by one screenful.
View>Scrolling>Page Scroll Down (shortcut: A+SLASH) scrolls the text area down by one screenful.

The above scrolling commands differ from the caret movement commands in that they don't actually
move the caret; they just change the scroll bar position.

Transferring Text

jEdit provides arich set of commands for moving and copying text. Commands are provided for moving
chunks of text from buffersto registers and vice-versa. A register isaholding areafor an arbitrary
length of text, with a single-character name. Most other programs can only transfer text to and from the
system clipboard; in jEdit, the system clipboard is just another register, with the special name $.
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The Clipboard

jEdit offers the usual text transfer operations, that operate on the $ register.
Edit>Cut (shortcut: C+x) places the selected text in the clipboard and removes it from the buffer.
Edit>Copy (shortcut: C+c) places the selected text in the clipboard and leaves it in the buffer.

Edit>Paste (shortcut: C+v) inserts the clipboard contents in place of the selection (or at the caret
position, if thereis no selection).

The Cut and Copy commands replace the old clipboard contents with the selected text. There are two
alternative commands which add the selection at the end of the existing clipboard contents, instead of
replacing it.

Edit>M ore Clipboar d>Cut Append (shortcut: C+e C+u) appends the selected text to the clipboard,
then removesit from the buffer. After this command has been invoked, the clipboard will consist of the
former clipboard contents, followed by a newline, followed by the selected text.

Edit>More Clipboard>Copy Append (shortcut: C+e C+a) isthe same as Cut Append except it does
not remove the selection from the buffer.

Quick Copy

The quick copy featureis usually found in Unix text editors. Quick copy is disabled by default, but it
can be enabled in the M ouse pane of the Utilities>Options dialog box.

The quick copy feature is accessed using the middle mouse button. If you do not have athree-button
mouse, then either Al t -click (on Windows and Unix) or Opt i on-click (on MacOS X). The quick copy
feature enables the following behavior:

* Clicking the middle mouse button in the text area inserts the most recently selected text at the clicked
location. If you only have a two-button mouse, you can click the left mouse button while holding
down Al t instead of middle-clicking.

 Dragging with the middle mouse button creates a selection without moving the caret. As soon as
the mouse button is rel eased, the selected text isinserted at the caret position and the selection is
deactivated. A message is shown in the status bar while text is being selected to remind you that this
isnot an ordinary selection.

» Holding down Shi f t while clicking the middle mouse button will duplicate text between the caret
and the clicked location.

» Holding down Cont r ol while clicking the middle mouse button on a bracket will insert all text in
that bracket's scope at the caret position.

The most recently selected text is stored in the %oregister.

If jEdit is being run under Java 2 version 1.4 on Unix, you will be able to transfer text with other X
Windows applications using the quick copy feature. On other platforms and Java versions, the contents
of the quick copy register are only accessible from within jEdit.

General Register Commands

These commands require more keystrokes than the two methods shown above, but they can operate on
any register, allowing an arbitrary number of text chunks to be retained at atime.
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Each command prompts for a single-character register name to be entered after being invoked. Pressing
ESCAPE instead of specifying aregister name cancels the operation.

Note that the content of registers other than the clipboard and quick copy register are automatically
saved between jEdit sessions.

Edit>More Clipboard>Cut to Register (shortcut: C+r C+x key) stores the selected text in the
specified register, removing it from the buffer.

Edit>More Clipboard>Copy to Register (shortcut: C+r C+c key) storesthe selected text in the
specified register, leaving it in the buffer.

Edit>M ore Clipboard>Cut Append to Register (shortcut: C+r C+u key) adds the selected text to
the existing contents of the specified register, and removes it from the buffer.

Edit>M ore Clipboar d>Copy Append to Register (shortcut: C+r C+a key) adds the selected text to
the existing contents of the specified register, without removing it from the buffer.

Edit>M ore Clipboar d>Paste from Register (shortcut: C+r C+v key) replaces the selection with the
contents of the specified register.

The following three commands display dialog boxesinstead of prompting for aregister name.

Edit>M ore Clipboar d>Paste Previous (shortcut: C+e C+v) displays adialog box listing the 20 most
recently copied and pasted text strings.

Edit>M ore Clipboar d>Paste Deleted (shortcut: C+e Cty) isnot really aregister command; it
displays adialog box listing the 20 most recently deleted text strings.

Edit>More Clipboar d>View Register s displays adialog box for viewing register contents, including
the clipboard and the quick copy.

Markers
Marker Sets

The MarkerSets plugin is a replacement for the built-in Markers feature of jEdit. Markers saved
with MarkerSets properly update when lines are added or removed from a buffer. Furthermore,
you can see markers from multiple files in the Marker Sets dockable. We recommend you use
that instead of the built-in Markers.

A marker isa pointer to a specific location within a buffer, which may or may not have asingle-
character shortcut associated with it. Markers are persistent; they are saved to. fi | enane. mar ks,
wheref i | ename isthe name of the buffer. (The dot prefix makes the markers file hidden on Unix
systems.) Marker saving can be disabled in the General pane of the Utilities>Options dialog box; see
the section called “The General Pane”.

Markers>Add/Remove Marker (shortcut: C+e C+mm) adds a marker without a shortcut pointing to
the current line. If amarker is aready set on the current line, the marker is removed instead. If text is
selected, markers are added to the first and last line of each selection.

Markers are listed in the M arker s menu; selecting a marker from this menu will move the caret to its
location.

Markers>Go to Previous Marker (shortcut: C+te  C+COVMA) goes to the marker immediately before
the caret position.
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Markers>Go to Next Marker (shortcut: C+te C+PERI OD) goes to the marker immediately after the
caret position.

Markers>Remove All Markersremoves all markers set in the current buffer.

Markers with shortcuts allow for quicker keyboard-based navigation. The following commands all
prompt for a single-character shortcut when invoked. Pressing ESCAPE instead of specifying a shortcut
will cancel the operation.

Markers>Add Marker With Shortcut (shortcut: C+t  key) adds a marker with the specified shortcut.
If marker with that shortcut already exists, it will remain in the buffer but lose its shortcut.

Markers>Go to Marker (shortcut: C+y key) moves the caret to the location of the marker with the
specified shortcut.

Markers>Select to Marker (shortcut: C+u key) creates a selection from the caret location to the
marker with the specified shortcut.

Markers>Swap Caret and Marker (shortcut: C+k  key) moves the caret to the location of the marker
with the specified shortcut, and moves the marker to the former caret position. Invoke this command
multiple timesto flip between two locations in the buffer.

Lines which contain markers are indicated in the gutter with a highlight. Moving the mouse over the
highlight displays atool tip showing the marker's shortcut, if it has one. See the section called “ Interface
Overview” for information about the gutter.

Search and Replace

Searching For Text

Search>Find (shortcut: C+f ) displays the search and replace dialog box.

The search string can be entered in the Sear ch for text field. This text field remembers previously
entered strings; see Appendix C, History Text Fields for details.

If text was selected in the text area and the selection does not span aline break, the selected text
becomes the default search string.

If the selection spans aline break, the Sear ch in Selection and Hyper Sear ch buttons will be pre-
selected, and the search string field will beinitially blank. (See the section called “HyperSearch” for
information about the HyperSearch feature.)

Selecting the I gnor e case check box makes the search case insensitive - for example, searching for
“Hello” will match “hello”, “HELLO” and “HeL10O".

After selecting the Whole word check box, searching respects the Extra word character s setting from
the editing options for recognizing words.

To search for special characters (such as newlines or non-printable characters), inexact sequences
of text, or strings that span multiple lines, we use Regular Expressions. Selecting the Regular
expressions check box allows special characters to be used in the search string. Regular expression
syntax is described in Appendix E, Regular Expressions. If you use (groups) in the search field, you
back-reference them with $1 through $9 in the replace field.

The Backwar d and Forward buttons specify the search direction. Note that regular expressions can
only be used when searching in aforward direction.
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Clicking Find will locate the next occurrence of the search string (or previous occurrence, if searching
backwards). If the K eep dialog check box is selected, the dialog box will remain open after the search
string has been located; otherwise, it will close.

If no occurrences could be found and the Auto wrap check box is selected, the search will automatically
restart from the beginning of the buffer (or the end, if searching backwards). If Auto wrap is not
selected, a confirmation dialog box is shown before restarting the search.

Search>Find Next (shortcut: C+g) locates the next occurrence of the most recent search string without
displaying the search and replace dialog box.

Search>Find Previous (shortcut: C+h) locates the previous occurrence of the most recent search string
without displaying the search and replace dialog box.

Replacing Text

The replace string text field of the search dialog remembers previously entered strings; see Appendix C,
History Text Fields for details.

Clicking Replace & Find will perform areplacement in the current selection and locate the next
occurrence of the search string. Clicking Replace All will replace all occurrences of the search string
with the replacement string in the current search scope (which is either the selection, the current buffer,
or aset of buffers, as specified in the search and replace dialog box).

Occurrences of the search string can be replaced with either areplacement string, or the return value of a
BeanShell script snippet. Two radio buttons in the search and replace dialog box select between the two
replacement modes, which are described in detail below.

Text Replace
If the Text button is selected, the search string is simply replaced with the replacement string.

If regular expressions are enabled, positional parameters ($0, $1, $2, and so on) can be used to insert
the contents of matched subexpressions in the replacement string; see Appendix E, Regular Expressions
for more information.

If the search is case-insensitive, jEdit attempts to modify the case of the replacement string to match
that of the particular instance of the search string being replaced. For example, searching for “label” and
replacing it with “text”, will perform the following replacements:

e “String label” would become “ String text”
» “setl abel” would become “ setText”

* “DEFAULT_LABEL” would become“DEFAULT_TEXT”

BeanShell Replace

In BeanShell replacement mode, the search string is replaced with the return value of a BeanShell
snippet. If you want to use multiple line snippet, enclose your BeanShell in braces. The following
predefined variables can be referenced in the snippet:

* _0 --thetext to be replaced

e 1-_ 9 --if regular expressions are enabled, these contain the values of matched subexpressions.
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BeanShell syntax and features are covered in great detail in Part 111, “Writing Macros’, but here are
some examples:

To replace each occurrence of “Windows” with “Linux”, and each occurrence of “Linux” with
“Windows’, search for the following regular expression:

(W ndows| Li nux)

Replacing it with the following BeanShell snippet:

_1.equal s("Wndows") ? "Linux" : "Wndows"

To convert all HTML tagsto lower case, search for the following regular expression:
<\ S+

Replacing it with the following BeanShell snippet:

_0.toLower Case()

To replace arithmetic expressions contained in curly braces with the result of evaluating the expression,
search for the following regular expression:

\V{(.+?2)\}
Replacing it with the following BeanShell snippet:
eval (_1)

These examples only scratch the surface; the possibilities are endless.

HyperSearch

If the Hyper Sear ch check box in the search and replace dialog box is selected, clicking Find lists all
occurrences of the search string, instead of locating the next match.

By default, HyperSearch results are shown in a floating window. This window can be docked using the
commands in its top-left corner popup menu; see the section called “Window Docking Layouts”.

If the Multipleresults check box is selected in the results window, past search results are retained.
Running searches can be stopped in the Utilities>Tr oubleshooting>1/O Progress M onitor dialog box.

Once the results are shown in the Hypersearch dockable, you can left-click on aresult to jump to the
position, or right-click to see some "hidden actions". From the top tree-node, for example, you can Redo
Hyper search, and Copy to Clipboard.

Multiple File Search

Search and replace commands can be performed over an arbitrary set of filesin one step. The set of files
to search is selected with a set of buttons in the search dialog box.

If the Current buffer button is selected, only the current buffer is searched. Thisis the default behavior.

If the All buffers button is selected, all open buffers whose names match the glob pattern entered in
the Filter text field will be searched. See Appendix D, Glob Patterns for more information about glob
patterns.
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If the Directory radio button is selected, all files contained in the specified directory whose names
match the glob will be searched. The directory to search in can either be entered in the Directory text
field, or chosen in afile selector dialog box by clicking the Choose button next to the field. If the
Sear ch subdirectories check box is selected, all subdirectories of the specified directory will also be
searched. Keep in mind that searching through directories containing many files can take along time.

The Directory and Filter text fields remember previously entered strings; see Appendix C, History Text
Fieldsfor details.

When the search and replace dialog box is opened, the directory and file namefilter fields are set to
their previous values. They can be set to match the current buffer's directory and file name extension by
clicking Synchronize.

Note that clicking the All Buffersor Directory radio buttons also selects the Hyper Sear ch check box
since that is what you would want, most of the time. However, the Hyper Sear ch check box can be
unchecked, for stepping through search resultsin multiple files one at atime.

Two convenience commands are provided for performing multiple file searches.

Sear ch>Sear ch in Open Buffers (shortcut: C+e C+b) displays the search dialog box and selects the
All buffer s button.

Search>Search in Directory (shortcut: C+e C+d) displays the search dialog box and selects the
Directory button.

The Search Bar

The search bar feature provides a convenient way to search in the current buffer without opening the
search dialog box. The search bar does not support replacement or multiple file search. Previously
entered strings can be recalled in the search bar with the Up and Down arrow keys; see Appendix C,
History Text Fields.

By default, the search bar remains hidden until one of the quick search commands (described below) is
invoked; however you can choose to have it always visible in the View pane of the Utilities>Options
dialog box; see the section called “ The View Pane”.

Sear ch>Incremental Search Bar (shortcut: C+COVMA) displays the search bar if necessary, and gives
it keyboard focus.

Search>Incremental Search for Word (shortcut: A+COMVA) behaves like the above command except
it places the word at the caret in the search string field. If this command isinvoked while thereisa
selection, the selection is placed in the search string field instead.

Unless the Hyper Sear ch check box is selected, the search bar will perform an incremental search.

In incremental search mode, the first occurrence of the search string is located in the current buffer

asit isbeing typed. Pressing ENTER and S+ENTER searches for the next and previous occurrence,
respectively. Once the desired occurrence has been located, pressing ESCAPE returns keyboard focus
to the text area. Unless the search bar is set to be always visible (see above), pressing ESCAPE will also
hide the search bar.

Note

Incremental searches cannot be not recorded in macros. If your macro needs to perform
a search, use the search and replace dialog box instead. See Chapter 8, Using Macros for
information about macros.
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Sear ch>Hyper Sear ch Bar (shortcut: C+PERI QD) displays the search bar if necessary, givesit
keyboard focus, and selects the Hyper Sear ch check box. If thiscommand isinvoked while thereisa
selection, the selected text will be searched for immediately and the search bar will not be shown.

If the Hyper Sear ch check box is selected, pressing Ent er in the search string field will perform a
HyperSearch in the current buffer.

Sear ch>Hyper Sear ch for Word (shortcut: A+PERI OD) performs a HyperSearch for the word at the
caret. This command does not show the search bar or give it keyboard focus.




Chapter 6. Editing Source Code
Edit Modes

An edit mode specifies syntax highlighting rules, auto indent behavior, and various other customizations
for editing a certain file type. This section only covers using existing edit modes; information about
writing your own can be found in Part 11, “Writing Edit Modes”.

When afileis opened, jEdit first checks the file name against alist of known patterns. For example,
fileswhose names end with . ¢ are opened with C mode, and files named Makef i | e are opened with
Makefile mode. If a suitable match based on file name cannot be found, jEdit checks the first line of the
file. For example, fileswhosefirst lineis#! / bi n/ sh are opened with shell script mode.

Mode Selection

File name and first line matching is done using glob patterns similar to those used in Unix shells. Glob
patterns associated with edit modes can be changed in the Editing pane of the Utilities> Options dialog
box. Note that the glob patterns must match the file name or first line exactly; so to match files whose
first line contains begi n, you must use afirst line glob of * begi n*. See Appendix D, Glob Patterns
for a description of glob pattern syntax.

The default edit mode for files which do not match any pattern can be set in the Editing pane as well.

The edit mode can be specified manually as well. The current buffer's edit mode can be set on aone-
time basis in the Utilities>Buffer Options dialog box; see the section called “ The Buffer Options
Dialog Box”. To set a buffer's edit mode for future editing sessions, place the following in one of the
first or last 10 lines of the buffer, whereedi t nbde isthe name of the desired edit mode:

:mode=edit node:
Syntax Highlighting

Syntax highlighting is the display of programming language tokens using different fonts and colors. This
makes code easier to follow and errors such as misplaced quotes easier to spot. All edit modes except for
the plain text mode perform some kind of syntax highlighting.

The colors and styles used to highlight syntax tokens can be changed in the Syntax Highlighting pane
of the Utilities> Options dialog box; see the section called “ The Syntax Highlighting Pane”.

Tabbing and Indentation

jEdit makes a distinction between the tab width, which isis used when displaying hard tab characters,
and the indent width, which is used when alevel of indent isto be added or removed, for example by
mode-specific auto indent routines. Both can be changed in one of several ways:

» Onagloba or mode-specific basisin the Editing pane of the the Utilities> Options dialog box. See
the section called “ The Editing Pane”.

* Inthe current buffer for the duration of the editing session in the Utilities>Buffer Options dialog
box. See the section called “ The Buffer Options Dialog Box”.

« Inthe current buffer for future editing sessions by placing the following in one of thefirst or last 10
lines of the buffer, where n is the desired tab width, and mis the desired indent width:
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:tabSi ze=n:i ndent Si ze=m

Edit>I ndent>Shift Indent L eft (shortcut: S+TAB or A+LEFT) removes one level of indent from each
selected line, or the current line if there is no selection.

Edit>I ndent>Shift Indent Right (shortcut: A+RI GHT) adds one level of indent to each selected line, or
the current line if thereis no selection. Pressing Tab while amulti-line selection is active has the same
effect.

Edit>Indent>Remove Trailing Whitespace (shortcut: C+e r) removes all whitespace from the end of
each selected line, or the current lineif there is no selection.

Soft Tabs

Files containing hard tab characters may look less than ideal if the default tab size is changed, so some
people prefer using multiple space characters instead of hard tabs to indent code.

This feature is known as soft tabs. Soft tabs can be enabled or disabled in one of severa ways.

» Onagloba or mode-specific basisin the Editing pane of the Utilities> Options dialog box. See the
section called “ The Editing Pane”.

* Inthe current buffer for the duration of the editing session in the Utilities>Buffer Options dialog
box. See the section called “ The Buffer Options Dialog Box”.

* Inthe current buffer for future editing sessions by placing the following in one of thefirst or last 10
lines of the buffer, wheref | ag iseither “true” or “false”:

:noTabs=f1| ag:

Changing the soft tabs setting has no effect on existing tab characters; it only affects subsequently-
inserted tabs.

Edit>I ndent>Spacesto Tabs converts soft tabs to hard tabs in the current selection, or the entire buffer
if nothing is selected.

Edit>Indent>Tabsto Spaces converts hard tabs to soft tabs in the current selection, or the entire buffer
if nothing is selected.

Elastic Tabstops

Elastic tabstops are an aternative way to handle tabstops. Elastic tabstops differ from traditional fixed
tabstops because columns in lines above and below the "cell" that is being changed are always kept
aligned. Asthe width of text before atab character changes, the tabstops on adjacent lines are also
changed to fit the widest piece of text in that column. It provides certain explicit benefits like it saves
time spent on arranging the code and works seemlessly with variable width fonts.But at the sametime it
can make the code look unorganized on editors that do not support elastic tabstops.

Thisfeature is known as elastic tabstops. Elastic tabstops can be enabled or disabled in one of several
ways:

» Onagloba or mode-specific basisin the Editing pane of the Utilities>Options dialog box. See the
section called “ The Editing Pane”.

* Inthe current buffer for the duration of the editing session in the Utilities>Buffer Options dialog
box. See the section called “ The Buffer Options Dialog Box”.
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« Inthe current buffer for future editing sessions by placing the following in one of thefirst or last 10
lines of the buffer, wheref | ag iseither “true” or “false”’:

s el asti cTabst ops=f1l ag:

Note that this feature does not work with soft tabs. where tabs are emulated as spaces

Automatic Indent

The auto indent feature inserts the appropriate number of tabs or spaces at the beginning of aline. There
are three different indentation schemes to choose from: “full”, “simple”, and “none”. The scheme can be
chosen on aglobal or per-edit mode basis using the Editing pane of the Utilities>Options dialog. It can
also be changed for a specific buffer using the Buffer Options dialog, or with a buffer-local property.
(see the section called “Buffer-Local Properties’)

Automatic Indent Scheme: full

In this default scheme, the amount of indentation inserted is mode-specific. In most edit modes,
the indent of the previouslineis simply copied over. However, in C-like languages (C, C++, Java,
JavaScript), curly brackets and language statements are taken into account and indent is added and
removed as necessary.

The automatic indentation can be triggered by: pressing ENTER (thiswill by default only affect the
indentation of the new line), pressing TAB at the beginning of, or inside the leading whitespace of aline,
entering one the bracket characters defined in the edit mode, pressing one of theel ect ri cKeys for
the current edit mode (more details in the section called “ The PROPS Tag"), or when causing a hard
wrap (see the section called “Wrapping Long Lines").

No matter what automatic indentation scheme is currently active, Edit > Indent > Indent Selected
Lines (shortcut: C+i ) indents all selected lines, or the current line if there is no selection, asif inthe
“full” scheme.

Electric keys

Electric keys cause reapplying of the indentation rules to the current line. Thanks to the electric keysthe
following code fragments are indented properly on-line:

» Java, C: brackets. If indenting brackets are defined for the language, they are implicitly considered
eectric keys. Thus a closing bracket is placed in its correct position immediately after being typed.

» Java, C: labels. Labels end with acolon and the colon isincluded in electric keys for these languages.
With pressing the colon, the lineis reindented and the labels are indented alevel to the left.

e Basic: endi f . Heref letter isan electric key, that makes the line indented to the left.

In jEdit 4 electric keys worked unconditionally. As of jEdit 5 they trigger reindentation only if the
indentation of the line, before pressing akey, is the same as jEdit would indent it using its rules. This
allows for specifying more electric keysin mode files, because they don't cause unwanted indentation
like they did before. Electric keysincluding all letters seem to be good solution for basic-like languages.

Automatic Indent Scheme: simple

In this simplified automatic-indentation scheme, only two actions trigger an indentation: pressing
ENTER, or causing a hard wrap. Only the new line will be indented, and the amount of indentation will
be the same as the previoudly line.
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Automatic Indent Scheme: none

In this automatic indentation scheme, no actionsin the text area will trigger areindentation, and all lines
start completely unindented.

Further customization of automatic indentation

The behavior of the ENTER and TAB keys can be configured in the Shortcuts pane of the
Utilities>Options diaog. box, just as with any other key. The ENTER key can be bound to one of the
following, or indeed any other command or macro:

* Insert Newline.

» Insert Newlineand I ndent, which isthe default. Thisis equivalent to I nsert Newline when using the
indentation scheme “none’”.

The TAB can be bound to one of the following, or again, any other command or macro:
* Insert Tab.

* Insert Tab or Indent, which isthe default. Thisis equivaent to Insert Tab when not using the “full”
automatic indentation scheme.

* Indent Selected Lines. This binding will not respect the selected auto indentation scheme.
See the section called “ The Shortcuts Pane” for details.

Toinsert aliteral tab or newline without performing indentation, prefix the tab or newline with C+e v.
For example, to create a new line without any indentation, type C+e v ENTER.

Commenting Out Code

Most programming and markup languages support the notion of “comments’, or regions of code which
are ignored by the compiler/interpreter. jEdit has commands which make inserting comments more
convenient.

Comment strings are mode-specific, and some in some modes such as HTML different parts of a buffer
can have different comment strings. For example, in HTML files, different comment strings are used for
HTML text and inline JavaScript.

Edit>Sour ce Code>Range Comment (shortcut: C+e C+c) encloses the selection with comment start
and end strings, for example/ * and */ in Javamode.

Edit>Sour ce Code>Line Comment (shortcut: C+e C+k) inserts the line comment string, for example
/1 in Javamode, at the start of each selected line.

Toggling Comments

Y ou might be looking for the actions Toggle Line Comment or Toggle Range Comment.
They are available from the TextTools plugin, not jEdit core.

Bracket Matching

Misplaced and unmatched brackets are one of the most common syntax errors encountered when writing
code. jEdit has several features to make brackets easier to deal with.
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Positioning the caret immediately after a bracket will highlight the corresponding closing or opening
bracket (assuming it is visible), and draw a scope indicator in the gutter. If the highlighted bracket is not
visible, the text of the matching line will be shown in the status bar. If the matching line consists of only
whitespace and the bracket itself, the previous line is shown instead. This feature is very useful when
your codeis indented as follows, with braces on their own lines:

public void someMet hod()

{
i f (i sOK)
{

}

doSonet hi ng() ;

}

Invoking Edit>Sour ce>Go to M atching Bracket (shortcut: C+] ) or clicking the scope indicator in the
gutter moves the caret to the matching bracket.

Edit>Sour ce>Select Code Block (shortcut: C+[ ) selects all text between the closest two brackets
surrounding the caret.

Holding down Cont r ol while clicking the scope indicator in the gutter or a bracket in the text area will
select all text between the two matching brackets.

Edit>Sour ce>Go to Previous Bracket (shortcut: C+e  C+[ ) moves the caret to the previous opening
bracket.

Edit>Sour ce>Go to Next Bracket (shortcut: C+e C+] ) moves the caret to the next closing bracket.

Bracket highlighting in the text area and bracket scope display in the gutter can be customized in the
Text Area and Gutter panes of the Utilities>Options dialog box; see the section called “The Global
Options Dialog Box”.

Tip

jEdit's bracket matching algorithm only checks syntax tokens with the same type as the original
bracket, so for example unmatched brackets inside string literals and comments will be skipped
when matching brackets that are part of program syntax.

Abbreviations

Abbreviations are invoked by typing a couple of letters and then issuing the Edit>Expand
Abbreviation (keyboard shortcut: C+; ), which takes the word before the caret as the abbreviation
name. If that particular abbreviation was not yet set, a dialog will pop up, and you can enter the text to
insert before and after the caret. After the abbreviation is created, it can be viewed or edited from the
Abbreviations pane of the Utilities>Options dialog box; see the section called “ The Abbreviations
Pane”.

Using abbreviations reduces the time spent typing long but commonly used strings. For example,

in Java mode, the abbreviation “sout” is defined to expand to “ System.out.printin()”, so to insert
“System.out.printin()” in a Java buffer, you only need to type “sout” followed by C+; . An abbreviation
can either be global, in which case it can be used in al edit modes, or specific to a single mode.

The Java, VHDL. XML and XSL edit modes include some pre-defined abbreviations you might find
useful. Other modes do not have any abbreviations defined by default.
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Automatic abbreviation expansion can be enabled in the Abbr eviations pane of the Utilities>Options
dialog box. If enabled, pressing the space bar after entering an abbreviation will automatically expand it.

If automatic expansion is enabled, a space can be inserted without expanding the word before the caret
by pressing Cont r ol +EV Space.

Positional Parameters

Positional parameters are an advanced feature that make abbreviations much more useful. The best way
to describe them is with an example.

Java mode defines an abbreviation “F” that is set to expand to the following:
for(int $1 = 0; $1 < $2; $1++)

Expanding F#j #ar r ay. | engt h# will insert the following text into the buffer:
for(int j =0; j < array.length; j++)

Expansions can contain up to nine positional parameters. Note that atrailing hash character (“#') must
be entered when expanding an abbreviation with parameters.

If you do not specify the correct number of positional parameters when expanding an abbreviation, any
missing parameters will be blank in the expansion, and extra parameters will be ignored. A status bar
message will be shown stating the required number of parameters.

Folding

Program source code and other structured text files can be thought of as containing a hierarchy of
sections, which themselves might contain sub-sections. The folding feature lets you selectively hide
and show these sections, replacing hidden ones with a single line that serves as an “overview” of that
section. Folding is disabled by default. To enable it, you must choose one of the available folding
modes.

“Indent” mode creates folds based on a line's |eading whitespace; the more leading whitespace a block
of text has, the further down it isin the hierarchy. For example:

This is a section
This is a sub-section
This is another sub-section
This is a sub-sub-section
Anot her top-1level section

“Explicit” mode folds away blocks of text surrounded with “{{{” and “}}}". For example:

{{{ The first line of a fold.
VWhen this fold is collapsed, only the above line will be visible.

{{{ A sub-section.
Wth text inside it.
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Both modes have distinct advantages and disadvantages; indent folding requires no changes to be
made to a buffer's text and does a decent job with most program source. Explicit folding requires “fold
markers’ to be inserted into the text, but is more flexible in exactly what to fold away.

Some plugins might add additional folding modes; see Chapter 9, Installing and Using Plugins for
information about plugins.

Folding can be enabled in one of several ways.

* Onagloba or mode-specific basisin the Editing pane of the Utilities> Options dialog box. See the
section called “The Editing Pane”.

* Inthe current buffer for the duration of the editing session in the Utilities>Buffer Options dialog
box. See the section called “ The Buffer Options Dialog Box”.

« Inthe current buffer for future editing sessions by placing the following in the first or last 10 lines of a
buffer, where node iseither “indent”, “explicit”, or the name of a plugin folding mode:

: f ol di ng=node:
Warning

When using indent folding, portions of the buffer may become inaccessible if you change
the leading indent of thefirst line of a collapsed fold. If you experience this, you can use the
Expand All Folds command to make the text visible again.

Collapsing and Expanding Folds

Thefirst line of each fold has atriangle drawn next to it in the gutter (see the section called “Interface
Overview” for more information about the gutter). The triangle points toward the line when the fold is
collapsed, and downward when the fold is expanded. Clicking the triangle collapses and expands the
fold. To expand all sub-folds aswell, hold down the Shi f t while clicking.

Thefirst line of acollapsed fold is drawn with a background color that depends on the fold level, and the
number of linesin thefold is shown to theright of the line's text.

Folds can also be collapsed and expanded using menu item commands and keyboard shortcuts.
Folding>Collapse Fold (shortcut: A+BACK SPACE) collapses the fold containing the caret.

Folding>Expand Fold One L evel (shortcut: A+ENTER) expands the fold containing the caret. Nested
folds will remain collapsed, and the caret will be positioned on the first nested fold (if any).

Folding>Expand Fold Fully (shortcut: AS+ENTER) expands the fold containing the caret, also
expanding any nested folds.

Folding>Collapse All Folds (shortcut: C+e c¢) collapses all foldsin the buffer.

Folding>Expand All Folds (shortcut: C+e x) expands all folds in the buffer.

Navigating Around With Folds

Folding>Go to Parent Fold (shortcut: C+e u) moves the caret to the fold containing the one at the
caret position.
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Folding>Go to Previous Fold (shortcut: A+UP) moves the caret to the fold immediately before the
caret position.

Folding>Go to Next Fold (shortcut: A+DOWN) moves the caret to the fold immediately after the caret
position.

Miscellaneous Folding Commands

Folding>Add Explicit Fold (shortcut: C+e a) surrounds the selection with “{{{” and “}}}”. If the
current buffer's edit mode defines comment strings (see the section called “ Commenting Out Code”) the
explicit fold markers will automatically be commented out as well.

Folding>Select Fold (shortcut: C+e s) selectsal lines within the fold containing the caret. Cont r ol -
clicking afold expansion triangle in the gutter has the same effect.

Folding>Expand Folds With Level (shortcut: C+e ENTER key) reads the next character entered at
the keyboard, and expands folds in the buffer with afold level less than that specified, while collapsing
all others.

Sometimesit is desirable to have files open with folds initially collapsed. This can be configured as
follows:

» Onaglobal or mode-specific basisin the Editing pane of the Utilities> Options dialog box. See the
section called “ The Editing Pane”.

* Inthe current buffer for future editing sessions by placing the following in the first or last 10 lines of a
buffer, wherel evel isthedesired fold level:

. col | apseFol ds=l evel :

Narrowing

The narrowing feature temporarily “narrows’ the display of a buffer to a specified region. Text outside
the region is not shown, but is still present in the buffer.

Holding down Al t while clicking afold expansion triangle in the gutter will hide all lines the buffer
except those contained in the clicked fold.

Folding>Narrow Buffer to Fold (shortcut: C+e n n) hidesal lines the buffer except those in the fold
containing the caret.

Folding>Narrow Buffer to Selection (shortcut: C+e n s) hidesall lines the buffer except those in the
selection.

Folding>Expand All Folds (shortcut: C+e Xx) shows lines that were hidden as a result of narrowing.
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The Buffer Options Dialog Box

Utilities>Buffer Options displays adialog box for changing editor settings on a per-buffer basis.
Changes made in this dialog box are not retained after the buffer is closed.

The following settings can be changed here:

» Theline separator (see the section called “Line Separators’)

» The character encoding (see the section called “ Character Encodings’)

* If thefile should be GZipped on disk (see the section called “Opening Files’)

» Whether to show adialog or auto-reload when this buffer'sfile is changed on disk.
» The edit mode (see the section called “Edit Modes’)

» Thefold mode (see the section called “Folding”)

» The automatic indentation scheme (see the section called “ Automatic Indent”)

» Thewrap mode and margin (see the section called “Wrapping Long Lines")

» Thetab width (see the section called “ Tabbing and Indentation”™)

* Theindent width

If soft tabs should be used (see the section called “ Tabbing and Indentation”)

Buffer-Local Properties

Buffer-local properties provide an alternate way to change editor settings on a per-buffer basis. While
changes made in the Buffer Options dialog box are lost after the buffer is closed, buffer-local properties
take effect each time the file is opened, because they are embedded in the file itself.

When jEdit loads afile, it checks the first and last 10 lines for colon-enclosed name/value pairs. For
example, placing the following in a buffer changes the indent width to 4 characters, enables soft tabs,
and activates the Perl edit mode:

;i ndent Si ze=4: noTabs=t r ue: node=per|l :
Adding buffer-local properties to a buffer takes effect after the the buffer is saved and loaded again.

The following table describes each buffer-local property in detail.

Property name Description

col | apseFol ds Folds with alevel of thisor higher will be collapsed when the buffer is
opened. If set to zero, all folds will be expanded initially. See the section
caled “Folding”.

deepl ndent When set to “true”, multiple-line expressions delimited by parentheses are
aigned like so:
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Property name

Description

retVal.x = (int)(horizontal O fset
+ Chunk. of f set ToX(i nf 0. chunks,
of fset));

With this setting disabled, the text would look like so:

retVal.x = (int)(horizontal Ofset
+ Chunk. of f set ToX(i nf 0. chunks,
of fset));

fol di ng The fold mode; one of “none”, “indent”, “explicit”, or the name of a plugin
folding mode. See the section called “Folding”.
i ndent Si ze The width, in characters, of one indent. Must be an integer greater than 0.

See the section called “ Tabbing and Indentation”.

maxLi neLen

The maximum line length and wrap column position. Inserting text beyond
this column will automatically insert aline break at the appropriate position.
See the section called “Inserting and Deleting Text”.

node The default edit mode for the buffer. See the section called “Edit Modes'.

noTabs If set to “true”, soft tabs (multiple space characters) will be used instead of
“real” tabs. See the section called “ Tabbing and Indentation”.

noWr dSep A list of non-alphanumeric characters that are not to be treated as word
separators. Global defaultis*_".

tabSi ze The tab width. Must be an integer greater than 0. See the section called

“Tabbing and Indentation”.

wor dBr eakChar s

Characters, in addition to spaces and tabs, at which lines may be split when
the word wrap mode is set to “hard”. See the section called “Wrapping Long
Lines'.

W ap The word wrap mode; one of “none”, “soft”, or “hard”. See the section called
“Wrapping Long Lines’.
aut ol ndent The automatic indentation scheme; one of “none”, “full”, or “simple’. See

the section called “ Automatic Indent”.

You may see: encodi ng=XXX: inafileasitisabuffer-local property and specifying the character
encoding for thefile. But it is not really a buffer-local property, and behaves differently. It is detected
by buf f er -1 ocal - pr operty detector only if the detector is selected in encoding options. Thus,
it works only at loading, and it must appear near the top of the file. See the section called “ Character

Encodings’.

The Global Options Dialog Box

Utilities>Options displays the options dialog. It has 2 tabs, the first is Global Options. Thistab
contains several options panes, each containing a set of related options. Use the list on the left splitter to
switch between panes. Only panes created by jEdit are described here; Plugin Options panes are created
and documented by the plugins themselves.

The General Pane

The General pane contains various settings, such as the number of recent files to remember, when
to check for changed files, if the recent file list should be sorted, what current locale to use, if caret
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positions or markers in buffers should be saved, if previously open files or split configurations should be
restored on startup, and so on.

If Open Buffers Are Changed On Disk....  If Do Nothing is selected, then modifications from
jEdit will silently clobber changes made from other processes during saves. Don't use this option unless
you know what you are doing! Also, changing this option here only affects newly opened buffers, not
the ones that are currently open. Y ou can also change this setting for individual buffers from Buffer
Options. the section called “ The Buffer Options Dialog Box”

Check for changed buffersupon....  Thisoption allows you choose additional times that jEdit
checks for changed files on disk. For slow or remote file systems, removing unnecessary file status
checks might improve performance. Regardless of the choice here, files are still checked before save,
unless Do Nothing is aso selected for the previous option.

The Abbreviations Pane

The Abbreviations option pane can be used to enable or disable automatic abbreviation expansion, and
to edit currently defined abbreviations.

The combo box labelled “Abbrev set” selects the abbreviation set to edit. The first entry, “global”,
contains abbreviations available in al edit modes. The subsequent entries correspond to each mode's
local set of abbreviations.

To change an abbreviation or its expansion, either double-click the appropriate table entry, or click a
table entry and then click the Edit button. Thiswill display a dialog box for modifying the abbreviation.

The Add button displays a dialog box where you can define a new abbreviation. The Remove button
removes the currently selected abbreviation from the list.

See the section called “ Positional Parameters” for information about positional parametersin
abbreviations.

The Appearance Pane

The Appear ance pane can be used to change the appearance of user interface controls such as buttons,
labels and menus. It can also be used to change the icon set, or look and feel, enable/disable the splash
screen or system tray, and other appearance tweaks. Y ou can also set the number of itemsretained in
history text fields, see Appendix C, History Text Fields.

The Context Menu Pane

The Context M enu option pane edits the text area's right-click context menu. See the section called
“Multiple Views”.

The Docking Pane

The Docking option pane shows a list of available dockables, and allows you to specify docking
locations for each of them. Another way to specify docking locationsis to use the popup menus
associated with each dockable window.

It is possible to configure jEdit to automatically load and/or save Docking L ayouts (similar to eclipse
perspectives) based on the edit mode of your current buffer through the checkboxes in this pane. See the
section called “Window Docking Layouts”.
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jEdit also supports alternate docking frameworks. If the appropriate plugins are installed (Currently only
MyDoggy is available), you can change docking frameworks from here.

The Editing Pane

The Editing option pane contains settings such as the tab size, syntax highlighting and soft tabs on a
global or mode-specific basis.

Changing options from this optionpane does not change XML mode definition files on disk; it merely
writes values to the user properties file which override those set in mode files. To find out how to edit
mode files directly, see Part 11, “Writing Edit Modes’. Some of these options can be further overridden
on an individual file basis through the use of buffer-local properties.

TheFile nane globandFirst |ine gl ob textfieldslet you specify aglob pattern that paths
and first lines of buffers will be matched against to determine the edit mode. See Appendix D, Glob
Patterns for information about glob patterns.

TheExtra Word Char act er s adlowsyou to set the noLi neSep buffer property on a mode-wide
basis, allowing you to define what is considered part of aword when double-clicking on it in the text
area.

TheDeep | ndent option instructs jEdit to indent subsegquent lines so that they line up with the open
bracket on the previous line.

The Encodings Pane

This option pane offers users of jEdit many flexible options for defining how Encodings are handled in
jEdit. See the section called “ Character Encodings’ for the basics.

The default line separator character (see the section called “Line Separators’) can be set from here.
Use autodetection when possible is an option you can switch on or off.

Theli st of Encodi ng Aut odetector Names canbeused to control what encoding
detections are used on each file when it is loaded. The order they appear in thislist determines the order
of detectors that are tried. There are some detectors which are available with jEdit core:

* BOM detects Byte Order Mark.
e XML- Pl : detects encoding declaration in XML Processing Instruction.
o htm : detects charset descriptionin HTML META element.

» pyt hon: detects various encoding declaration accepted in Python. This accepts encoding
declarations for GNU Emacs or Bram Moolenaar's VIM.

» buffer-1ocal - property: detects same syntax described at the section called “Buffer-Local
Properties’ for property name "encoding". Note that unlike other buffer-local properties, this one will
not work unlessit is at the top of the file, and this appearsin the list of encoding detectors.

Others can be defined in plugins as services and added to this space-separated list. See
EncodingDetector for details on how to offer additional encoding autodetector.

Theli st of Fallback Encodi ngs isused when afilefailsto open in the default encoding, and
the Encoding Autodetectors also fail. The list order here determines the order of encodings that are tried.
Each is separated by a space. Thisis especially handy when doing directory searches through files of
different encodings. We suggest using UTF- 8 as either your default or one of the fallback encodings.
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While jEdit allows you to edit filesin avariety of different encodings, the average user switches
between only 2 or 3. In other parts of jEdit, where the list of encodingsis displayed in a combobox
(such as the buffer options) or amenu (such as File - Reload with Encoding submenu) it may be
desirable to display only a subset of available encodings, those that are in common local use. The
Encodings checkbox list allows the user to select the subset of supported encodings to display in other
GUI components that list all of the encodings.

The Gutter Pane

The Gutter option pane contains settings to customize the appearance of the gutter. Y ou can customize
values such as "minimal number of digitsto reserve for line numbers', and "fold style". See the section
called “Interface Overview”.

The Mouse Pane

The M ouse option pane contains settings for toggling drag and drop of text, as well as gutter mouse
click behavior.

The only option that may not be self-explanatory is the Double-Click drag joins non-alphanumeric
characters. This option means that double-click will select aregion that includes the non-alphabetical
characters, as defined for the current mode. The actual set of characters can be defined for an indiviual
file via buffer-local properties (noWor dSep) or on a mode-wide basis from the Editing option pane
(Extra Word Char act ers).

The Plugin Manager Pane

The Plugin Manager pane contains a chooser for the desired download mirror, as well as various
settings such as the directory where plugins are to be installed. In addition, you can set the time
in minutes that the pluginlist can be cached from jedit.org, helping to reduce the server load. See
Chapter 9, Installing and Using Plugins.

If the option Disable Obsolete Pluginsis checked, then plugins that were released on Plugin Manager
will be checked against the plugins you have installed, for those with a maximum jEdit version that
islower than the one you are running. Plugins are marked with a maximum jEdit version when they
are found to be broken or somehow incompatible with a given jEdit release. Until an update is made
available for such a plugin on Plugin Manager, these plugins are automatically unloaded and marked
unsupported. This should improve the stability of jEdit.

If you re-enable a plugin that was disabled this way, it will remain loaded until the next time the plugin

list is checked - whenever the user selects the Update or Install tab from Plugin Manager. If you un-
check this option, then plugins will not be automatically disabled in thisway.

The Printing Pane

The Printing option pane contains settings to control the appearance of printed output. Workarounds
that might be needed for your Java version to print correctly can also be enabled here. See the section
called “Printing”.

The Proxy Servers Pane

The Proxy Servers option pane lets you specify HTTP and SOCKS proxy serversto use when jEdit
makes network connections, for example when downloading plugins.
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The Saving and Backup Pane

The Saving and Backup option pane contains settings for the autosave and backup features. See the
section called “ Autosave and Crash Recovery” and the section called “Backups'.

The Shortcuts Pane

The Shortcuts option pane associates keyboard shortcuts with commands. Each command can have up
to two shortcuts associated with it, and each shortcut can be a single or multiple key sequence.

jEdit 5 introduces a new feature known as "keymaps'. Each keymap is a named set of keyboard shortcut
mappings. Default keymaps are found in jEdit'skeymaps folder, and user customized keymaps are are
stored in the user settings keymaps folder.

The top combobox allows you to Choose a Keymap, or a set of shortcuts. The "imported” keymap is
automatically created and selected when jEdit needsto initially create a"keymaps' user settings folder.
At this point, jEdit imports the existing shortcuts and places them into "imported". This makesit easy to
bring in shortcuts from properties files that were customized with jEdit 4.5 or earlier.

If akeymap of the same name exists in the defaults and the user settings directory, the user versionis
the onethat is used in favor of the default. To take an existing keymap and customize it, select it, click
duplicate and you will be asked for the name of the new keymap. A copy of that keymap will be saved
in the user settings keymaps directory. At this point, this keymap will be selected and will determine
where new shortcut properties are stored. To remove all customizations and restore a default keymap,
click reset.

The combo box below the keymap selector selects the command set to edit. Command sets exist for the
set of al built-in commands, the commands of each plugin, and the set of macros.

To change a shortcut, click the appropriate table entry and press the keys you want associated with that

command in the resulting dialog box. The dialog box will warn you if the shortcut is already assigned.
The properties will be saved in the currently selected keymap.

The Status Bar Pane

The Status Bar, its API, and its corresponding option pane contains settings to customize which widgets
are in the status bar, their order, and what separators exist between them. Also, you can disable it
completely, for regular and/or plain views. See the section called “ The Status Bar”.

From the Opt i ons tab, you can customize information about the caret display in the lower left corner.

Selecting the W dget s tab of this option pane shows you what widgets on the right, and their order.
Y ou can add or remove widgets and separators/labels here.

The Syntax Highlighting Pane

The Syntax Highlighting pane can be used to customize the fonts and colors for syntax highlighting.
See the section called “ Syntax Highlighting”.

The Text Area Pane

The Text Area pane contains settings to customize the appearance of the text area.
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Y ou can configure the Text Font, antialias settings, colors, cursor style, highlight matching, and word-
completion settings from here.

Fractional Font Metricsisan old option that helps with certain versions of Java, but usually not in
combination with subpixel antialiasing.

Additional Fontswith font substitution if checked, shows alist of Preferred fonts, aswell asthe
following option. Fonts added to this list will determine the order jEdit searches for glyphs that may be
missing from your chosen Text Font.

If the Font Substitution: Search all system fonts option is checked, all of the installed fonts are
searched for glyphs, after the preferred list is searched. If this option is checked, no fonts need to be
added to preferred fonts list. Y ou probably don't want to un-check either of these options unless you
want to test a system with limited fonts.

The Tool Bar Pane

The Tool Bar option pane lets you edit the tool bar, or disable it completely. See the section called
“Multiple Views”.

The View Pane

The View option pane lets you change various settings related to the editor main window appearance,
including the arrangement of dockable windows, whether the search bar and buffer switcher are
visible, and whether menu, toolbar, and statusbar are visible in full-screen mode. See the section called
“Multiple Views”.

Y ou can choose the default bufferset scope here, as well as whether/how you want buffersets to be
sorted in buffer switchers. See the section called “ Buffer Sets’ for more details.

If Abbreviate pathswith environment variables when possible is checked, you will notice that
jEdit displays abbreviated versions of file paths when it can, using $VARI ABLE/ nane. ext or
%/ARI ABLE% nane. ext syntax, depending on your platform. Abbreviating isused in the File
System Browser, as well asin the window title, and in plugins, to save horizontal space. Reverse-
expansions also work as you would expect them to, with both syntaxes recognized on both platforms.

The File System Browser Panes

The File System Browser group contains two option panes, General and Colors. The former contains
various file system browser settings. The latter configures glob patterns used for coloring thefile list.
See the section called “ The File System Browser (FSB)” for more information.

The jEdit Settings Directory

jEdit stores settings, keymaps, macros, and plugins as files inside the settings directory. In most cases,
editing these files by hand is not necessary, since graphical tools and editor commands can do the job.
However, being familiar with the structure of the settings directory still comesin handy in certain
situations, for example when you want to copy jEdit settings between computers.

The location of the settings directory is system-specific Litis printed to the activity log
(Utilities>Troubleshooting>Activity L og). For example:

LonLinux, itis~/ . j edi t . On Windows, you will find it in YAPPDATA% j Edi t . Onthe Mac, itis~/ Li brary/j Edit.
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[message] jEdit: Settings directory is /home/slaval.jedit

Another way to find the location of your settings directory isto use the "Utilities" menu, then the
"Settings Directory" menu item. The first item in the pullout menu is the location of your settings
directory.

Specifying the - set t i ngs switch on the command line instructs j Edit to store settingsin a directory
other than the default. For example, the following command will instruct jEdit to store al settingsin the
j edi t subdirectory of the C. drive:

C\jedit> jedit -settings=C\jedit

The- noset t i ngs switch will force jEdit to not look for or create a settings directory; default settings
will be used instead.

jEdit creates the following files and directoriesinside the settings directory; plugins may add more:

abbr evs - aplain text file which stores all defined abbreviations. See the section called
“Abbreviations”.

activity. | og-aplaintext file which contains the full activity log. See Appendix B, The Activity
Log.

hi st ory - aplain text file which stores history lists, used by history text fields and the Edit>Paste
Previous command. See the section called “ Transferring Text” and Appendix C, History Text Fields.

j ar s - thisdirectory contains plugins. See Chapter 9, Installing and Using Plugins.

j ar s- cache - thisdirectory contains plugin cache files which decrease the time to start jEdit. They
are automatically updated when plugins are installed or updated.

keymaps - thisdirectory contains collections of named keyboard shortcuts which can be defined
from the Shortcuts Option Pane (see the section called “ The Shortcuts Pane”).

kil'lring.xm - storesrecently deleted text. See the section called “Transferring Text”.
macr os - thisdirectory contains macros. See Chapter 8, Using Macros.
nodes - thisdirectory contains custom edit modes. See Part 11, “Writing Edit Modes’.

perspective. xm -an XML filethat storesthe list of open buffers and views used to maintain
editor state between sessions.

Pl ugi nManager . downl oad - thisdirectory isusualy empty. It only contains files while the
plugin manager is downloading a plugin. For information about the plugin manager, see Chapter 9,
Installing and Using Plugins.

pl ugi nMgr - Cached. xm . gz - this contains a cached copy of thelast XML plugin list
downloaded from plugin central. If you delete thisfile, a new one will be created next time you try to
install a plugin via Plugin Manager.

pri nt spec - abinary file that stores printing settings.

properties - aplain text file that stores the magjority of jEdit's and its plugins settings. For more
information see the section called “ The jEdit propertiesfile”.

recent . xm -an XML filewhich storesthe list of recently opened files. jEdit remembers the caret
position and character encoding of each recent file, and automatically restores those values when one
of thefilesis opened.
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e regi sters. xm -an XML filethat storesregister contents. See the section called “ General
Register Commands’ for more information about registers.

» server -aplaintextfilethat only existswhilejEdit is running. The edit server's port number and
authorization key is stored here. See Chapter 2, Starting jEdit.

» settings-backup - thisdirectory contains numbered backups of al automatically-written settings
files.

e st art up - Thisdirectory contains startup scripts in beanshell or other plugin-supported scripting
languages. They are run at the time jEdit starts, after the st ar t up scriptsin the jEdit install
directory have been run. See the section called “ Startup Scripts’

The jEdit properties file

ThejEdit pr operti es file uses the Java properties syntax to store key/value pairs. All of the values
are stored as strings, but are interpreted as other types (such as integer or boolean) by plugins at runtime.

Do not edit this file while jEdit is running. If you do, it is possible that your changes (either your edits,
or jEdit settings changes) may get lost.

Site Properties

Y ou may also put propertiesfilesinthe pr oper ti es directory under the jEdit home directory (NOT
the jedit settings directory). Y ou can locate the jEdit home directory by going to the Utilities menu
directory, then the jEdit Home Directory menu item, and the first item in the pullout menu will be the
location of the jEdit home directory. Thisisintended for site-wide settings. Thislets you keep custom
user properties separate from the jEdit site-wide properties, so they are easier to find, edit, and move
between machines. Note that your custom properties files must have ".props" as the file name extension.

Prior to jEdit 5.0, this was a so where site-wide keyboard shortcuts were placed, but now you can define
custom sets of shortcuts as keymap files. These files can be cloned and edited from the Shortcuts Option
Pane, or edited by hand. To place them in a system-wide location, copy them into the keymaps folder
under the jedit home directory.

Site properties files are read in alphabetically by file name. This meansthat if you have a property with
the same name in more than one file, the value for that property will be the value found in the last file
that was read.

Y ou can edit these files inside jEdit - changes made to these files will not be re-read until the next time
jEdit is started.
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Macrosin jEdit are short scripts written in a scripting language called BeanShell. They provide an easy
way to automate repetitive keyboard and menu procedures, as well as access to the objects and methods
created by jEdit. Macros also provide a powerful facility for customizing jEdit and automating complex
text processing and programming tasks. This section describes how to record and run macros. A detailed
guide on writing macros appears later; see Part 111, “Writing Macros’.

Other scripting languages

A number of jEdit plugins provide support for writing scriptsin alternative programming
languages, like Python and Prolog. Consult the documentation for the appropriate plugins for
more information.

Recording Macros

The simplest use of macrosisto record a series of key strokes and menu commands as a BeanShell
script, and play them back later. While this doesn't let you take advantage of the full power of
BeanShell, it is still agreat time saver and can even be used to “ prototype” more complicated macros.

Macros>Record Macro (shortcut: C+m C+r ) prompts for amacro name and begins recording.

While recording isin progress, the string “Macro recording” is displayed in the status bar. jEdit records
the following:

» Key strokes

» Menu item commands

* Tool bar clicks

« All search and replace operations, except incremental search

Mouse clicks in the text area are not recorded; use text selection commands or arrow keys instead.

Macros>Stop Recor ding (shortcut: C+m C+s) stops recording. It also switches to the buffer
containing the recorded macro, giving you a chance to check over the recorded commands and make
any necessary changes. When you are happy with the macro, save the buffer and it will appear in the
Macr os menu. To discard the macro, close the buffer without saving it.

Thefile name extension . bsh isautomatically appended to the macro name, and all spaces are
converted to underscore characters, in order to make the macro name avalid file name. These two
operations are reversed when macros are displayed in the M acr os menu; see the section called “How
jEdit Organizes Macros” for details.

If acomplicated operation only needs to be repeated a few times, using the temporary macro featureis
quicker than saving a new macro file.

Macros>Record Temporary Macr o (shortcut: C+m C+m) begins recording to a buffer named

Tenpor ary_Macr 0. bsh. Once recording of atemporary macro is complete, jEdit does not display
the buffer containing the recorded commands, but the name Tenpor ary_Macr 0. bsh will bevisible
on any list of open buffers. By switching to that buffer, you can view the commands, edit them, and save
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them if you wish to a permanent macro file. Whether or not you look at or save the temporary macro
contents, it isimmediately available for playback.

Macros>Run Temporary Macro (shortcut: C+m C+p) plays the macro recorded to the
Tenpor ary_Macr o. bsh buffer.

Only one temporary macro is available at atime. If you begin recording a second temporary macro, the
first is erased and cannot be recovered unless you have saved the contents to a file with a name other
than Tenpor ary_Macr o. bsh. If you do not save the temporary macro, you must keep the buffer
containing the macro script open during your jEdit session. To have the macro available for your next
jEdit session, save the buffer Tenpor ary_Macr 0. bsh asan ordinary macro with a descriptive name
of your choice. The new name will then be displayed in the M acr os menu.

Running Macros

Macros supplied with jEdit, as well as macros that you record or write, are displayed under the M acr os
menu in a hierarchical structure. The jEdit installation includes about 30 macros divided into several
major categories. Each category corresponds to a nested submenu under the M acr os menu. An index

of these macros containing short descriptions and usage notes is found in Appendix F, Macros Included
With jEdit.

To run amacro, choose the M acr os menu, navigate through the hierarchy of submenus, and select

the name of the macro to execute. Y ou can aso assign execution of a particular macro to a keyboard
shortcut, toolbar button or context menu using the M acr o Shortcuts, Tool Bar or Context Menu panes
of the Utilities>Options dialog; see the section called “ The Global Options Dialog Box”.

How JEdit Organizes Macros

Every macro, whether or not you originally recorded it, is stored on disk and can be edited as a text
file. The file name of amacro must havea. bsh extension in order for jEdit to be aware of it. By
default, jEdit associates a. bsh file with the BeanShell edit mode for purposes of syntax highlighting,
indentation and other formatting. However, BeanShell syntax does not impose any indentation or line
break requirements.

The Macros menu lists all macros stored in two places: the macr os subdirectory of the jEdit home
directory, and the macr os subdirectory of the user-specific settings directory (see the section called
“The jEdit Settings Directory” for information about the settings directory). Any macros you record will
be stored in the user-specific directory.

Macros stored el sewhere can be run using the M acr os>Run Other Macr o command, which displays a
file chooser dialog box, and runs the specified file.

The listing of individual macros in the M acr os menu can be organized in a hierarchy using
subdirectories in the general or user-specific macro directories; each subdirectory appears as a submenu.
Y ou will find such ahierarchy in the default macro set included with jEdit.

When jEdit first loads, it scans the designated macro directories and assembles alisting of individual
macros in the M acr os menu. When scanning the names, jEdit will delete underscore characters and the
. bsh extension for menu labels, sothat Li st _Usef ul _| nf or mat i on. bsh, for example, will be
displayed in the Macros menu as List Useful Information.

Y ou can browse the user and system macro directories by opening the macr os directory from the
Utilities>] Edit Home Directory and Utilities>Settings Directory menus.
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Macros can be opened and edited much like ordinary files from the file system browser. Editing macros
from within jEdit will automatically update the macros menu; however, if you modify macros from
another program or add macro files to the macro directories, you should run the M acr os>Rescan

M acr os command to update the macro list.




Chapter 9. Installing and Using Plugins

A plugin is an application which isloaded and runs as part of another, host application. Plugins respond
to user commands and perform tasks that supplement the host application's features.

This chapter coversinstalling, updating and removing plugins. Documentation for the plugins
themselves can be found in Help>j Edit Help, and information about writing plugins can be found in
Part IV, “Writing Plugins’.

The Plugin Manager

Plugins>Plugin Manager displays the plugin manager window. It consists of three tabs: Manage,
Update and Install. The Manage tab lists al installed plugins; clicking on a plugin in the list will display
information about it.

To remove plugins, select them (multiple plugins can be selected by holding down Cont r ol ) and click
Remove. Thiswill display a confirmation dialog box first.

To view plugin documentation, select a plugin and click Help. Note that plugin documentation can also
be accessed by invoking Help>jEdit Help.

After you have tuned jEdit to your liking and want to install the same set of plugins onto another host,
or another user's profile, you can export your currently installed plugin list as an xml file, known as a
PluginSet. The Save rollover button allows you to save the list of installed and loaded pluginsto an
XML file. Seethe section called “Plugin Sets’ for more information.

Plugins>Plugin Options displays a dialog box for changing plugin settings.

Installing and Updating Plugins

Plugins can be installed in two ways; manually, and from the plugin manager. In most cases, plugins
should be installed from the plugin manager. It is easier and more convenient.

Toinstall plugins manually, go to http://plugins.jedit.org in aweb browser and follow the directions on
that page.

Toinstall plugins from the plugin manager, make sure you are connected to the Internet and click

the Install tab in the plugin manager window. The plugin manager will then download information
about available plugins from the jEdit web site, and present alist of plugins compatible with your jEdit
release.

Click on apluginin thelist to see some information about it. To select plugins for installation, click the
check box next to their namesin thelist.

The Total sizefield showsthetotal size of all plugins chosen for installation, along with any plugins
that will be automatically downloaded in order to fulfill dependencies.

If apreviously saved PluginSet was selected, it will automatically be loaded whenever the Install tab is
created, and you will see the filename in the hovertip of the choose rolloverbutton, as well as al of the
pluginsin that set already checked for you.

Y ou can clear the active PluginSet with the clear button next to it, or choose a different PluginSet xml
file with the choose button. See the section called “Plugin Sets’ for more information.
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Once you have specified pluginsto install, click I nstall to begin the download process.

By default, the plugin manager does not download plugin source code, and installs the downl oaded
pluginsinthej ar s subdirectory of the user-specific settings directory. These settings can be changed
in Plugin Manager pane of the Utilities>Options dialog box; see the section called “ The Plugin
Manager Pane”.

The Update tab of the plugin manager is very similar to the Install tab. It lists plugins for which
updated versions are available. It will also offer to delete any obsolete plugins.

Proxy Servers and Firewalls

If you are connected to the Internet through an HTTP proxy or SOCK S firewall, you will need to
specify the relevant details in the Proxy Server s pane of the Utilities>Options dialog box; see
the section called “ The Proxy Servers Pane”.

Plugin Sets

A PluginSet is acollection of plugins, represented as an XML file. These XML files can be created
from the save button of the Manage tab of the Plugin Manager. Saving a PluginSet remembers all of the
currently loaded plugins.

When a PluginSet has been saved, it becomes the "default pluginset”, which means that if you unload/
uninstall plugins from that set and go back to the Install tab, you should see them selected for download
again. To clear this setting, click on the clear button in the Install tab.

It is posisble to Choose/Open a PluginSet from the Manage or the Install tab. The behavior of choosing a
PluginSet depends on which tab you are on when you choose it. From the Manage tab, it unloads plugins
that are loaded but not in the list. From the Install tab, it selects plugins from that list that are not loaded,
marking them for download from Plugin Central.

When choosing a PluginSet, the path can be given as aremote URL. This helps teachers and sysadmins
direct the students/slaves to a standard set of plugins that are required for the course/job.
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Appendix A. Keyboard Shortcuts

This appendix documents the "jEdit" keymap of keyboard shortcuts. Keymaps can be created and

customized to suit your taste in the Shortcuts pane of the Utilities>Options dialog box; see the section

called “ The Shortcuts Pane”.

Files
For details, see the section called “ Switching Buffers’, the section called “Multiple Views’ and
Chapter 4, Working With Files.
C+n New file.
C+o Open file.
C+w Close buffer.
C+te Ctw Close dl buffers.
C+s Save buffer.
C+e Cts Save all buffers.
Ctp Print buffer.
C+PAGE_UP Go to previous buffer.
C+PAGE_DOVWN Go to next buffer.
C+ Go to recent buffer.
A+’ Show buffer switcher.
C+q Exit jEdit.
Views
For details, see the section called “Multiple Views’.
C+re C+t Turn gutter (line numbering) on and off.
C+0 Remove split containing current text areaonly.
C+1 Remove al splits.
C+2 Split view horizontally.
C+3 Split view verticaly.
A+PAGE_UP Send keyboard focus to previous text area.
A+PACE_DOMN Send keyboard focus to next text area.
C+e UP; LEFT; DOMN; RI GHT Send keyboard focus to top; bottom; |eft; right docking area.
C+e C+ Close currently focused docking area.
Action Bar

For details, see the section called “ The Action Bar”.

C+ENTER

Display the action bar and give it keyboard focus.
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C+SPACE Repeat last editor action.

Moving the Caret

For details, see the section called “Moving The Caret”, the section called “Working With Words’, the
section called “Working With Lines’, the section called “Working With Paragraphs’ and the section
called “Bracket Matching”.

Arr ow Move caret one character or line.

C+Arr ow Move caret one word or paragraph.

PAGE_UP; PAGE DOV Move caret one screenful.

HOVE First non-whitespace character of line, beginning of line, first
visible line (repeated presses).

END Last non-whitespace character of line, end of line, last visible line
(repeated presses).

C+HOVE Beginning of buffer.

C+END End of buffer.

C+] Go to matching bracket.

Cre [;] Go to previous; next bracket.

CH Gotoline.

Selecting Text

For details, see the section called “ Selecting Text”, the section called “Working With Words’, the
section called “Working With Lines’, the section called “Working With Paragraphs’ and the section
called “Bracket Matching”.

S+Arr ow Extend selection by one character or line.

CS+Ar r ow Extend selection by one word or paragraph.

S+PAGE_UP; S+PAGE_DOWN Extend selection by one screenful.

S+HOVE Extend selection to first non-whitespace character of line,
beginning of line, first visible line (repeated presses).

S+END Extend selection to last non-whitespace character of line, end of
ling, last visible line (repeated presses).

CS+HOMVE Extend selection to beginning of buffer.

CS+END Extend selection to end of buffer.

C+[ Select code block.

Cte wl;p Select word; line; paragraph.

C+re CH Select line range.

Ct+a Select all.

ESCAPE Select none.

A+\ Switch between range and rectangular selection mode.
C+\ Switch between single and multiple selection mode.
Cre i Invert selection.
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Scrolling
For details, see the section called “Multiple Views'.
Cte CHj Ensure current line is visible, and send focus to the text area.
C+e C+n Center caret on screen.
C+'; CH/ Scroll up; down oneline.
A+ A+ Scroll up; down one page.
Text Editing

For details, see the section called “Undo and Redo”, the section called “Inserting and Deleting Text”, the
section called “Working With Words’, the section called “Working With Lines’ and the section called
“Working With Paragraphs’.

Undo.

Redo.

C+z

C+e C+z

BACK_SPACE; DELETE

Delete character before; after caret.

C+BACK_SPACE; C+DELETE

Delete word before; after caret.

C+d;C+re d

Delete line; paragraph.

CS+BACK_SPACE; CS+DELETE

Delete from caret to beginning; end of line.

C+te r

Remove trailing whitespace from the current line (or all selected
lines).

C+j Join lines.
C+b Complete word.
Cte f Format paragraph (or selection).

Clipboard and Registers

For details, see the section called “Transferring Text”.

C+x or S+DELETE

Cut selected text to clipboard.

C+c or C+l NSERT

Copy selected text to clipboard.

C+e Ctu Append selected text to clipboard, removing it from the buffer.

C+e Cta Append selected text to clipboard, leaving it in the buffer.

C+v or S+| NSERT Paste clipboard contents.

C+e C+p Vertically paste clipboard contents.

C+r C+x key Cut selected text to register key.

C+r C+c key Copy selected text to register key.

C+r Ctu key Append selected text to register key, removing it from the
buffer.

C+r C+a key Append selected text to register key, leaving it in the buffer.

C+r Ct+v key Paste contents of register key.

C+r C+p key Vertically paste contents of register key.
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C+re Ctv ‘Paste previous.
C+e Cry ‘Pastedeleted.
Markers

For details, see the section called “Markers”.

C+e C+tm If current line doesn't contain a marker, one will be added.
Otherwise, the existing marker will be removed. Use the
M ar kers menu to return to markers added in this manner.
C+t key Add marker with shortcut key .
C+y key Go to marker with shortcut key.
C+u key Select to marker with shortcut key.
C+k key Go to marker with shortcut key, and move the marker to the

previous caret position.

C+e C+, ; C+e C+.

Search and Replace

Move caret to previous; next marker.

For details, see the section called “ Search and Replace”.

C+f Open search and replace dialog box.
C+g Find next.

C+h Find previous.

C+e C+b Search in open buffers.

Ct+e C+d Search in directory.

C+re CHr Replace in selection.

C+te Ctg Replace in selection and find next.
C+, Incremental search bar.

At, HyperSearch bar.

C+. Incremental search for word under the caret.
At. HyperSearch for word under the caret.
C+re CHi Toggle ignore case.

C+e C+x Toggle regular expressions.

Source Code Editing

For details, see the section called “ Abbreviations®, the section called “ Tabbing and Indentation” and the
section called “Commenting Out Code”.

C+; Expand abbreviation.
A+LEFT; A+RI GHT Shift current line (or all selected lines) l€ft; right.
S+TAB; TAB Shift selected lines | eft; right. Note that pressing TAB with no

selection active will insert atab character at the caret position.
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C+i Indent current line (or all selected lines).
Cte Ctc Range comment selection.
C+e Ct+k Line comment selection.

Folding and Narrowing

For details, see the section called “Folding” and the section called “Narrowing”.

A+BACK_SPACE

Collapse fold containing caret.

A+ENTER Expand fold containing caret one level only.

AS+ENTER Expand fold containing caret fully.

Cte x Expand al folds.

C+te a Add explicit fold.

Cte s Select fold.

C+e ENTER key Expand folds with level lessthan key, collapse al others.

Cte n n Narrow to fold.

Cte n s Narrow to selection.

A+UP; A+DOVN Moves caret to previous; next fold.

Cte u Moves caret to the parent fold of the one containing the caret.
Macros

For details, see Chapter 8, Using Macros.

C+m C+r Record macro.

C+rm C+m Record temporary macro.
C+m C+s Stop recording.

C+m C+p Run temporary macro.

Alternative Shortcuts

A few frequently-used commands have alternative shortcuts intended to help you keep your hands from

moving all over the keyboard.

Atj ; A+l Move caret to previous, next character.

A+i ; Atk Move caret up, down oneline.

At+q; Ata Move caret up, down one screenful.

Atz First non-whitespace character of line, beginning of line, first
visible line (repeated presses).

A+X Last non-whitespace character of line, end of line, last visible line

(repeated presses).
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Appendix B. The Activity Log

The activity log is very useful for troubleshooting problems, and hel ps when devel oping plugins.

Utilities>Troubleshooting>Activity L og displays the last 500 lines of the activity log. By default, the
activity log is shown in afloating window. This window can be docked using the commandsin its top-
left corner popup menu; see the section called “Window Docking Layouts’.

The complete log can befound intheact i vi ty. | og fileinside the jEdit settings directory, the path
of which is shown inside the activity log window.

jEdit writes the following information to the activity log:
« Information about your Javaimplementation (version, operating system, architecture, etc).

* All error messages and runtime exceptions (most errors are shown in dialog boxes as well, but the
activity log usually contains more detailed and technical information).

 All sorts of debugging information that can be helpful when tracking down bugs.
* Information about loaded plugins.

WhilejEdit is running, the log file on disk may not always accurately reflect what has been logged, due
to buffering being done for performance reasons. To ensure the file on disk is up to date, invoke the
Utilities>Troubleshooting>Update Activity L og on Disk command. The log fileis also automatically
updated on disk when jEdit exits.

The Settings button in the Activity Log window shows a dialog that |ets you adjust the output colors,
filter the messages by type, and lets you set the maximum number of lines to display. Note that larger
numbers will decrease the overall performance of jEdit since these lines are kept in memory.

In the Settings pane there is also a debugging option, Beep on output. It allows for catching problems
right after they show up. Each error message entry is accompanied by a system beep. Lower priority
entries may be aerted thisway, if thel og option is used, see the section called “Command Line

Usage”.
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Appendix C. History Text Fields

Thetext fields in many jEdit components, such as the file system browser, incremental search bar, and
action bar, al remember the last 20 entered strings by default. The number of strings to remember can
be changed in the Appear ance pane of the Utilities>Options dialog box; see the section called “The
Appearance Pane”.

Pressing UP recalls previous strings. Pressing DOWN after recalling previous strings recalls later strings.

Pressing S+UP or S+DOAN will search backwards or forwards, respectively, for strings beginning with
the text already entered in the text field.

Clicking the triangle to the right of the text field, or clicking with the right-mouse button anywhere else
will display a pop-up menu of al previously entered strings; selecting one will input it into the text field.
Selecting the first item, "previously entered strings:” pops up a dialog that lets you change previously
entered strings. Holding down Shi ft while clicking will display a menu of all previously entered
strings that begin with the text already entered.

Sear ch and Replacefields

In jEdit 4.3, the search/replace history fields are multi-line textareas, so they no longer use the
same single-line history textfield described above. The multiline history textarea behaves a
little differently: UP and DOWN arrows go up and down aline in the textarea, instead of through
the previously entered strings. PageUp and PageDown are used instead to select history
strings, and there is no arrow combo button, although right-click will still show you the history
as a context menu.
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Appendix D. Glob Patterns

jEdit uses glob patterns similar to those in the various Unix shells to implement file name filtersin the
file system browser. Glob patterns resemble regular expressions somewhat, but have a much simpler
syntax. The following character sequences have special meaning within a glob pattern:

» ? matches any one character

* * matches any humber of characters

{! gl ob} Matches anything that does not match gl ob

* {a, b, c} matchesany oneof a,b orc

[ abc] matchesany characterintheseta, b orc
» [~abc] matchesany character notintheseta, b or c

* [ a- z] matchesany character intherangea to z, inclusive. A leading or trailing dash will be
interpreted literally

Sinceweusej ava. uti |l . r egex patternsto implement globs, this means that in addition to the
above, anumber of “character class metacharacters’ may be used. Keep in mind, their usefulness
islimited since the regex quantifier metacharacters (asterisk, questionmark, and curly brackets) are
redefined to mean something elsein filename glob language, and the regex quantifiers are not available
in glob language.

* \ wmatches any alphanumeric character or underscore

 \ s matches a space or horizontal tab

* \ S matches a printable non-whitespace.

 \ d matches adecimal digit

Here are some examples of glob patterns:

e * -dlfiles.

e *_ java - dl fileswhose names end with “.java’.

o * [ch] -al fileswhose names end with either “.c” or “.h".
« * {c, cpp, h, hpp, cxx, hxx} -al Cor C++files.

o ["#] * - dl fileswhose names do not start with “#”.

Using regexes instead of globs

Sometimesit is desirable to use aregular expression instead of a glob for specifying file sets. Thisis
because regular expressions are more powerful than globs and can provide the user with more specific
filename matching criteria. To avoid the glob-to-regex transformation, prefix your pattern with the string
(re),whichwill tell jEdit to not trand ate the following pattern into aregex (sinceit already isone).
For example:

(re).*\.(hlc(c|pp)?) Matches*.c, *.cpp, *.h, *.cc
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Glob Patterns

If you need to match files that begin with the glob-trandate-disable prefix ( r ) , you can escape it with
aleading backslash and the metacharacters will be translated into globs as before.
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Appendix E. Regular Expressions

jEdit uses regular expressions from java.util.regex.Pattern to implement inexact search and replace.
Click there to see a complete reference guide to all supported meta-characters.

A regular expression consists of a string where some characters are given special meaning with regard to
pattern matching.

Inside XML files

Inside XML files (such as jEdit modefiles), it isimportant that you escape XML special
characters, such as &, <, >, etc. You can use the XML plugin's "characters to entities' to
perform this mapping.

Inside Java / beanshell / propertiesfiles

Java strings are always parsed by java before they are processed by the regular expression
engine, so you must make sure that backslashes are escaped by an extrabackdash (\ \ )

Within aregular expression, the following characters have special meaning:

Positional Operators

» " matches at the beginning of aline

$ matches at the end of aline
* \ B matches at anon-word break

* \ b matches at aword boundary

One-Character Operators

e . matches any single character

* \ d matches any decimal digit

* \ D matches any non-digit

* \ n matches the newline character

 \ s matches any whitespace character

\ x NN matches hexadecimal character code NN

* \ S matches any non-whitespace character

* \'t matchesahorizontal tab character

* \ wmatches any word (alphanumeric) character

* \ Wmatches any non-word (a phanumeric) character

* \'\ matchesthe backslash (“\") character
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Regular Expressions

Character Class Operator

» [ abc] matchesany characterintheseta, b orc
» [~abc] matchesany character notintheseta, b or c

» [ a- z] matchesany character intherangea to z, inclusive. A leading or trailing dash will be
interpreted literally

Subexpressions and Backreferences

* (abc) matcheswhatever the expression abc would match, and savesit as a subexpression. Also
used for grouping

e (?:...) puregrouping operator, does not save contents
e (?#...) embedded comment, ignored by engine

* (?=...) positivelookahead; the regular expression will match if the text in the brackets matches,
but that text will not be considered part of the match

o (?!...) negativelookahead; the regular expression will match if the text in the brackets does not
match, and that text will not be considered part of the match

* \ n where 0 < n < 10, matches the same thing the nth subexpression matched. Can only be used in the
search string

» $n where 0 < n < 10, substituted with the text matched by the nth subexpression. Can only be used in
the replacement string

Branching (Alternation) Operator

» a| b matches whatever the expression a would match, or whatever the expression b would match.

Repeating Operators

These symbols operate on the previous atomic expression.

» ? matches the preceding expression or the null string

» * matches the null string or any number of repetitions of the preceding expression
» + matches one or more repetitions of the preceding expression

» {m} matches exactly mrepetitions of the one-character expression

{'m n} matches between mand n repetitions of the preceding expression, inclusive

* {m} matches mor more repetitions of the preceding expression

Stingy (Minimal) Matching

If arepeating operator (above) isimmediately followed by a?, the repeating operator will stop at the
smallest number of repetitions that can complete the rest of the match.
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Regular Expressions

On regex search

There are some known issueswith thej ava. uti | . r egex library, asit standsin Java.

In particular, it is possible to create regular expressions that hang the VM, or cause stack
overflow errors, which was not as easy to accomplish using the legacy gnu. r egexp
library. If you find that gnu. r egexp, used in jEdit 4.2 and earlier, is more suitable for your
search/replace needs, you can try the X Sear ch plugin, which still usesit and can provide a
replacement to the built-in search dialog.
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Appendix F. Macros Included With jEdit

jEdit comes with alarge number of sample macrosthat perform avariety of tasks. The following index
provides short descriptions of each macro, in some cases accompanied by usage notes.

In addition to the macrosincluded with jEdit, avery large collection of user-contributed macros
isavailablein the “Downloads’ section of the community.jedit.org web site. There are detailed
descriptions for each macro as well as a search facility.

C/C++ macros

These macros are useful for C/C++ programming.
e Include_Guard. bsh

Inserts conditional preprocessor directives around a header file, to prevent it from being included
multiple times.

The name of the generated preprocessor macro is based on the buffer's name.
» Toggl e_Header _Source

Toggles between the header and the implementation file. Works for .c, .cxx, and .cpp extensions.

Clipboard Macros

These macros copy or cut text to the clipboard.
* Copy_Li nes_Cont ai ni ng. bsh
Copies dl lines from the current buffer, containing a user-supplied string, to the clipboard.
e Cut _Lines_Containing. bsh
Cuts al lines from the current buffer, containing a user-supplied string, to the clipboard.
» Copy_Sel ection_or_Line. bsh

If no text is selected, the current line is copied to the clipboard, otherwise the selected text is copied
to the clipboard. Some editors have this has the default copy behavior. To achieve the same effect in
jEdit, bind this macro to C+c in the Shortcuts pane of the Utilities> Options dialog box.

* Cut_Sel ection_or_Line. bsh

If no text is selected, the current lineis cut to the clipboard, otherwise the selected text is cut to the
clipboard. Some editors have this has the default cut behavior. To achieve the same effect in jEdit,
bind this macro to C+x in the Shortcuts pane of the Utilities> Options dialog box.

» Copy_Visi bl e_Lines. bsh

Copiesthe visible lines from the current buffer to the Clipboard. Lines that are not visible becuase
they are folded are not copied.

e Paste_I ndent. bsh
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Macros Included With jEdit

Pastes the content of the clipboard and indentsiit.

Editing Macros

These macros automate various text editing tasks.

Dupl i cat e_Li nes_Above. bsh

Duplicates current/selected ling(s) upward.

Dupl i cat e_Li nes_Bel ow. bsh

Duplicates current/selected ling(s) downward.

Emacs_Cirl - K. bsh

Cuts and appends text, from the cursor to the end of the line, into the copy buffer.
Emacs_Next Li ne. bsh

Moves the cursor to the next line, centering the current line in the middle of the text areaif the cursor
is at the bottom of the text area.

Emacs_Previ ous_Li ne. bsh

Moves the cursor to the previous line, centering the current line in the middle of the text areaif the
cursor is at the top of the text area.

Go_to_Col umm. bsh
Prompts the user for a column position on the current line, then moves the caret there.
G eedy_Backspace. bsh

If buffer is using soft tabs, this macro will backspace to the previous tab stop, if al characters between
the caret and the tab stop are spaces. In all other cases a single character is removed.

Greedy_Del et e. bsh

If abuffer is using soft tabs, this macro will delete tabSize number of spaces, if al the characters
between the caret and the next tab stop are spaces. In all other cases a single character is deleted.

Greedy_Left. bsh

If abuffer is using soft tabs, this macro will move the caret tabSize spaces to the left, if al the
characters between the caret and the previous tab stop are al spaces. In al other cases, the caret is
moved a single character to the left.

Greedy_Ri ght. bsh

If abuffer is using soft tabs, this macro will move the caret tabSize spacesto theright, if al the
characters between the caret and the next tab stop are all spaces. In al other cases, the caret is moved
asingle character to theright.

Keywords_to_Upper _Case. bsh

Converts all keywords in the current buffer to upper case.
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Macros Included With jEdit

 Mbde_Swi t cher. bsh

Displays amodal dialog with the current buffer's mode in atext field, allowing one to change the
mode by typing in its name.

ENTER selects the current mode; if the text is not avalid mode, the dialog still dismisses, but a
warning is logged to the activity log. ESACPE closes the dialog with no further action. TAB attempts
to auto-complete the mode name. Pressing TAB repeatedly cycles through the possible completions.
SHI FT- TAB cycles through the completionsin reverse.

 Move_ Li ne_Down. bsh
Moves the current line down one, with automatic indentation.
* Move_Li ne_Up. bsh
Moves the current line up one, with automatic indentation.
* Open_Li ne_Above. bsh
Adds a new blank line before the current/selected line(s).
* Open_Li ne_Bel ow. bsh
Adds a new blank line after the current/selected line(s).
» Toggl e_Fol d. bsh
Toggles visibility of current fold.

Thisis especialy useful for fold toggling via keyboard.

File Management Macros

These macros automate the opening and closing of files.
» Browse Buffer_Directory. bsh

Opens athe current buffer's directory in the file system browser.
 Browse _Directory. bsh

Opens adirectory supplied by the user in the file system browser.
 Buf fer _Swi tcher. bsh

Displays amodal dialog listing al open buffers, allowing one to switch to and/or close buffers.
ENTER switches to a buffer and closes the dialog, DELETE closes a buffer, SPACE switchesto a
buffer but does not close the dialog.

e Close Al _Except Active. bsh
Closes all files except the current buffer.
Prompts the user to save any buffer containing unsaved changes.

e Copy_Path _to dipboad. bsh
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Copies the current buffer's path to the clipboard.
» Copy_Nane_to_Cipboad. bsh
Copies the current buffer's filename to the clipboard.
e Duplicate_ Buffer.bsh
Duplicates the current buffer into a new one.
e Del ete_Current. bsh
Deletes the current buffer's file on disk, but doesn't close the buffer.
* 3 ob_C ose. bsh
Closes all open buffers matching a given glob pattern.
* I nsert_Sel ection. bsh

Assumes the current selection isfile path and tries replaces the selection with the contents of thefile.
Does nothing if no text is selected or the selection spans multiple lines.

* Next_Dirty Buffer.bsh

Switches to the next dirty buffer, if thereis one.
* Open_Pat h. bsh

Opens the file supplied by the user in an input dialog.
e Open_Sel ecti on. bsh

Opens the file named by the current buffer's selected text. Current VFS browser directory isalso tried
as aparent of the filename, but only asalocal path.

* Open_Sel ection_I n_Deskt op. bsh
Opens the file named by the current buffer's selected text using Deskt op. That is opensthefile using
operating system's default application. If alink is selected, it is browsed instead, using default web
browser. If no selection is active, the path under caret is used.

» Send_Buffer_To_Next _Split.bsh
If bufferset scopeis set to EditPane, the current buffer is added to the next Editpane's bufferset.

» Toggl e_ReadOnly. bsh

Toggles alocal file's read-only flag. Uses platform-specific commands, so it only works on Windows,
Unix and MacOS X.

User Interface Macros

Description.

» Decrease_Font _Si ze. bsh
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Decreases the font size in the gutter and text area by 1 point.
e I ncrease_Font _Si ze. bsh

Increases the font size in the gutter and text area by 1 point.
* Open_Cont ext _Menu. bsh

Opens the text area context menu just below and to the right of the caret.
* Reset Text Area. bsh

Performs a split and an unsplit of the current TextArea. Useful for those occasions when your textarea
is corrupt (painting the incorrect characters on the screen).

* Splitpane_G ow. bsh

When inside a split EditPane, this macro moves the splitter away from the cursor, effectively
increasing the size of the currently active split pane.

» Toggl e_Bott om Docki ng_Ar ea. bsh
Expands or collapses the bottom docking area, depending on it's current state.
e Toggl e_Left Docki ng_Area. bsh
Expands or collapses the left docking area, depending on it's current state.
» Toggl e_Ri ght Docki ng_Area. bsh
Expands or collapses the right docking area, depending on it's current state.
» Toggl e_Top_Docki ng_Ar ea. bsh

Expands or collapses the top docking area, depending on it's current state.

Java Code Macros

These macros handle text formatting and generation tasks that are particularly useful in writing Java
code.

 Create_Constructor. bsh

Inserts constructor for the class at the current caret position.
e Get _C ass_Nane. bsh

Inserts a Java class name based upon the buffer's file name.
» Get _Package_Name. bsh

Inserts a plausible Java package name for the current buffer.

The macro compares the buffer's path name with the elements of the classpath being used by the jEdit
session. An error message will be displayed if no suitable package name is found. This macro will not
work if jEdit is being run as a JAR file without specifying a classpath; in that case the classpath seen
by the macro consists solely of the JAR file.
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e Java_Fil e_Save. bsh

Acts as awrapper script to the Save As action. If the buffer isanew filg, it scansthe first 250 lines for a Java class
or interface declaration. On finding one, it extracts the appropriate filename to be used in the Save As dialog.

« Make_Get _and_Set Met hods. bsh
Createsget XXX() or set XXX() methods that can be pasted into the buffer text.

This macro presents adialog that will “grab” the names of instance variables from the caret line of
the current buffer and paste a corresponding get XXX() or set XXX() method to one of two text
areasin the dialog. The text can be edited in the dialog and then pasted into the current buffer using
the Insert... buttons. If the caret is set to aline containing something other than an instance variable,
the text grabbing routine is likely to generate nonsense.

As explained in the notes accompanying the source code, the macro uses a global variable which can
be set to configure the macro to work with either Java or C++ code. When set for use with C++ code,
the macro will also write (in commented text) definitions of get XXX() or set XXX() suitablefor
inclusion in a header file.

* Previ ew Javadoc_of Buffer. bsh
Create and display APl documentation for the current buffer.

The macro includes various configuration variables you can change; see the comment at the beginning
of the macro source for details.

Miscellaneous Macros

While these macros do not fit easily into the other categories, they all provide interesting and useful
functions.

 Buffer_to_HyperSearch_Results. bsh

Reads HyperSearch results from a buffer that was previously created by the
HyperSearch_Results to Buffer macro and possibly filtered manually, and imports them into the
HyperSearch Results dockable.

» Debug_BufferSets. bsh

Display int and hex values for the character at the caret, in the status bar.
» Di spl ay_Abbrevi ati ons. bsh

Displays the abbreviations registered for each of jEdit's editing modes.

The macro provides aread-only view of the abbreviations contained in the “ Abbreviations’ option
pane. Pressing aletter key will scroll the table to the first entry beginning with that letter. A further
option is provided to write a selected mode's abbreviations or all abbreviations in atext buffer for
printing as a reference. Notesin the source code listing point out some display options that are
configured by modifying global variables.

* Di splay_Actions. bsh
Displaysalist of al the actions known to jEdit categorised by their action set.

This macro can be a useful reference if you want to use the jEdit 4.2 action bar.
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e Di spl ay_Char act er _Code. bsh

Display int and hex values for the character at the caret, in the status bar.
« Display_Shortcuts. bsh

Displays a sorted list of the keyboard shortcuts currently in effect.

The macro provides a combined read-only view of command, macro and plugin shortcuts. Pressing a
letter key will scroll the table to the first entry beginning with that letter. A further option is provided
to write the shortcut assignments in atext buffer for printing as a reference. Notes in the source code
listing point out some display options that are configured by modifying global variables.

 Eval uate_Buffer _in_BeanShel|l. bsh

Evaluates contents of current buffer as a BeanShell script, and opens a new buffer to receive any text
output.

Thisisaquick way to test amacro script even beforeits text is saved to afile. Opening a new buffer
for output is a precaution to prevent the macro from inadvertently erasing or overwriting itself.
BeanShell scripts that operate on the contents of the current buffer will not work meaningfully when
tested using this macro.

» Hex_Convert. bsh

Converts byte characters to their hex equivalent, and vice versa.
* Hyper Search_Results_to_Buffer. bsh

Writes HyperSeach results to a new buffer.

This buffer can be re-imported to the HyperSearch Results dockable by the
Buffer_to_HyperSearch_Results macro.

» Make Bug_Report. bsh
Creates a new buffer with installation and error information extracted from the activity log.
The macro extractsinitial messages written to the activity log describing the user's operating system,
JDK, jEdit version and installed plugins. It then appends the last set of error messages written to the

activity log. The new text buffer can be saved and attached to an email message or a bug report made
on SourceForge.

* Run_Script. bsh
Runs script using interpreter based upon buffer's editing mode (by default, determined using file
extension). Y ou must have the appropriate interpreter (such as Perl, Python, or Windows Script Host)
installed on your system.

» Show _Threads. bsh

Displaysin atree format all running Java threads of the current Java Virtual Machine.

Property Macros

These macros produce lists or tables containing properties used by the Java platform or jEdit itself.
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Text

Create_ Pl ugi n_Announcenent. bsh

Creates an announcement for the Plugin Central Submission Tracker based on the plugins * .props and
description.html files.

Insert Buffer Properties. bsh
Inserts buffer-local propertiesinto the current buffer.

If the buffer's mode has a line comment defined, or comment start and end defined, the inserted
properties will be commented out.

j Edit_Properties. bsh

Writes an unsorted list of jEdit propertiesin a new buffer.

Look_and_Feel Properties. bsh

Writes an unsorted list of the names of Java Look and Feel propertiesin anew buffer.
System Properties. bsh

Writes an unsorted list of al Java system propertiesin a new buffer.

Macros

These macros generate various forms of formatted text.

Add_Prefix_and_Suffix. bsh
Adds user-supplied “ prefix” and “suffix” text to each line in agroup of selected lines.

Text is added after leading whitespace and before trailing whitespace. A dialog window receives input
and “remembers’ past entries.

Col or _Pi cker. bsh

Displays a color picker and inserts the selected color in hexadecimal format, prefixed with a“#”.
Conpose_Tag. bsh

The selection is taken as tag name and replaced with afull xml tag.

Dupl i cat e_Li ne. bsh

Duplicates the line on which the caret liesimmediately beneath it and moves the caret to the new line.
I nsert _Date. bsh

Inserts the current date and time in the current buffer.

Theinserted text includes a representation of the timein the “Internet Time” format.

I nsert _Tag. bsh

Inserts a balanced pair of HTML/SGML/XML markup tags as supplied in an input dialog. The tags
will surround any selected text.
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e Line_Filter.bsh

Filters lines of the current buffer due to a provided regular expression. The resulting set of lines can
be either removed from the buffer or written to a new buffer.

Thefilter works on a multiline selection (if thereis one) otherwise on the whole buffer. The resulting
set of linesincludes those lines that either match or not match the regular expression.

* Next Char. bsh
Finds next occurrence of character on current line.

The macro takes the next character typed after macro execution as the character being searched. That
character is not displayed. If the character does not appear in the balance of the current line, no action
occurs.

Thismacro illustrates the use of | nput Handl er . r eadNext Char () asameans of obtaining user
input. See the section called “Using a Single Keypress as I nput”.

* Reverse Lines. bsh

Reverses the selected lines or the entire buffer if no lines are selected. Does not support Rectangular
Selections.

e Single Space Buffer.bsh

Removes every second line, if they are all blank.
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Part Il. Writing Edit Modes

This part of the user's guide covers writing edit modes for jEdit.

Edit modes specify syntax highlighting rules, auto indent behavior, and various other customizations for editing
different file types. For general information about edit modes, see the section called “Edit Modes’.

This part of the user's guide was written by Slava Pestov and is maintained by the jEdit core development team.




Chapter 10. Mode Definition Syntax

Edit modes are defined using XML, the eXtensible Markup Language; mode files have the extension

. xm . XML isavery simple language, and as aresult edit modes are easy to create and modify. This
section will start with a short XML primer, followed by detailed information about each supported tag
and highlighting rule.

Editing a mode or a mode catal og file within jEdit will cause the changes to take effect immediately.
If you edit modes using another application, the changes will take effect after the Utilities >
Troubleshooting > Reload Edit M odes command is invoked.

An XML Primer

A very simple XML file (which also happens to be an edit mode) looks like so:
<?xm version="1.0"7?>
<! DOCTYPE MODE SYSTEM "xnode. dt d" >

<MCDE>
<PROPS>
<PROPERTY NAME="coment Start" VALUE="/*" />
<PROPERTY NAME="coment End" VALUE="*/" />
</ PROPS>

<RULES>
<SPAN TYPE=" COMMENT1" >
<BEG N>/ * </ BEG N>
<END>*/ </ END>
</ SPAN>
</ RULES>
</ MODE>

Note that each opening tag must have a corresponding closing tag. If there is nothing between the
opening and closing tags, for example <TAG></ TAG>, the shorthand notation <TAG / > may be used.
An example of this shorthand can be seen in the <PROPERTY> tags above.

Validation and Errors

Most XML file formats have aformal grammar specified in either DTD, XSD or RNG. In
the example above, we can see that the DOCTYPE, or formal grammar for jEdit mode filesis
described in xnode. dt d, which happensto come from jEdit's source code. If you install the
XML plugin, and while editing a mode file in jEdit, go to Plugins- XML - Parseas XML,
you should see a structure tree in Sidekick, and you will also see errors (if there are any) in
ErrorList, if the document does not conform to the proper XML syntax or the document's
formal grammar. In addition, the XML plugin provides completion tips for elements and
attributes. All of these things can help immensely especially when learning XML.

It is highly recommended that you check your XML files for validation errors before
submitting them to the community.

XML is case sensitive. Span or span is not the same as SPAN.
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Toinsert aspecia character such as < or > literally in XML (for example, inside an attribute value), you
must write it as an entity. An entity consists of the character's symbolic name enclosed within “&” and
“;". The most frequently used entities are;

» & t; - Thelessthan (<) character

» &gt ; - The greater-than (>) character

e &anp; - Theampersand (&) character

For example, the following will cause a syntax error:

<SEQ TYPE=" OPERATOR' >&</ SEQ>

Instead, you must write;

<SEQ TYPE=" OPERATOR' >&anp; </ SEQ>

Now that the basics of XML have been covered, the rest of this section will cover each construct in
detail.

The Preamble and MODE tag

Each mode definition must begin with the following:

<?xm version="1.0"7>
<! DOCTYPE MODE SYSTEM " xnode. dt d" >

Each mode definition must also contain exactly one MODE tag. All other tags (PROPS, RULES) must be
placed inside the MODE tag. The MODE tag does not have any defined attributes. Here is an example:

<MODE>

node definition goes here ...
</ MODE>

The PROPS Tag

The PROPS tag and the PROPERTY tagsinside it are used to define mode-specific properties. Each
PROPERTY tag must have a NAME attribute set to the property's name, and a VAL UE attribute with the
property's value.

All buffer-local properties listed in the section called “Buffer-Local Properties’ may be given valuesin
edit modes.

cont ext I nsensi ti ve - If true, the property indicates that aline can always be highlighted without
taking care of the previous line. If activated, the syntax parsing will be much faster.

The following mode properties specify commenting strings:
» commrent End - the comment end string, used by the Range Comment command.

e coment St art - the comment start string, used by the Range Comment command.
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e | i neComment - theline comment string, used by the Line Comment command.
When performing auto indent, a number of mode properties determine the resulting indent level:

» Theline and the one before it are scanned for bracketslisted in thei ndent Cl oseBr acket s and
i ndent QpenBr acket s properties. Opening brackets in the previous line increase indent.

If1'i neUpC osi ngBracket issettot r ue, then closing brackets on the current line will
line up with the line containing the matching opening bracket. For example, in Java mode
I'i neUpd osi ngBr acket issettot r ue, resulting in brackets being indented like so:

{
/1 Code
{
/!l More code
}
}

If1'i neUpCl osi ngBr acket issettof al se, theline after a closing bracket will be
lined up with the line containing the matching opening bracket. For example, in Lisp mode
I i neUpd osi ngBracket issettof al se, resulting in brackets being indented like so:

(foo 'a-paraneter
(crazy-p)
(bar baz ()))
(print "hello world")

« If the previous line contains no opening brackets, or if thedoubl eBr acket | ndent property is set
tot r ue, the previous line is checked against the regular expressionsin thei ndent Next Li ne and
i ndent Next Li nes properties. If the previous line matches the former, the indent of the current
lineisincreased and the subsequent lineis shifted back again. If the previous line matches the | atter,
the indent of the current and subsequent linesis increased.

There are corresponding uni ndent Thi sLi ne and uni ndent Next Li nes propertieswhich are
checked also, for doing the reverse-indent operation on lines that match certain regular expressions.

In Javamode, for example, thei ndent Next Li ne property is set to match control structures such
as“if”, “else”, “while”, and so on.

Thedoubl eBr acket | ndent property, if set to the default of f al se, resultsin code indented like
S0

whi | e(obj ects. hasNext ())

{
hj ect next = objects. hasNext ();
i f(next instanceof Paintable)
next . pai nt (g);
}

On the other hand, settings this property to “true” will give the following result:

whi | e(obj ects. hasNext ())
{
hj ect next = objects. hasNext ();
i f(next instanceof Paintable)
next . pai nt(g);
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}

» el ectri cKeys: characterslisted here, when typed on aline, cause the current line to be re-
indented. Notice that by default, pressing "Enter" does not re-indent the current line, only the new
line. To get this behavior, add the newline character to el ect ri cKeys inthe xml-escaped form
&#XA;

* i gnor eWi t espace: Ignore whitespace lines. This property ison (t r ue) by default. Python
language setsthisto f al se because of the special treatment of whitespaces. Note this example:

def funl:
a=1
b =2

def fun2:

Pressing C+i (Indent Lines command) on thef un2 line would usually indent this line and make
it evenwiththeb = 2 line. But with switched off i gnor eWhi t espace setting the line will stay
the way it was indented manually. i gnor eWhi t espace=f al se setting prevents any forward
indentation after awhitespace line.

Here is the complete <PROPS> tag for Java mode:

<PROPS>
<PROPERTY NAME="conmment Start" VALUE="/*" [>
<PROPERTY NAME="commrent End" VALUE="*/" [>
<PROPERTY NAME="|i neComment" VALUE="//" [|>
<PROPERTY NAME="wor dBr eakChars" VALUE=", +- =&l t; &gt ;/ ?"&anp; *" />

<l-- Auto indent -->

<PROPERTY NAME="i ndent OpenBrackets" VALUE="{" />

<PROPERTY NAME="i ndent Cl oseBrackets" VALUE="}" />

<PROPERTY NAME="unal i gnedOpenBr acket s" VALUE="(" />

<PROPERTY NAME="unal i gnedC oseBrackets" VALUE=")" />

<PROPERTY NAME="i ndent Next Li ne"
VALUE="\s*(((if|while)\s*\(|else\s*|else\s+if\s*\(|for\s*\(.*\))[*{;]*)" />

<PROPERTY NAME="uni ndent Thi sLi ne"
VALUE="".*(defaul t:\s*|case.*:.*)$" />

<PROPERTY NAME="el ectri cKeys" VALUE=":" />

<l-- set this to "true' if you want to use GNU coding style -->

<PROPERTY NAME="doubl eBracket | ndent" VALUE="fal se" />

<PROPERTY NAME="I|i neUpd osi ngBracket" VALUE="true" />

</ PROPS>

The RULES Tag

RULES tags must be placed inside the MODE tag. Each RULES tag defines aruleset. A ruleset consists
of anumber of parser rules, with each parser rule specifying how to highlight a specific syntax token.
There must be at |east one ruleset in each edit mode. There can also be more than one, with different
rulesets being used to highlight different parts of a buffer (for example, in HTML mode, one rule set
highlights HTML tags, and another highlights inline JavaScript). For information about using more than
one ruleset, see the section called “The SPAN Tag”.

The RULES tag supports the following attributes, all of which are optional:
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» SET - the name of thisruleset. All rulesets other than the first must have a name.

» | GNORE_CASE - if set to FALSE, matches will be case sensitive. Otherwise, case will not matter.
Default is TRUE.

» ESCAPE - specifies a character sequence for escaping literals. The first character following the escape
sequence is not considered as input for syntax highlighting, thus being highlighted with default token
for therule set.

* NO_WORD_SEP - any non-aphanumeric character not in thislist is treated as a word separator for the
purposes of syntax highlighting.

» DEFAULT - the token type for text which doesn't match any specific rule. Default isNULL. Seethe
section called “Token Types’ for alist of token types.

e HGHLIGHT_DIA TS
* DI A T_RE - see below for information about these two attributes.
Here is an example RULES tag:

<RULES | GNORE_CASE="FALSE" HI GHLI GHT_DI A TS="TRUE" >
parser rules go here ...
</ RULES>

Highlighting Numbers

If theHl GHLI GHT_DI @ TS attribute is set to TRUE, jEdit will attempt to highlight numbersin this
ruleset.

Any word consisting entirely of digits (0-9) will be highlighted with the DI G T token type. A word
that contains other letters in addition to digits will be highlighted with the DI G T token type only if it
matches the regular expression specified inthe DI G T_RE attribute. If this attribute is not specified, it
will not be highlighted.

Hereisan example DI G T_RE regular expression that highlights Java-style numeric literals (normal
numbers, hexadecimals prefixed with Ox, numbers suffixed with various type indicators, and floating
point literals containing an exponent). Note that newlines have been inserted here for readability.

DIG T_RE="(O[1L]?|[1-9]\d{0, 9} (\d{0, 9}[IL])?

| O[xX]\ p{XDi gi t}{1,8(\p{XDigit}{0, 8}[IL])?

| 0[ 0-7] {1, 11} ([0-7]{0, 11}[I L])?| ([0-9] +\.[0-9] *

|\.[0-9]+) ([€E][+-]?[0-9]+)?[fFdD] 2| [0-9]+([eE][+-]?[0-9]+[fFdD]?
| ([eE] [+-]?[0-9] +)?[fFdD]))"

Regular expression syntax is described in Appendix E, Regular Expressions.

Rule Ordering Requirements

Y ou might encounter this very common pitfall when writing your own modes.

Since jEdit checks buffer text against parser rulesin the order they appear in the ruleset, more specific
rules must be placed before generalized ones, otherwise the generalized rules will catch everything.

Thisis best demonstrated with an example. The following is incorrect rule ordering:
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<SPAN TYPE=" MARKUP" >
<BEGQ N>[ </ BEG N>
<END>] </ END>

</ SPAN>

<SPAN TYPE=" KEYWORD1" >
<BEGQ N>[ ! </ BEGA N>
<END>] </ END>

</ SPAN>

If you write the above in arule set, any occurrence of “[” (even things like “[\DEFINE”, etc) will be
highlighted using the first rule, because it will be the first to match. Thisis most likely not the intended
behavior.

The problem can be solved by placing the more specific rule before the general one:

<SPAN TYPE=" KEYWORD1" >
<BEG N>[ ! </ BEGA N>
<END>] </ END>

</ SPAN>

<SPAN TYPE=" MARKUP" >
<BEGQ N>[ </ BEG N>
<END>] </ END>

</ SPAN>

Now, if the buffer contains the text “[!SPECIAL]”, the rules will be checked in order, and the first rule
will be the first to match. However, if you write “[FOQ]”, it will be highlighted using the second rule,
which is exactly what you would expect.

Per-Ruleset Properties

The PROPS tag (described in the section called “The PROPS Tag”) can also be placed inside the RULES
tag to define ruleset-specific properties. The following properties can be set on a per-ruleset basis:

» comment End - the comment end string.
» coment St art - thecomment start string.
* | i neComment - the line comment string.

This allows different parts of afileto have different comment strings (in the case of HTML, for
example, in HTML text and inline JavaScript). For information about the commenting commands, see
the section called “Commenting Out Code”.

The TERMINATE Tag

The TERM NATE rule, which must be placed inside a RULES tag, specifies that parsing should stop
after the specified number of characters have been read from aline. The number of charactersto
terminate after should be specified with the AT _CHAR attribute. Here is an example:

<TERM NATE AT_CHAR="1" />

Thisruleisused in Patch mode, for example, because only the first character of each line affects
highlighting.
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The SPAN Tag

The SPAN rule, which must be placed inside a RULES tag, highlights text between a start and end string.
The start and end strings are specified inside child elements of the SPAN tag. The following attributes
are supported:

» TYPE - The token type to highlight the span with. See the section called “Token Types’ for alist of
token types.

» AT LI NE_START - If set to TRUE, the span will only be highlighted if the start sequence occurs at
the beginning of aline.

« AT_WH TESPACE_END - If set to TRUE, the span will only be highlighted if the start sequence isthe
first non-whitespace text in the line.

 AT_WORD_ START - If set to TRUE, the span will only be highlighted if the start sequence occurs at
the beginning of aword.

» DELEGATE - text inside the span will be highlighted with the specified ruleset. To delegateto a
ruleset defined in the current mode, just specify its name. To delegate to a ruleset defined in another
mode, specify a name of the form node: : r ul eset . Note that the first (unnamed) ruleset in amode
iscaled “MAIN".

» MATCH_TYPE - Controls how the start and end of the sequence will be highlighted. See the section
called “The MATCH_TYPE Attribute” for more information.

» ESCAPE - specifies a character sequence for escaping characters. The first character following the
escape sequence is not considered as input for syntax highlighting, thus being highlighted with rule's
token.

NO_LI NE_BREAK - If set to TRUE, the span will not cross line breaks.
* NO WORD BREAK - If set to TRUE, the span will not cross word breaks.

Notethat the AT_LI NE_START, AT_VWH TESPACE_END and AT_WORD START attributes can also
be used on the END element.

Here isa SPAN that highlights Java string literals, which cannot include line breaks:

<SPAN TYPE="LI TERAL1" NO_LI NE_BREAK="TRUE" >
<BEGQ N>" </ BEG N>
<END>" </ END>

</ SPAN>

Here isa SPAN that highlights Java documentation comments by delegating to the “JAVADOC” ruleset
defined elsewhere in the current mode:

<SPAN TYPE=" COMMENT2" DELEGATE="JAVADCC" >
<BEG N>/ ** </ BEG N>
<END>*/ </ END>

</ SPAN>

Hereisa SPAN that highlights HTML cascading stylesheetsinside <STYLE> tags by delegating to the
main ruleset in the CSS edit mode:

<SPAN TYPE="MARKUP" DELEGATE="css:: MAI N'>
<BEG N>&l t ; styl e&gt ; </ BEG N>
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<END>&l t ; / styl e&gt ; </ END>
</ SPAN>

The SPAN_REGEXP Tag

The SPAN_RECGEXP ruleis similar to the SPAN rule except the start sequence and optionally the end
sequence are taken to be regular expressions. In addition to the attributes supported by the SPAN tag, the
following attributes are supported:

* HASH CHAR - aliteral string which must be at the start of aregular expression.

 HASH CHARS - alist of possible literal characters, one of which must match at the start of the regular
expression.

HASH CHAR and HASH CHARS attributes are both optional, but you may only specify one, not both.

If both are specified, HASH CHARS isignored and an error is shown. Whenever possible, use aliteral
prefix to specify a SPAN_RECEXP. If the starting prefix is always the same, use HASH CHAR and
provide as much prefix as possible. Only in rare cases would you omit both attributes, such asthe case
where there is no other reliable way to get the highlighting you need, for example, with commentsin the
Cobol programming language.

In addition, the END subtag supports the attribute REGEXP, which if set to TRUE, tells the highlighter to
interpret the END text as aregular expression as well.

The regular expression match cannot span more than one line. Any text matched by groupsin the
BEQ Nregular expression is substituted in the END string. See below for an example of where thisis
useful.

Regular expression syntax is described in Appendix E, Regular Expressions.
Hereisa SPAN_REGEXP rule that highlights “read-ins’ in shell scripts:

<SPAN_REGEXP HASH CHAR="&l t;" TYPE="LI TERAL1" DELEGATE="LI TERAL" >
<BEGQ N><! [ CDATA[ <<[\ p{ Space}" "]1*([\p{A nun}_] +) [\ p{Space}' "]1*]]></ BEA N>
<END>$1</ END>

</ SPAN_RECEXP>

Hereisa SPAN_REGEXP rule that highlights constructs placed between <#f t | and >, aslong asthe
<#f t| isfollowed by aword break:

<SPAN_REGEXP TYPE="KEYWORD1" HASH CHAR="&It;" DELEGATE="EXPRESSI ON'>
<BEG N>& t ; #f t 1\ b</ BEG N>
<END>&gt ; </ END>

</ SPAN_REGEXP>

The EOL_SPAN Tag

An EOL_SPANissimilar to a SPAN except that highlighting stops at the end of the line, and no
end sequence needs to be specified. The text to match is specified between the opening and closing
ECL_SPANtags. The following attributes are supported:

» TYPE - The token type to highlight the span with. See the section called “Token Types’ for alist of
token types.

e AT _LI NE_START - If set to TRUE, the span will only be highlighted if the start sequence occurs at
the beginning of aline.
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o AT_WH TESPACE_END - If set to TRUE, the span will only be highlighted if the sequence isthe first
non-whitespace text in the line.

 AT_WORD_ START - If set to TRUE, the span will only be highlighted if the start sequence occurs at
the beginning of aword.

» DELEGATE - text inside the span will be highlighted with the specified ruleset. To delegateto a
ruleset defined in the current mode, just specify its name. To delegate to a ruleset defined in another
mode, specify aname of the form node: : r ul eset . Note that the first (unnamed) ruleset in amode
iscaled “MAIN".

» MATCH_TYPE - Controls how the start of the sequence will be highlighted. See the section called
“The MATCH_TY PE Attribute” for more information.

Hereisan EQL_ SPAN that highlights C++ comments:

<EOL_SPAN TYPE="COMVENT1" >/ / </ EOL_SPAN>

The EOL_SPAN_REGEXP Tag

The EOL_SPAN_REGEXP ruleissimilar to the EOL_ SPAN rule except the match sequence is taken
to be aregular expression. In addition to the attributes supported by the EOL_ SPAN tag, the following
attributes are supported:

* HASH CHAR - alitera string which must be at the start of aregular expression.

e HASH CHARS - alist of possible literal characters, one of which must match at the start of the regular
expression.

HASH CHAR and HASH CHARS attributes are both optional, but you may only specify one, not both.

If both are specified, HASH_CHARS isignored and an error is shown. Whenever possible, use aliteral
prefix to specify a EQL_ SPAN_REGEXP. If the starting prefix is always the same, use HASH CHAR and
provide as much prefix as possible. Only in rare cases would you omit both attributes, such as the case
where there is no other reliable way to get the highlighting you need, for example, with commentsin the
Cobol programming language.

The regular expression match cannot span more than one line.
Regular expression syntax is described in Appendix E, Regular Expressions.

Hereisan EQOL_SPAN REGEXP that highlights MS-DOS batch file comments, which start with REM
followed by any whitespace character, and extend until the end of the line;

<EOL_SPAN_REGEXP AT_WH TESPACE_END="TRUE" HASH CHAR="REM' TYPE="COMVENT1" >REM s</E

The MARK_PREVIOUS Tag

The MARK_PREVI QUS rule, which must be placed inside a RULES tag, highlights from the end of the
previous syntax token to the matched text. The text to match is specified between opening and closing
MARK_PREVI QUS tags. The following attributes are supported:

» TYPE - The token type to highlight the text with. See the section called “ Token Types’ for alist of
token types.

« AT_LI NE_START - If set to TRUE, the sequence will only be highlighted if it occurs at the
beginning of aline.
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o AT_WH TESPACE_END - If set to TRUE, the sequence will only be highlighted if it is the first non-
whitespace text in the line.

AT _WORD_ START - If set to TRUE, the sequence will only be highlighted if it occurs at the
beginning of aword.

* MATCH_TYPE - Controls how the matched region will be highlighted. See the section called “ The
MATCH_TY PE Attribute” for more information.

Hereisarule that highlights labels in Java mode (for example, “XXX:"):

<MARK_PREVI QUS AT_WH TESPACE_END=" TRUE"
MATCH_TYPE="DEFAULT" >: </ MARK_PREVI QUS>

The MARK_FOLLOWING Tag

The MARK_FOLLOW NGrule, which must be placed inside a RULES tag, highlights from the start
of the match to the next syntax token. The text to match is specified between opening and closing
MARK FOLLOW NGtags. The following attributes are supported:

» TYPE - The token type to highlight the text with. See the section called “ Token Types’ for alist of
token types.

o AT_LI NE_START - If set to TRUE, the sequence will only be highlighted if it occurs at the
beginning of aline.

» AT_WH TESPACE_END - If set to TRUE, the sequence will only be highlighted if it is the first non-
whitespace text in the line.

« AT _WORD_ START - If set to TRUE, the sequence will only be highlighted if it occurs at the
beginning of aword.

* MATCH_TYPE - Controls how the matched region will be highlighted. See the section called “ The
MATCH_TY PE Attribute” for more information.

Hereisarulethat highlights variablesin Unix shell scripts (“$SCLASSPATH”, “$IFS’, etc):

<MARK_FOLLOW NG TYPE="KEYWORD2" >$</ MARK_FOLLOW NG>

The SEQ Tag

The SEQrule, which must be placed inside a RULES tag, highlights fixed sequences of text. The text to
highlight is specified between opening and closing SEQtags. The following attributes are supported:

» TYPE - the token type to highlight the sequence with. See the section called “Token Types’ for alist
of token types.

o AT_LI NE_START - If set to TRUE, the sequence will only be highlighted if it occurs at the
beginning of aline.

» AT_WH TESPACE_END - If set to TRUE, the sequence will only be highlighted if it is the first non-
whitespace text in the line.

« AT _WORD START - If set to TRUE, the sequence will only be highlighted if it occurs at the
beginning of aword.
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» DELEGATE - if this attribute is specified, all text after the sequence will be highlighted using this
ruleset. To delegate to aruleset defined in the current mode, just specify its name. To delegateto a
ruleset defined in another mode, specify aname of the form node: : r ul eset . Note that the first
(unnamed) ruleset inamodeiscaled “MAIN".

The following rules highlight a few Java operators:

<SEQ TYPE=" OPERATOR' >+</ SEQ>
<SEQ TYPE=" OPERATOR' >- </ SEQ>
<SEQ TYPE=" OPERATOR' >* </ SEQ>
<SEQ TYPE=" OPERATOR' >/ </ SEQ>

The SEQ REGEXP Tag

The SEQ REGEXP ruleis similar to the SEQrule except the match sequence is taken to be aregular
expression. In addition to the attributes supported by the SEQtag, the following attributes are supported:

* HASH CHAR- aliteral string which must be at the start of aregular expression.

» HASH CHARS - alist of possible literal characters, one of which must match at the start of the regular
expression.

HASH CHAR and HASH CHARS attributes are both optional, but you may only specify one, not both.

If both are specified, HASH_CHARS isignored and an error is shown. Whenever possible, use aliteral
prefix to specify a SEQ REGEXP. If the starting prefix is always the same, use HASH CHAR and
provide as much prefix as possible. Only in rare cases would you omit both attributes, such as the case
where there is no other reliable way to get the highlighting you need, for example, with commentsin the
Cobol programming language.

The regular expression match cannot span more than one line.
Regular expression syntax is described in Appendix E, Regular Expressions.

NOTE: c-style character escaping for literals (such as the tab char: \t) do not work as attribute valuesin
XML. Usethe XML character entity instead. For example: & #09; instead of \t.

Hereisa SEQ REGEXP rule from moin.xml that uses the HASH CHARS attribute, to describe a
keyword (wikiword) that can start with any uppercase letter and contain lower case letters and at | east
one uppercase letter in the middle.

<SEQ REGEXP HASH_CHARS=" ABCDEFGHI JKLMNOPQRSTUWAKYZ" AT_WORD_START="TRUE"
TYPE=" KEYWORD2" >[ A- Z] [ a- z] +[ A- Z] [ a- zA- Z] +</ SEQ REGEXP>

The IMPORT Tag

The | MPORT tag, which must be placed inside a RULES tag, loads all rules defined in a given ruleset
into the current ruleset; in other words, it has the same effect as copying and pasting the imported
ruleset.

The only required attribute DELEGATE must be set to the name of aruleset. To import aruleset defined
in the current mode, just specify its name. To import aruleset defined in another mode, specify aname
of theform node: : r ul eset . Note that the first (unnamed) ruleset in amode s called “MAIN”.
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One quirk is that the definition of the imported ruleset is not copied to the location of the | MPORT tag,
but rather to the end of the containing ruleset. This has implications with rule-ordering; see the section
called “Rule Ordering Requirements”.

Here is an example from the PHP mode, which extends the inline JavaScript highlighting to support
embedded PHP:

<RULES SET="JAVASCRI PT+PHP" >

<SPAN TYPE="MARKUP" DELEGATE="php: : PHP" >
<BEG N>&l t ; ?php</ BEG N>
<END>?8&gt ; </ END>

</ SPAN>

<SPAN TYPE=" MARKUP" DELEGATE="php: : PHP">
<BEG N>&l t ; ?</ BEG N>
<END>?&gt ; </ END>

</ SPAN>

<SPAN TYPE=" MARKUP" DELEGATE="php: : PHP">
<BEG N>&l t ; %</ BEG N>
<END>%&gt ; </ END>

</ SPAN>

<I MPORT DELEGATE="j avascript:: MAIN'/>
</ RULES>

The KEYWORDS Tag

The KEYWORDS tag, which must be placed inside a RULES tag and can only appear once, specifiesalist
of keywords to highlight. Keywords are similar to SEQs, except that SEQs match anywhere in the text,
whereas keywords only match whole words. Words are considered to be runs of text separated by non-
alphanumeric characters.

The KEYWORDS tag does not define any attributes.

Each child element of the KEYWORDS tag is an element whose name is a token type, and whose
content is the keyword to highlight. For example, the following rule highlights the most common Java
keywords:

<KEYWORDS>
<KEYWORD1>i f </ KEYWORD1 >
<KEYWORD1>el se</ KEYWORD1 >
<KEYWORD3>i nt </ KEYWORD3>
<KEYWORD3>voi d</ KEYWORD3>
</ KEYWORDS>

Token Types

The various token types are used to syntax highlight particular words in alanguage. This makes code
easier to read. Thereis awide latitude in the usage of the token types, and really it depends on the
specifics of the language as to which token represents which type. Some examples are given below, but
these are just guidelines, not hard and fast rules.
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Many languages include constructs from other languages. One common example is html files

can include javascript and css blocks. Several of the mode tags support a DELEGATE attribute,
which will allow a section of text to be passed to a different mode for highlighting. The html mode
delegates to the javascript mode for javascript blocks and to the css mode for style blocks. Use of the
DELEGATE attribute is highly encouraged when appropriate since it makes writing modes easier,
reduces duplication, and promotes visual consistency across languages.

Parser rules can highlight tokens using any of the following token types:
* NULL - no specid highlighting is performed on tokens of type NULL
« COMVENT1

¢ COMVENT2

 COMVENT3

 COMVENT4

jEdit supports four different types of comment tokens. Generally, comments are programmer-readable
constructs that are ignored by compilers and interpreters. As an example, the lisp mode defines four
comment types:

<EOL_SPAN TYPE="COMMENT4">;;;;</[EOL_SPAN>
<EOL_SPAN TYPE="COMMENTS3">;;;</EOL_SPAN>
<EOL_SPAN TYPE="COMMENT2">;;</EOL_SPAN>
<EOL_SPAN TYPE="COMMENT1">;</EOL_SPAN>

* FUNCTI ON

The function token isintended to identify functions, methods, procedures, routines, or named
subprograms.

e DIAT
The digit token is to identify numbers.

* | NVALI D
Theinvalid typeisto indicate that particular words are not to be used, for example, the java mode
defined both "goto" and "const" asinvalid words. These are words that are defined by the language,
but are not to be used.

* KEYWORD1

* KEYWORD2

e KEYWORD3

* KEYWORD4
Keywords are used to identify well-defined words within alanguage. Some languages naturally divide

keywords into groups, for example, the pascal mode identifies "for" asa KEYWORD1, "private" asa
KEYWORD2, and "int" asa KEYWORD3.
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* LABEL

A label is generally a named position within a source, for example, the ada mode defined alabel as
<<foo>>.

* LI TERALL
* LI TERAL2
* LI TERAL3
* LI TERAL4

Literals are usually, but not always, uninterpreted strings, for example, "foo" or 'bar'. There are awide
variety of usages of literalsin the modefiles.

* MARKUP

The markup token is generally used in the various "markup” languages, such as xml and html.
Markup is used for those elements that are not specified as words belonging to the language. For
example, in html, <body> would be considered a keyword, where <foo> would be considered
markup.

* OPERATOR

Common examples of operators are the math symbols, such as'+', -, and so on.

The MATCH_TYPE Attribute

The MATCH_TYPE attribute is used by some of the rules to control how the region matched by the rule
will be highlighted.

For example, when using a MARK_PREVI OUS rule to highlight afunction call of theformf cal | (),
the following rule could be used:

<MARK_PREVI QUS TYPE="FUNCTI ON' NMATCH_TYPE=" OPERATCR" >( </ MARK_PREVI QUS>

Thiswould causef cal | to be highlighted as FUNCTI ON, and ( to be highlighted as OPERATOR. In
this case, to maintain bracket matching working, a SEQrule would have to be added to match ) and
mark it as OPERATOR.

The MATCH_TYPE attribute value can be any of the valid token types, or the following special values:

* RULE: thisisthe default value. It tells the syntax system to use the same token type asthe TY PE
attribute of therule. Thisis equivalent to EXCLUDE MATCH=" FALSE" in 4.2 and earlier modefiles.

» CONTEXT: using this value tells the syntax system to mark the matched region using the
default token type for the current rule set. In 4.2 and earlier mode files, this was specified by
EXCLUDE_MATCH="TRUE" .
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The easiest way to install anew mode locally isto use the Editing dialog found under Utilities - Global
Options. At the bottom of thisdialog is an "Add Maode" button. Clicking this button shows adialog to
add a modeto jEdit. Simply fill in the blanks and the mode file will be put in the proper place and the
catalog file will be updated appropriately. Modes added this way can be removed by selecting the mode
in the Editing dialog, then clicking the "Delete Mode" button. This button will only appear for modes
that exist in the user settings directory. Core modes, that is, those modes distributed with jEdit cannot be
deleted thisway. The details of adding a mode by hand are below.

jEdit looks for edit modes in two locations; the modes subdirectory of the jEdit settings directory, and
the nodes subdirectory of the jEdit install directory. The location of the settings directory is system-
specific; see the section called “ The jEdit Settings Directory”.

Each mode directory containsacat al og file. All edit modes contained in that directory must be listed
in the catal og, otherwise they will not be available to jEdit.

Catalogs, like modes themselves, are written in XML. They consist of a single MODES tag, with a
number of MODE tags inside. Each mode tag associates a mode name with an XML file, and specifies
the file name and first line pattern for the mode. A sample mode catal og looks as follows:

<?xm version="1.0"?>
<! DOCTYPE CATALOG SYSTEM "cat al og. dt d">

<MODES>
<MODE NAME="shel |l script" FILE="shellscript.xn"
FI LE_NAME_G.OB="*.sh"
FI RST_LINE_G.OB="#!/*sh*" [|>
</ MODES>

In the above example, amode named “ shellscript” is defined, and is used for files whose names end with
. sh, or whose first line starts with “#!/” and contains “sh”.

The MODE tag supports the following attributes:

* NAME - the name of the edit mode, asit will appear in the Buffer Options dialog box, the status bar,
and so on.

* FI LE - the name of the XML file containing the mode definition.

* FI LE_NAME_ G OB - files whose names match this glob pattern will be opened in this edit
mode. This can also specify full paths, if the glob pattern contains a path separator character.
FI LE_NAME_GL.OB can be specified in the nodes/ cat al og file, or the modefile itself. See the
FI LE_NAME_GL.OB for apacheconf . xm innodes/ cat al og for an example of full path
filename globbing.

e FI RST_LI NE_GLOB - fileswhose first line matches this glob pattern will be opened in this edit
mode.

Glob pattern syntax is described in Appendix D, Glob Patterns.
Tip

If an edit mode in the user-specific catalog has the same name as an edit mode in the system
catalog, the version in the user-specific catalog will override the system default.
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When abuffer is opened, jEdit must choose an edit mode for that buffer. It checks conditionsin this
order to decide which edit mode to use:

1. thefilenameis an exact match for the FI LE_NAMVE GLOB.

2. thefilename matchesthe FI LE_NAME_GLOB and the first line of the file matches the
FIRST_LINE_GLOB

3. thefilename matchesthe FI LE_ NAME_GLOB

4. thefirst line of the file matchesthe FI RST_LI NE_ GLOB
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Chapter 12. Updating Edit Modes
From jEdit 4.2t0 4.4

1. All regular expressions in mode files were rewritten to use java.util.regex instead of gnu.regexp.

2. HASH_CHAR handling of xxx_ REGEXP elements has been updated, as explained in the section
caled “The SPAN_REGEXP Tag”.

3. The EXCLUDE_MATCH attribute got superseded by MATCH_TYPE. The attribute values translate
from TRUE to CONTEXT and from FALSE to RULE, respectively. For more information see the
section called “The MATCH_TY PE Attribute”.

4. NO_ESCAPE is now deprecated and ignored by the parsing engine. ESCAPE is now avalid attribute
for SPAN and SPAN_REGEXP rules.
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Part Ill. Writing Macros

This part of the user's guide covers writing macros for jEdit.

First, we will tell you alittle about BeanShell, jEdit's macro scripting language. Next, we will walk through a few
simple macros. We then present and analyze a dialog-based macro to illustrate additional macro writing techniques.
Finally, we discuss several tips and techniques for writing and debugging macros.




Chapter 13. Macro Basics

Introducing BeanShell

Here is how BeanShell's author, Pat Niemeyer, describes his creation:

“Beanshell isasmall, free, embeddable, Java source interpreter with object scripting
language features, written in Java. BeanShell executes standard Java statements

and expressions, in addition to obvious scripting commands and syntax. BeanShell
supports scripted objects as simple method closures like those in Perl and JavaScript.”

Y ou do not have to know anything about Java to begin writing your own jEdit macros. But if you know
how to program in Java, you aready know how to write BeanShell scripts. The major strength of using
BeanShell with a program written in Javaisthat it allows the user to customize the program's behavior
using the same interfaces designed and used by the program itself. BeanShell can turn awell-designed
application into a powerful, extensible toolkit.

This guide focuses on using BeanShell in macros. If you are interested in learning more about BeanShell
generaly, consult the BeanShell web site. Information on how to run and organize macros, whether
included with the jEdit installation or written by you, can be found in Chapter 8, Using Macros.

Single Execution Macros

Asnoted in the section called “How jEdit Organizes Macros’, you can save a BeanShell script of any
length as atext file with the . bsh extension and run it from the M acr os menu. There are three other
ways jEdit lets you use BeanShell quickly, without saving a script to storage, on a“onetime only” basis.
Y ou will find them in the Utilities menu.

Utilities>BeanShell>Evaluate BeanShell Expression displays atext input dialog that asks you to
type asingle line of BeanShell commands. Y ou can type more than one BeanShell statement so long as
each of them ends with a semicolon. If BeanShell successfully interprets your input, a message box will
appear with the return value of the last statement.

Utilities>BeanShell>Evaluate For Selected Lines displays atext input dialog that asks you to type
asingle line of BeanShell commands. The commands are evaluated for each line of the selection.

In addition to the standard set of variables described in the section called “ Predefined Variablesin
BeanShell”, this command defines the following:

* | i ne - theline number, from the start of the buffer. Thefirst line is numbered 0.
* | ndex - theline number, from the start of the selection. The first line is numbered 0.
* text -thetext of theline.

Try typing an expression like(line + 1) + ": " + text intheEvaluate For Selected Lines
dialog box. Thiswill add aline number to each selected line beginning with the number 1.

The BeanShell expression you enter will be evaluated and substituted in place of the entire text of a
selected line. If you want to leave the lin€'s current text as an element of the modified line, you must
include the defined variable t ext as part of the BeanShell expression that you enter.

Utilities>BeanShell>Evaluate Selection evaluates the selected text as a BeanShell script and replaces it
with the return value of the statement.
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Using Evaluate Selection is an easy way to do arithmetic calculations inline while editing. BeanShell
uses numbers and arithmetic operations in an ordinary, intuitive way.

Try typing an expression like ( 3745* 856) +74 in the buffer, select it, and choose
Utilities>BeanShell>Evaluate Selection. The selected text will be replaced by the answer, 3205794.

Console plugin

Y ou can aso do the same thing using the BeanShell interpreter option of the Console plugin.

The Mandatory First Example

Macr os. nessage(view, "Hello world!");

Running this one line script causes jEdit to display a message box (more precisely, aJOpt i onPane
object) with the traditional beginner's message and an OK button. Let's see what is happening here.

This statement calls a static method (or function) named nessage in jEdit's Macros class. If you don't
know anything about classes or static methods or Java (or C++, which employs the same concept),

you will need to gain some understanding of afew terms. Obviously thisis not the place for academic
precision, but if you are entirely new to object-oriented programming, here are afew skeleton ideas to
help you with BeanShell.

» An object isacollection of datathat can beinitialized, accessed and manipulated in certain defined
ways.

* A classisa specification of what data an object contains and what methods can be used to work
with the data. A Java application consists of one or more classes (in the case of jEdit ,over 600
classes) written by the programmer that defines the application’'s behavior. A BeanShell macro uses
these classes, along with built-in classes that are supplied with the Java platform, to define its own
behavior.

» A subclass (or child class) is a class which uses (or “inherits”) the data and methods of its parent
class along with additions or modifications that alter the subclass's behavior. Classes are typically
organized in hierarchies of parent and child classes to organize program code, to define common
behavior in shared parent class code, and to specify the types of similar behavior that child classes
will perform in their own specific ways.

» A method (or function) is a procedure that works with datain a particular object, other data (including
other objects) supplied as parameters, or both. Methods typically are applied to a particular object
which is an instance of the class to which the method belongs.

» A static method differs from other methods in that it does not deal with the datain a particular object
but isincluded within a class for the sake of convenience.

Javahas arich set of classes defined as part of the Java platform. Like all Java applications, jEdit is
organized as a set of classes that are themselves derived from the Java platform's classes. We will refer
to Java classes and jEdit classes to make this distinction. Some of jEdit's classes (such as those dealing
with regular expressions and XML ) are derived from or make use of classes in other open-source Java
packages. Except for BeanShell itself, we won't be discussing them in this guide.

In our one line script, the static method Macr os. nessage() hastwo parameters because that is the
way the method is defined in the Macros class. Y ou must specify both parameters when you call the
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function. Thefirst parameter, vi ew, is avariable naming the current, active View object. Information
about pre-defined variables can be found in the section called “ Predefined Variables in BeanShell”.

The second parameter, which appears to be quoted text, isastring literal - a sequence of characters
of fixed length and content. Behind the scenes, BeanShell and Javatake this string literal and use it
to createa St r i ng object. Normally, if you want to create an object in Java or BeanShell, you must
construct the object using the new keyword and a constructor method that is part of the object's class.
WEe'l show an example of that later. However, both Java and BeanShell let you use a string literal
anytime a method's parameter callsfor aSt ri ng.

If you are a Java programmer, you might wonder about a few things missing from this one line program.
Thereis no class definition, for example. Y ou can think of a BeanShell script as an implicit definition

of amai n() method in an anonymous class. That isin fact how BeanShell isimplemented; the class

is derived from a BeanShell class called X This. If you don't find that helpful, just think of a script

as one or more blocks of procedural statements conforming to Java syntax rules. Y ou will also get

along fine (for the most part) with C or C++ syntax if you leave out anything to do with pointers or
memory management - Java and BeanShell do not have pointers and deal with memory management
automatically.

Another missing item from a Java perspectiveisapackage statement. In Java, such a statement is used
to bundle together a number of files so that their classes become visible to one another. Packages are not
part of BeanShell, and you don't need to know anything about them to write BeanShell macros.

Finally, therearenoi nport statementsinthisscript. In Java, ani nport statement makes public
classes from other packages visible within the file in which the statement occurs without having to
specify afully qualified class name. Without an import statement or a fully qualified name, Java cannot
identify most classes using a single name as an identifier.

jEdit automatically imports a number of commonly-used packages into the namespace of every
BeanShell script. Because of this, the script output of arecorded macro does not containi npor t
statements. For the same reason, most BeanShell scripts you write will not requirei mpor t statements.

Javarequiresi nport statement to be located at the beginning of a source file. BeanShell alows you
toplacei nport statements anywhere in ascript, including inside ablock of statements. Thei npor t
statement will cover all names used following the statement in the enclosing block.

If you try to use aclass that is not imported without its fully-qualified name, the BeanShell interpreter
will complain with an error message relating to the offending line of code.
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Hereisthe full list of packages automatically imported by jEdit:

j ava. amt

j ava. awm . event

j ava. net

java. util

java.io

java.l ang

j avax. swi ng

j avax. swi ng. event
org.gjt.sp.jedit
org.gjt.sp.jedit. browser
org.gjt.sp.jedit. buffer
org.gjt.sp.jedit. gui
org.gjt.sp.jedit. help
org.gjt.sp.jedit.io
org.gjt.sp.jedit. nmsg
org.gjt.sp.jedit.options
org.gjt.sp.jedit. plugi nngr
org.gjt.sp.jedit.print
org.gjt.sp.jedit.search
org.gjt.sp.jedit.syntax
org.gjt.sp.jedit.textarea
org.gjt.sp.util

Predefined Variables in BeanShell

The following variables are always available for use in BeanShell scripts:
» buf f er - aBuffer object represents the contents of the currently visible open text file.

* vi ew- A View represents the current top-level editor window, extending Java's JFr ane class, that
contains the various visible components of the program, including the text area, menu bar, toolbar,
and any docked windows.

This variable has the same value as the return value of:
j Edit.get ActiveView)

» edi t Pane - an EditPane object contains a text area and buffer switcher. A view can be split to
display edit panes. Among other things, the EditPane class contains methods for selecting the buffer
to edit.

Most of the time your macros will manipulate the buf f er or thet ext Ar ea. Sometimes you will
need to use vi ew as a parameter in amethod call. You will probably only need to use edi t Pane if
your macros work with split views.

This variable has the same value as the return val ue of:
vi ew. get Edi t Pane()

* text Area - aJEditTextAreais the visible component that displays the current buffer.
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This variable has the same value as the return value of:
edi t Pane. get Text Area()

» wm- a DockableWindowManager is the visible component that manages dockable windowsin the
current view. This classis discussed in detail in Part 1V, “Writing Plugins’. This object is useful for
writing macros that interface with, open, or close plugin windows.

This variable has the same value the return value of:
vi ew. get Dockabl eW ndowivanager ()
e scri pt Pat h - set to the full path of the script currently being executed.

Note that these variables are set at the beginning of macro execution. If the macro switches views,
buffers or edit panes, the variable values will be out of date. In that case, you can use the equivalent
method calls.

Helpful Methods in the Macros Class

Including message() , there arefive static methods in the Macros class that alow you to converse
easily with your macros. They all encapsulate calls to methods of the Java platform's JOpt i onPane
class.

 public static void nmessage(Conponent conp, String nmessage);
 public static void error(Component conp, String nmessage);
e public static String input(Conponent conp, String pronpt);

e public static String input(Conponent conp, String pronpt, String
def aul t Val ue) ;

* public static int confirn{Conponent conp, String pronpt, int
butt ons);

The format of these four declarations provides a concise reference to the way in which the methods
may be used. The keyword publ i ¢ means that the method can be used outside the Macros class. The
aternativesarepr i vat e and pr ot ect ed. For purposes of BeanShell, you just have to know that
BeanShell can only use public methods of other Java classes. The keyword st at i ¢ we have already
discussed. It means that the method does not operate on a particular object. You call a static function
using the name of the class (like Macros) rather than the name of a particular object (likevi ew). The
third word is the type of the value returned by the method. The keyword voi d is Java's way of saying
the the method does not have areturn value.

Theer ror () method worksjust likemessage() but displays an error icon in the message box.
Thei nput () method furnishes atext field for input, an OK button and a Cancel button. If Cancel is
pressed, the method returnsnul | . If OK ispressed, a St r i ng containing the contents of the text field
isreturned. Note that there are two forms of thei nput () method; the first form with two parameters
displays an empty input field, the other forms |ets you specify an initial, default input value.

For those without Java experience, it isimportant to know that nul | is not the same as an empty,
“zero-length” St ri ng. It is Java's way of saying that there is no object associated with this variable.
Whenever you seek to use areturn value fromi nput () inyour macro, you should test it to seeif it is
nul | . In most cases, you will want to exit gracefully from the script with ar et ur n statement, because
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the presence of anull value for an input variable usually means that the user intended to cancel macro
execution. BeanShell will complainif you call any methodson anul | object.

Theconfirn() method in the Macros classis alittle more complex. The but t ons parameter
hasani nt type, and the usual way to supply avalueisto use one of the predefined values taken
from Java's JOpt i onPane class. You can choose among JOpt i onPane. YES_NO_OPTI ON,
JOpti onPane. YES NO CANCEL_ OPTI ON, or JOpt i onPane. OK_CANCEL_OPTI ON.
Thereturn value of the method isalso ani nt , and should be tested against the value of other
predefined constants: JOpt i onPane. YES_OPTI ON, JOpt i onPane. NO_CPTI ON,

JOpt i onPane. OK_OPTI ONor JOpt i onPane. CANCEL_CGPTI ON.

We've looked at using Macr os. message( ) . To use the other methods, you would write something
like the following:

Macros. error(view, "Goodbye, cruel world!");
String result = Macros.input(view, "Type sonething here.");

String result = Macros.input(view, "Wen were you born?",
"I don't remenber, | was very young at the time");

int result = Macros.confirmview, "Do you really want to | earn"
+ " about BeanShel | ?", JOpti onPane. YES_NO _OPTI ON);

In the last three examples, placing theword St ri ng or i nt before the variable namer esul t tells
BeanShell that the variable refersto an integer or aSt r i ng object, even before a particular value
isassigned to the variable. In BeanShell, this declaration of the type of r esul t is not necessary;
BeanShell can figure it out when the macro runs. This can be helpful if you are not comfortable with
specifying types and classes; just use your variables and |et BeanShell worry about it.

Note that macros are not limited to using these methods for presenting a user interface. In fact, full-
blown user interfaces using the Java Swing APIs are also possible, and will be covered later onin
Chapter 14, A Dialog-Based Macro.

BeanShell Dynamic Typing

Without an explicit type declaration like St ri ng r esul t , BeanShell variables can change their type
at runtime depending on the object or data assigned to it. This dynamic typing allows you to write code
likethis (if you really wanted to):

/1 note: no type declaration
result = Macros.input(view, “Type sonething here.”);

/1 this is our predefined, current View
result = view,

/1 this is an “int” (for integer);

/1 in Java and BeanShell, int is one of a small nunber
/1 of “primtive” data types which are not classes
result = 14;

However, if you first declared r esul t to betype St ri ng and and then tried these reassignments,
BeanShell would complain. While avoiding explicit type declaration makes writing macro code simpler,
using them can act as a check to make sure you are not using the wrong variable type of object at alater
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point in your script. It also makesit easier (if you are so inclined) to take a BeanShell “prototype” and
incorporate it in a Java program.

One last thing before we bury our first macro. The double slashes in the examples just above signify that
everything following them on that line should be ignored by BeanShell as a comment. Asin Javaand C/
C++, you can also embed comments in your BeanShell code by setting them off with pairsof / * */ , as
in the following example:

/* This is a long comment that covers several lines
and will be totally ignored by BeanShell regardless of how
many lines it covers */

Now For Something Useful

Here isamacro that inserts the path of the current buffer in the text:

String newText = buffer.getPath();
t ext Ar ea. set Sel ect edText ( newText) ;

Unlikein our first macro example, here we are calling class methods on particular objects. First, we
call get Pat h() on the current Buffer object to get the full path of the text file currently being edited.
Next, we call set Sel ect edText () on the current text display component, specifying the text to be
inserted as a parameter.

In preciseterms, the set Sel ect edText () method substitutes the contents of the St r i ng parameter
for arange of selected text that includes the current caret position. If no text is selected at the caret
position, the effect of this operation is simply to insert the new text at that position.

Here's afew aternatives to the full file path that you could use to insert various useful things:

/1 the file name (w thout full path)
String newText = buffer.getNanme();

/1 today's date
i mport java.text.DateFornat;

String newText = DateFormat. get Dat el nst ance()
.format (new Date());

/1 a line count for the current buffer
String newlText = "This file contains "
+ text Area. getLineCount() + " lines.";

Here are brief comments on each:
 Inthefirst, thecal to get Nanme() invokes another method of the Buffer class.
» The syntax of the second example chains the results of several methods. Y ou could write it this way:

i nport java.text. DateFormat;

Date d = new Date();

Dat eFor mat df Dat eFor mat . get Dat el nst ance() ;
String result df . format (d);

Taking the piecesin order:
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A Java Dat e object is created using the new keyword. The empty parenthesis after Dat e
signify acall on the constructor method of Dat e having no parameters; here, aDat e is created
representing the current date and time.

Dat eFor mat . get Dat el nst ance() isastatic method that creates and returns a

Dat eFor mat object. Asthe name implies, Dat eFor mat isaJavaclassthat takes Dat e objects
and produces readable text. The method get Dat el nst ance() returnsaDat eFor mat object
that parses and formats dates. It will use the default locale or text format specified in the user's Java
installation.

Finally, Dat eFor mat . f or mat () iscalled on the new Dat eFor mat object using the Dat e
object as aparameter. Theresultisa St ri ng containing the date in the default locale.

Note that the Dat e classiscontainedinthej ava. uti | package, so an explicit import statement
isnot required. However, Dat eFor nat ispart of thej ava. t ext package, whichis not
automatically imported, so an expliciti npor t statement must be used.

The third example shows three items of note:

e get Li neCount () isamethod in jEdit's JEditTextAreaclass. It returnsani nt representing
the number of linesin the current text buffer. We call it ont ext Ar ea, the pre-defined, current
JEditTextArea object.

» The use of the + operator (which can be chained, as here) appends objects and string literalsto
return asingle, concatenated St r i ng.

104


../api/org/gjt/sp/jedit/textarea/JEditTextArea.html
../api/org/gjt/sp/jedit/textarea/JEditTextArea.html

Chapter 14. A Dialog-Based Macro

Now we will ook at a more complicated macro which will demonstrate some useful techniques and
BeanShell features.

Use of the Macro

Our new example adds prefix and suffix text to a series of selected lines. This macro can be used to
reduce typing for a series of text items that must be preceded and following by identical text. In Java, for
example, if we are interested in making a series of callsto St ri ngBuf f er . append() to construct a
lengthy, formatted string, we could type the parameter for each call on successive lines as follows:

profileString_1

secret Thing.toString()
nane

addr ess

addr essSupp

city

“stat e/ provi nce”
country

Our macro would ask for input for the common “prefix” and “suffix” to be applied to each ling; in this
case, the prefix isour St ri ngBuf f er . append( and the suffix is) ; . After selecting these lines and
running the macro, the resulting text would look like this:

our Stri ngBuffer.append(profileString_1);

our St ri ngBuf fer. append(secret Thing.toString());
our St ri ngBuf f er. append( nane);

our Stri ngBuf f er. append( addr ess) ;

our St ri ngBuf f er. append( addr essSupp) ;

our Stri ngBuffer. append(city);

our St ri ngBuf fer. append(“state/province”);

our St ri ngBuf fer. append(country);

Listing of the Macro

The macro script follows. You can find it in the jEdit distribution in the Text subdirectory of the
nmacr os directory. You can aso try it out by invoking Macros>Text>Add Prefix and Suffix.

/1 begi nning of Add_Prefix_and_Suffix. bsh

/1 inmport statement (see the section called “Inport Statenents”)
i mport javax.sw ng. border. *;

/1 main routine
voi d prefixSuffixDi al og()
{
/1 create dialog object (see the section called “Create the Dial 0g”)
title = “Add prefix and suffix to selected |ines”;
di al og = new JDi al og(view, title, false);
content = new JPanel (new BorderLayout());
content . set Border (new EnptyBorder (12, 12, 12, 12));
content . set PreferredSi ze(new D nmensi on(320, 160));
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di al og. set Cont ent Pane(content);

/1 add the text fields (see the section called “Create the Text Fields”)
fi el dPanel = new JPanel (new Gi dLayout(4, 1, 0, 6));

prefixField = new Hi storyTextFi el d(“nacro. add-prefix”);
prefixLabel = new JLabel (“Prefix to add:");
suffixField = new Hi storyTextFi el d(“macro. add-suffix”);

suf fi xLabel new JLabel (“Suffix to add:”);
fi el dPanel . add( prefi xLabel );

fi el dPanel . add( prefi xFi el d);

fi el dPanel . add(suffi xLabel);

fi el dPanel . add(suffi xFi el d);
content.add(fi el dPanel, “Center”);

/! add a panel containing the buttons (see the section called “Create the Butt

butt onPanel = new JPanel ();

but t onPanel . set Layout (new BoxLayout ( butt onPanel
BoxLayout . X AXI S)) ;

but t onPanel . set Bor der (new Enpt yBorder (12, 50, 0, 50));

but t onPanel . add( Box. creat ed ue());

ok = new JButton(“OK");

cancel = new JButton(“Cancel”);

ok. set PreferredSi ze(cancel . get PreferredSi ze());

di al og. get Root Pane() . set Def aul t But t on( ok) ;

but t onPanel . add( ok) ;

but t onPanel . add( Box. cr eat eHori zontal Strut (6));

but t onPanel . add( cancel ) ;

but t onPanel . add( Box. creat ed ue());

cont ent . add( butt onPanel , “South”);

/1 register this method as an ActionListener for

/1 the buttons and text fields (see the section called “Register the Action Li
ok. addActi onLi st ener (thi s);

cancel . addAct i onLi stener(this);

prefixFi el d. addActi onLi stener (this);

suf fi xFi el d. addAct i onLi st ener (this);

/1 locate the dialog in the center of the

/1 editing pane and make it visible (see the section called “Make the Dialog V
di al og. pack();

di al og. set Locati onRel ati veTo(vi ew);

di al og. set Def aul t G oseOper ati on(JDi al og. DI SPOSE_ON_CLOSE)

di al og. set Vi si bl e(true);

/1 this nethod will be called when a button is clicked
/1 or when ENTER is pressed (see the section called “The Action Listener”)
voi d actionPerformed(e)

{
i f(e.getSource() != cancel)
{
processText ();
}
di al og. di spose();
}
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/1 this is where the work gets done to insert
/1 the prefix and suffix (see the section called “Get the User's Input”)
voi d processText ()

{

prefix prefixFi el d. get Text ();

suffix = suffixField.getText();

if(prefix.length() == 0 & suffix.length() == 0)
return;

prefixFi el d. addCurrent ToH story();

suf fi xFi el d. addCur rent ToHi story();

/1 text manipul ati on begins here using calls
/1 to jEdit methods (see the section called “Call jEdit Methods to Manipu
buf f er. begi nConpoundEdi t () ;
sel ect edLi nes = textArea. get Sel ect edLi nes();
for(i = 0; i < selectedLines.length; ++i)
{

of fsetBOL = textArea.getLineStart O fset(

sel ectedLi nes[i]);

t ext Area. set Car et Posi ti on(of fset BOL) ;

t ext Area. goToSt art Of Wi t eSpace(fal se);

t ext Ar ea. goToEndCOF Whi t eSpace(true);

text = textArea.getSel ectedText();

if(text == null) text ="";

t ext Area. set Sel ect edText (prefix + text + suffix);

}
buf f er. endConpoundEdi t () ;

}

/1 this single line of code is the script's main routine
/1 (see the section called “The Main Routine”)
prefixSuffixDial og();

/1 end of Add_Prefix_and Suffix.bsh

Analysis of the Macro

Import Statements

/1 inport statenent
i mport javax.sw ng. border. *;

This macro makes use of classesinthej avax. swi ng. bor der package, which is not automatically
imported. Aswe mentioned previously (see the section called “ The Mandatory First Example”), jEdit's
implementation of BeanShell causes a number of classes to be automatically imported. Classes that are
not automatically imported must be identified by afull qualified name or be the subject of ani npor t
statement.

Create the Dialog

/1 create dial og object
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title = “Add prefix and suffix to selected |ines”;
di al og = new JDi al og(view, title, false);

content = new JPanel (new BorderLayout());

cont ent . set Border (new EnptyBorder (12, 12, 12, 12));
di al og. set Cont ent Pane(content);

To get input for the macro, we need a dialog that provides for input of the prefix and suffix strings, an
OK button to perform text insertion, and a Cancel button in case we change our mind. We have decided
to make the dialog window non-modal. Thiswill alow us to move around in the text buffer to find
things we may need (including text to cut and paste) while the macro is running and the dialog is visible.

The Javaobject we needisaJDi al og object from the Swing package. To construct one, we use the
new keyword and call a constructor function. The constructor we use takes three parameters: the owner
of the new dialog, the title to be displayed in the dialog frame, and abool ean parameter (t r ue or

f al se) that specifies whether the dialog will be modal or non-modal. We definethe variabletit| e
using astring literal, then use it immediately in the JDi al og constructor.

A JDi al og object isawindow containing a single object called a content pane. The content pane

in turn contains the various visible components of the dialog. A JDi al og creates an empty content
pane for itself as during its construction. However, to control the dialog's appearance as much as
possible, we will separately create our own content pane and attach it to the JDi al og. We do this
by creating aJPanel object. A JPanel isalightweight container for other components that can be
set to agiven size and color. It also contains alayout scheme for arranging the size and position of its
components. Here we are constructing aJPanel as a content pane with aBor der Layout . We put
aEnpt yBor der inside it to serve as a margin between the edge of the window and the components
inside. We then attach the JPanel asthe dialog's content pane, replacing the dialog's home-grown
version.

A Bor der Layout isone of the simpler layout schemes available for container objects like JPanel .
A Bor der Layout dividesthe container into five sections: “North”, “ South”, “East”, “West” and
“Center”. Components are added to the layout using the container's add method, specifying the
component to be added and the section to which it is assigned. Building a component like our dialog
window involves building a set of nested containers and specifying the location of each of their member
components. We have taken the first step by creating a JPanel asthe dialog's content pane.

Create the Text Fields

/1 add the text fields
fi el dPanel = new JPanel (new Gi dLayout (4, 1, 0, 6));

prefixField = new Hi storyTextFi el d("nacro. add-prefix");
prefixLabel = new JLabel (“Prefix to add”:);
suffixField = new Hi storyTextFi el d(“macro. add-suffix”);

suf fi xLabel new JLabel (“Suffix to add:”);
fi el dPanel . add( prefi xLabel );

fi el dPanel . add( prefi xFi el d);

fi el dPanel . add(suffi xLabel);

fi el dPanel . add(suffi xFi el d);
content.add(fiel dPanel, “Center”);

Next we shall create a smaller panel containing two fields for entering the prefix and suffix text and two
labels identifying the input fields.

For the text fields, we will use jEdit's HistoryTextField class. It is derived from the Java Swing class
JText Fi el d. Thisclass offers the enhancement of astored list of prior values used astext input.
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When the component has input focus, the up and down keys scroll through the prior values for the
variable.

To create the History TextField objects we use a constructor method that takes a single parameter: the
name of the tag under which history values will be stored. Here we choose names that are not likely to
conflict with existing jEdit history items.

The labels that accompany the text fields are JLabel objects from the Java Swing package. The
constructor we use for both labels takes the label text asasingle St r i ng parameter.

We wish to arrange these four components from top to bottom, one after the other. To achieve that,

we useaJPanel container object named f i el dPanel that will be nested inside the dialog's

content pane that we have already created. In the constructor for f i el dPanel , we assigh anew

Gri dLayout with theindicated parameters: four rows, one column, zero spacing between columns (a
meaningless element of agrid with only one column, but neverthel ess arequired parameter) and spacing
of six pixels between rows. The spacing between rows spreads out the four “grid” elements. After the
components, the panel and the layout are specified, the componentsare added to f i el dPanel topto
bottom, one “grid cell” at atime. Finally, the completef i el dPanel isadded to the dialog's content
pane to occupy the “ Center” section of the content pane.

Create the Buttons

/1 add the buttons

butt onPanel = new JPanel ();

but t onPanel . set Layout (new BoxLayout ( butt onPanel ,
BoxLayout. X AXI S));

but t onPanel . set Bor der (new Enpt yBorder (12, 50, 0, 50));

but t onPanel . add( Box. creat ed ue());

ok = new JButton(“OK");

cancel = new JButton(“Cancel”);

ok. set PreferredSi ze(cancel . get PreferredSi ze());

di al og. get Root Pane() . set Def aul t But t on( ok) ;

but t onPanel . add( ok) ;

but t onPanel . add( Box. cr eat eHori zontal Strut(6));

but t onPanel . add(cancel ) ;

but t onPanel . add( Box. creat ed ue());

content. add( buttonPanel, “South”);

To create the dialog's buttons, we follow repeat the “ nested container” pattern we used in creating the
text fields. First, we create a new, nested panel. Thistime we use aBoxLayout that places components
either in asingle row or column, depending on the parameter passed to its constructor. This layout
object ismore flexiblethan aGr i dLayout in that variable spacing between elements can be specified
easily. We put an Enpt yBor der inthe new panel to set margins for placing the buttons. Then we
create the buttons, using a JBut t on constructor that specifies the button text. After setting the size of
the OK button to equal the size of the Cancel button, we designate the OK button as the default button
in the dialog. This causesthe OK button to be outlined when the dialog if first displayed. Finally, we
place the buttons side by side with a 6 pixel gap between them (for aesthetic reasons), and place the
completed but t onPanel inthe*“South” section of the dialog's content pane.

Register the Action Listeners

/1 register this method as an ActionListener for
/1 the buttons and text fields
ok. addAct i onLi st ener (thi s);
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cancel . addAct i onLi stener(this);
prefixFi el d. addActi onLi st ener (this);
suf fi xFi el d. addAct i onLi st ener (this);

In order to specify the action to be taken upon clicking a button or pressing the Ent er key, we

must register an Act i onLi st ener for each of the four active components of the dialog - the two
HistoryTextField components and the two buttons. In Java, an Act i onLi st ener isaninterface- an
abstract specification for aderived classto implement. The Act i onLi st ener interface containsa
single method to be implemented:

public void actionPerformed(ActionEvent e);

BeanShell does not permit a script to create derived classes. However, BeanShell offers a useful
substitute: a method can be used as a scripted object that can include nested methods implementing a
number of Javainterfaces. The method pr ef i xSuf fi xDi al og() that we are writing can thus be
treated asan Act i onLi st ener object. To accomplish this, we call addAct i onLi st ener () on
each of the four components specifyingt hi s asthe Act i onLi st ener . We till need to implement
the interface. We will do that shortly.

Make the Dialog Visible

/1 locate the dialog in the center of the

/1 editing pane and nmake it visible

di al og. pack();

di al og. set Locati onRel ati veTo(vi ew);

di al og. set Def aul t G oseOper ati on(JDi al og. DI SPOSE_ON_CLOSE)
di al og. set Vi si bl e(true);

Here we do three things. First, we activate all the layout routines we have established by calling

the pack() method for the dialog as the top-level window. Next we center the dialog's position in

the active jEdit vi ewby callingset Locat i onRel ati veTo() onthedialog. Weaso cal the

set Def aul t O oseQper ati on() function to specify that the dialog box should be immediately
disposed if the user clicks the close box. Finally, we activate the dialog by calling set Vi si bl e() with
the state parameter settot r ue.

At this point we have a decent looking dialog window that doesn't do anything. Without more code, it
will not respond to user input and will not accomplish any text manipulation. The remainder of the script
deals with these two requirements.

The Action Listener

// this nmethod will be called when a button is clicked
/1 or when ENTER is pressed
voi d actionPerformed(e)

{
i f(e.getSource() != cancel)
{
processText ();
}
di al og. di spose();
}

Themethod act i onPer f or ned() nestedinside pr ef i xSuf fi xDi al og() implementsthe
implicit Act i onLi st ener interface. It looks at the source of the Act i onEvent , determined by a
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call to get Sour ce() . What we do with this return value is straightforward: if the source is not the
Cancel button, we call the pr ocessText () method to insert the prefix and suffix text. Then the
dialogisclosed by calling itsdi spose() method.

The ability to implement interfaces like Act i onLi st ener inside a BeanShell script is one of the
more powerful features of the BeanShell package. this techniqueis discussed in the next chapter; see the
section called “Implementing Classes and Interfaces’.

Get the User's Input

/1 this is where the work gets done to insert
/1 the prefix and suffix
voi d processText ()
{
prefix = prefixField.getText();
suffix = suffixField. getText();
if(prefix.length() == 0 & suffix.length() == 0)
return;
prefixFi el d. addCurrent ToH story();
suf fi xFi el d. addCur rent ToHi story();

The method pr ocessText () doesthe work of our macro. First we obtain the input from the two text
fieldswith acall to their get Text () methods. If they are both empty, there is nothing to do, so the
method returns. If thereisinput, any text in the field is added to that field's stored history list by calling
addCurrent ToH st ory().Wedo not need to test the pr ef i xFi el d or suf fi xFi el d controls
for nul I or empty values because addCur r ent ToHi st or y() doesthat internally.

Call jEdit Methods to Manipulate Text

/1 text manipul ati on begins here using calls
/1 to jEdit nethods
buf f er. begi nConmpoundEdi t () ;
sel ect edLi nes = textArea. get Sel ect edLi nes();
for(i = 0; i < selectedLines.length; ++i)
{
of fsetBOL = textArea. getLineStartOffset(
sel ectedLi nes[i]);
t ext Area. set Car et Posi ti on(of fset BOL) ;
t ext Area. goToSt art Of Whi t eSpace(fal se);
t ext Ar ea. goTOENndOf Whi t eSpace(true);
text = textArea.getSel ectedText ();
if(text == null) text ="";
text Area. set Sel ectedText (prefix + text + suffix);
}
buf f er. endConpoundEdi t () ;

}

The text manipulation routine loops through each selected line in the text buffer. We get the loop
parameters by calling t ext Ar ea. get Sel ect edLi nes() , which returns an array consisting of the
line numbers of every selected line. The array includes the number of the current line, whether or not

it is selected, and the line numbers are sorted in increasing order. We iterate through each member of
thesel ect edLi nes array, which represents the number of a selected line, and apply the following
routine;
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 Get the buffer position of the start of the line (expressed as a zero-based index from the start of the
buffer) by callingt ext Ar ea. getLi neStart Of f set (sel ectedLines[i]);

» Movethe caret to that position by calling t ext Ar ea. set Car et Posi ti on();

 Find thefirst and last non-whitespace characters on the line by calling
t ext Area. goToSt art O Whi t eSpace() andt ext Ar ea. goToEndOF Whi t eSpace() ;

ThegoTo. .. methodsin JEditTextAreatake a single parameter which tells jEdit whether the
text between the current caret position and the desired position should be selected. Here, we

call t ext Area. goToSt art Of Wi t eSpace(f al se) sothat no text is selected, then call

t ext Area. goToEndOrF Whi t eSpace(true) sothat all of the text between the beginning and
ending whitespace is selected.

» Retrieve the selected text by storing the return value of t ext Ar ea. get Sel ect edText () ina
new variablet ext .

If thelineis empty, get Sel ect edText () will return nul | . In that case, we assign an empty
string to t ext to avoid calling methods on a null object.

e Changethesdlectedtexttoprefi x + text + suffi x by calling
t ext Area. set Sel ect edText () . If thereis no selected text (for example, if the lineis empty),
the prefix and suffix will be inserted without any intervening characters.

Compound edits

Note the begi nConpoundEdi t () and endConpoundEdi t () cals. These ensure that all
edits performed between the two calls can be undone in one step. Normally, jEdit automatically
wraps a macro call in these methods; however if the macro shows a non-modal dialog box, as
far asjEdit is concerned the macro has finished executing by the time the dialog is shown, since
control returns to the event dispatch thread.

If you do not understand this, don't worry; just keep it in mind if your macro needs to show a non-
modal dialog box for some reason; Most macros won't.

The Main Routine

/1 this single line of code is the script's main routine
prefixSuffixDial og();

Thecadl toprefi xSuf fi xDi al og() istheonly linein the macro that is not inside an enclosing
block. BeanShell treats such code as atop-level mai n method and begins execution with it.

Our analysisof Add_Pr ef i x_and_Suf f i x. bsh isnow complete. In the next section, we look at
other ways in which a macro can obtain user input, as well as other macro writing techniques.
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Getting Input for a Macro

The dial og-based macro discussed in Chapter 14, A Dialog-Based Macro reflects a conventional
approach to obtaining input in a Java program. Nevertheless, it can be too lengthy or tedious for
someone trying to write a macro quickly. Not every macro needs a user interface specified in such
detail; some macros require only a single keystroke or no input at all. In this section we outline some
other techniques for obtaining input that will help you write macros quickly.

Getting a Single Line of Text

As mentioned earlier in the section called “Helpful Methods in the Macros Class’, the method
Macr os. i nput () offersaconvenient way to obtain asingle line of text input. Here is an example
that inserts apair of HTML markup tags specified by the user.

/1 Insert_Tag. bsh

voi d insertTag()
{
caret = textArea.getCaretPosition();
tag = Macros.input(view, “Enter name of tag:”);
if( tag == null || tag.length() == 0) return;
text = textArea. getSel ectedText ();
if(text == null) text =*"";
sb = new StringBuffer();
sb. append(“<”). append(tag).append(“>");
sb. append(text);
sb. append(“</"). append(tag). append(“>");
t ext Area. set Sel ect edText (sb.toString());
if(text.length() == 0)
text Area. set Caret Position(caret + tag.length() + 2);

}

i nsert Tag();

/1 end Insert_Tag. bsh

Herethecall to Macr os. i nput () seeksthe name of the markup tag. This method sets the message
box title to afixed string, “Macro input”, but the specific message Enter name of tag provides all the
information necessary. The return valuet ag must be tested to seeif it is null. Thiswould occur if the
user presses the Cancel button or closes the dialog window displayed by Macr os. i nput () .

Getting Multiple Data Items

If more than one item of input is needed, a succession of callsto Macr os. i nput () isapossible,

but awkward approach, because it would not be possible to correct early input after the corresponding
message box is dismissed. Where moreis required, but afull dialog layout is either unnecessary or too
much work, the Java method JOpt i onPane. showConf i r nDi al og() isavailable. The version to
use has the following prototype:
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 public static int showConfirnDi al og(Conponent parent Conponent,
hj ect nessage, String title, int optionType, int nmessageType);

The usefulness of this method arises from the fact that the message parameter can be an object of any
Javaclass (since al classes are derived from Obj ect ), or any array of objects. The following example
shows how this feature can be used.

/1 excerpt fromWite_File_Header. bsh

title = “Wite file header”;

current Nane = buffer.get Name();

naneFi el d = new JText Fi el d(current Nane);

aut horField = new JText Fi el d(“Your nanme here”);
descField = new JTextField("”, 25);

nanePanel = new JPanel (new GidLayout (1, 2));
naneLabel = new JLabel (“Nane of file:”, Sw ngConstants.LEFT);
saveFi el d = new JCheckBox(“Save file when done”,

I'buffer.isNewFile());
nanePanel . add( nanmeLabel ) ;
nanePanel . add(saveFi el d);

nmessage = new bject[9];

nmessage[ 0] = nanePanel ;

nmessage[ 1] = naneFi el d;

message[ 2] = Box.createVertical Strut(10);
message[ 3] = “Author's nane:”;

nmessage[ 4] = aut horFi el d;

message[ 5] = Box.createVertical Strut(10);
message[ 6] = “Enter description:”;
nmessage[ 7] = descFi el d;

message[ 8] = Box.createVertical Strut(5);

i f( JOptionPane. OK_ OPTION ! =
JOpt i onPane. showConf i rnDi al og(vi ew, nmessage, title,
JOpt i onPane. OK_CANCEL_OPTI ON,
JOpt i onPane. QUESTI ON_MESSACE) )
return null;

[l *****remai nder of nmacro script omtted*****
/1 end excerpt fromWite_File_Header.bsh

This macro takes several items of user input and produces a formatted file header at the beginning of the
buffer. The full macro isincluded in the set of macrosinstalled by jEdit. There are a number of input
features of this excerpt worth noting.

e Themacro uses atotal of seven visible components. Two of them are created behind the scenes by
showConf i r nDi al og(), therest are made by the macro. To arrange them, the script creates an
array of Cbj ect objects and assigns components to each location in the array. Thistrandatesto a
fixed, top-to-bottom arrangement in the message box created by showConf i r nDi al og() .
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e Themacro uses JText Fi el d objectsto obtain most of the input data. The fields nameFi el d
and aut hor Fi el d are created with constructors that take the initial, default text to be displayed in
the field as a parameter. When the message box is displayed, the default text will appear and can be
atered or deleted by the user.

» Thetextfield descFi el d usesan empty string for itsinitial value. The second parameter in its
constructor sets the width of the text field component, expressed as the number of characters of
“average” width. When showConf i r nDi al og() preparesthelayout of the message box, it
sets the width wide enough to accommodate the designated with of descFi el d. Thistechnique
produces a message box and input text fields that are wide enough for your data with one line of code.

» The displayed message box includes a JCheckBox component that determines whether the buffer
will be saved to disk immediately after the file header is written. To conserve space in the message
box, we want to display the check box to the right of the label Name of file:. To do that, we create a
JPanel object and populate it with the label and the checkbox in aleft-to-right Gri dLayout . The
JPanel containing the two componentsis then added to the beginning of nessage array.

» Thetwo visible components created by showConf i r nDi al og() appear at positions 3 and 6 of the
message array. Only the text is required; they are rendered as text labels.

» There are three invisible components created by showConf i r nDi al og() . Each of them involves
acal toBox. createVerti cal Strut (). TheBox classisasophisticated layout classthat gives
the user great flexibility in sizing and positioning components. Here we use ast at i ¢ method of the
Box classthat produces avertical strut. Thisis atransparent component whose width expands to fill
its parent component (in this case, the message box). The single parameter indicates the height of the
strut in pixels. Thelast call tocr eat eVerti cal St rut () separatesthe description text field from
the OK and Cancel buttons that are automatically added by showConf i r nDi al og() .

» Finally, thecall to showConf i r nDi al og() usesdefined constants for the option type and the
message type. The constants are the same as those used with the Macr os. conf i rn{) method;
see the section called “Helpful Methods in the Macros Class’. The option type signifies the use of
OK and Cancel buttons. The QUERY _MESSACGE message type causes the message box to display a
question mark icon.

The return value of the method istested against the value OK_OPTI ON. If the return valueis
something el se (because the Cancel button was pressed or because the message box window was
closed without a button press), anul | valueisreturned to acalling function, signaling that the user
canceled macro execution. If the return value is OK_OPTI ON, each of the input components can yield
their contents for further processing by callsto JText Fi el d. get Text () (or, in the case of the
check box, JCheckBox. i sSel ect ed()).

Selecting Input From a List

Another useful way to get user input for amacro is to use a combo box containing a number of pre-
set options. If thisisthe only input required, one of the versions of showl nput Di al og() inthe
JOpt i onPane class provides a shortcut. Here isiits prototype:

 public static hject show nput Di al og( Conponent par ent Conponent,
oj ect nessage, String title, int nmessageType, lcon icon, Ohject[]
sel ectionVal ues, Cbject initial Sel ectionVal ue);

This method creates a message box containing a drop-down list of the options specified in the method's
parameters, along with OK and Cancel buttons. Compared to showConf i r nDi al og() , this method
lacksan opt i onType parameter and has three additional parameters: ani con to display in the dialog
(which canbe settonul | ), an array of sel ecti onVal ues objects, and areference to one of the
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optionsasthei ni ti al Sel ecti onVal ue to be displayed. In addition, instead of returning ani nt
representing the user's action, showl nput Di al og() returnsthe Obj ect corresponding to the user's
selection, or nul | if the selection is canceled.

The following macro fragment illustrates the use of this method.

/1 fragment illustrating use of show nputDi al og()
options = new Cbject[5];

options[0] = "JLabel";

options[1] = "JTextField";

options[2] = "JCheckBox";

options[3] = "HistoryTextField";

options[4} = "-- other --";

result = JOpti onPane. show nput Di al og(Vvi ew,
"Choose conponent class",
"Sel ect class for input conponent",
JOpt i onPane. QUESTI ON_MESSAGE,
null, options, options[0]);

Thereturn valuer esul t will contain either the St r i ng object representing the selected text item
or nul | representing no selection. Any further use of this fragment would have to test the value of
resul t and likely exit from the macro if the value equaled nul | .

A set of options can be similarly placed in aJConmboBox component created as part of alarger dialog
or showvessageDi al og() layout. Here are some code fragments showing this approach:

/1 fragments from Di spl ay_Abbrevi ati ons. bsh
/1 inmport statements and other code onmitted

/!l frommin routine, this nmethod call returns an array
/1 of Strings representing the nanmes of abbreviation sets

abbrevSets = getActiveSets();

/1 from showAbbrevs() nethod

conbo = new JConboBox(abbrevSets);

/1 set width to uniformsize regardl ess of conbobox contents
Di nensi on di m = conbo. get PreferredSi ze();

dimwi dth = Math. max(di mw dth, 120);

conbo. set PreferredSi ze(di nj;

conbo. set Sel ect edl t en{ STARTI NG _SET); // defined as "gl obal"

/1 end fragnents

Using a Single Keypress as Input

Some macros may choose to emulate the style of character-based text editors such as emacs or vi. They
will require only a single keypress as input that would be handled by the macro but not displayed on
the screen. If the keypress corresponds to a character value, jEdit can pass that value as a parameter to a
BeanShell script.
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ThejEdit class InputHandler is an abstract class that that manages associations between keyboard input
and editing actions, along with the recording of macros. Keyboard input in jEdit is normally managed by
the derived class DefaultinputHandler. One of the methods in the InputHandler class handles input from
asingle keypress:

* public void readNext Char(String pronpt, String code);

When this method is called, the contents of the pr onpt parameter is shown in the view's status bar.
The method then waits for akey press, after which the contents of the code parameter will be run
as aBeanShell script, with one important modification. Each timethestring __char __ appearsin
the parameter script, it will be substituted by the character pressed. The key pressis “consumed” by
r eadNext Char () . It will not be displayed on the screen or otherwise processed by jEdit.

Using r eadNext Char () reguiresamacro within the macro, formatted as a single, potentially lengthy
string literal. The following macro illustrates this technique. It selects aline of text from the current
caret position to the first occurrence of the character next typed by the user. If the character does not
appear on the line, no new selection occurs and the display remains unchanged.

/1 Next Char.bsh

script = new StringBuffer(512);

script.append( "start = textArea.getCaretPosition();" )
script.append( "line = textArea.getCaretlLine();" )
script. append( "end = textArea.getLineEndOfset(line) + 1;" )
script.append( "text = buffer.getText(start, end - start);" )
script.append( "match = text.indexOr(__char__, 1);" )
script.append( "if(match !'= -1) {" )
scri pt. append( "if(__char__ !'="\\n") ++match;" )
scri pt. append( "text Area. sel ect (start, start + match - 1);" );
scri pt.append( "}" )

vi ew. get | nput Handl er (). readNext Char ("Enter a character",
script.toString());

/1 end Next Char.bsh
Once again, here are afew comments on the macro's design.

* A StringBuffer objectisused for efficiency; it obviates multiple creation of fixed-length
St ri ng objects. The parameter to the constructor of scri pt specifiestheinitial size of the buffer
that will receive the contents of the child script.

» Besides the quoting of the script code, the formatting of the macro is entirely optional but (hopefully)
makes it easier to read.

* Itisimportant that the child script be self-contained. It does not run in the same namespace as the
“parent” macro Next _Char . bsh and therefore does not share variables, methods, or scripted
objects defined in the parent macro.

 Finally, access to the InputHandler object used by jEdit is available by calling
get | nput Handl er () onthe current view.

Startup Scripts

On startup, jEdit runs any BeanShell scripts located inthe st ar t up subdirectory of the jEdit
installation and user settings directories (see the section called “ The jEdit Settings Directory”). Aswith
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macros, the scripts must have a. bsh file name extension. Startup scripts are run near the end of the
startup sequence, after plugins, properties and such have been initialized, but before the first view is
opened.

Startup scripts can perform initialization tasks that cannot be handled by command line options or
ordinary configuration options, such as customizing jEdit's user interface by changing entriesin the Java
platform's Ul Manager class.

Startup scripts have an additional feature lacking in ordinary macros that can help you further customize
jEdit. Variables and methods defined in a startup script are available in al instances of the BeanShell
interpreter created in jEdit. This allows you to create a personal library of methods and objects that can
be accessed at any time during the editing session in another macro, the BeanShell shell of the Console
plugin, or menu items such as Utilities>SBeanShell>Evaluate BeanShell Expression.

The startup script routine will run script filesin the installation directory first, followed by scriptsin
the user settings directory. In each case, scripts will be executed in alphabetical order, applied without
regard to whether the file name contains upper or lower case characters.

If astartup script throws an exception (because, for example, it attempts to call amethod on anul |
object). jEdit will show an error dialog box and move on to the next startup script. If script bugs are
causing jEdit to crash or hang on startup, you can use the - nost ar t upscri pt s command line
option to disable them for that editing session.

Another important difference between startup scripts and ordinary macros is that startup scripts cannot
use the pre-defined variablesvi ew, t ext Ar ea, edi t Pane and buf f er . Thisis because they are
executed before the initial view is created.

If you are writing a method in a startup script and wish to use one of the above variables, pass
parameters of the appropriate type to the method, so that a macro calling them after startup can supply
the appropriate values. For example, a startup script could include a method

voi d doSonet hi ngWthView(View v, String s) {
}
so that during the editing session another macro can call the method using

doSonet hi ngWthVi em(vi ew, "sonet hing");

Reloading startup scripts without restarting

It is actually possible to reload startup scripts or load other scripts without restarting jEdit, using a
BeanShell statement like the following:

BeanShel | . runScri pt (vi ew, pat h, nul | , fal se);

For pat h, you can substitute any string, or a method call such asbuf f er . get Pat h() .

Running Scripts from the Command Line

The - r un command line switch specifies a BeanShell script to run on startup:
$ jedit -run=test.bsh

Note that just like with startup scripts, thevi ew, t ext Ar ea, edi t Pane and buf f er variablesare
not defined.
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If another instance is already running, the script will be run in that instance, and you will be able to use
thej Edi t . get Last Vi ewm( ) method to obtain aview. However, if anew instance of jEdit is being
started, the script will be run at the same time as all other startup scripts; that is, before the first view is
opened.

If your script needs a view instance to operate on, you can use the following code pattern to obtain one,
no matter how or when the script is being run:

voi d doSomet hi ngUsef ul ()

{
void run()
{
view = jEdit.getLastView);
/1 put actual script body here
}
if(jEdit.getLastViewm) == null)
VFSManager . runl nAWIThr ead(t hi s);
el se
run();
}

doSonet hi ngUsef ul ();

If the script isbeing run in aloaded instance, it can be invoked to perform its work immediately.
However, if the script is running at startup, before an initial view exists, its operation must be delayed
to allow the view object first to be created and displayed. In order to queue the macro's operation,

the scripted “closure” named doSonet hi ngUsef ul () implementsthe Runnabl e interface

of the Java platform. That interface containsonly asingler un() method that takes no parameters
and has no return value. The macro's implementation of ther un() method contains the “working”
portion of the macro. Then the scripted object, represented by areferencetot hi s, is passed to the
runl nAWI'Thr ead() method. This schedules the macro's operations for execution after the startup
routineis complete.

Asthis exampleillustrates, the r unl NAWI Thr ead() method can be used to ensure that a macro will
perform operations after other operations have completed. If it isinvoked during startup, it schedules the
specified Runnabl e object to run after startup is complete. If invoked when jEdit is fully loaded, the
Runnabl e object will execute after al pending input/output is complete, or immediately if there are no
pending 1/O operations. Thiswill delay operations on a new buffer, for example, until after the buffer is
loaded and displayed.

Advanced BeanShell Techniques

BeanShell has afew advanced features that we haven't mentioned yet. They will be discussed in this
section.

BeanShell's Convenience Syntax

We noted earlier that BeanShell syntax does not require that variables be declared or defined with their
type, and that variables that are not typed when first used can have values of differing types assigned to
them. In addition to this“loose” syntax, BeanShell allows a“convenience” syntax for dealing with the
properties of JavaBeans. They may be accessed or set as if they were data members. They may also be
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accessed using the name of the property enclosed in quotation marks and curly brackets. For example,
the following statement are all equivalent, assuming bt n isaJBut t on instance:

b. set Text (" Choose");
b.text = "Choose";
b{"text"} = "Choose",

Thelast form can also be used to access a key-value pair of aHasht abl e object.

Special BeanShell Keywords

BeanShell uses special keywords to refer to variables or methods defined in the current or an enclosing
block's scope:

* Thekeywordt hi s refersto the current scope.
» Thekeyword super refersto theimmediately enclosing scope.
e Thekeyword gl obal refersto the top-level scope of the macro script.

The following script illustrates the use of these keywords:

a = "top\n";

foo() {
a = "mddle\n";
bar () {

a = "bottomn";

t ext Area. set Sel ect edText (gl obal . a);

t ext Area. set Sel ect edText (super. a);

/1 equivalent to textArea.setSel ectedText(this.a):
t ext Area. set Sel ect edText (a);

}
bar () ;
}
foo();

When the script is run, the following text is inserted in the current buffer:
top

m ddl e
bottom

Implementing Classes and Interfaces

As discussed in the macro example in Chapter 14, A Dialog-Based Macro, scripted objects can
implicitly implement Javainterfaces such as Act i onLi st ener . For example:

nyRunnabl e() {

run() {
Systemout.printin("Hello world!");
}

return this;
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}

Runnabl e r = nyRunnabl e();
new Thread(r).start();

Frequently it will not be necessary to implement all of the methods of a particular interface in order to
specify the behavior of a scripted object. To prevent BeanShell from throwing exceptions for missing
interface methods, implement thei nvoke() method, which is called when an undefined method is
invoked on a scripted object. Typically, the implementation of this method will do nothing, asin the
following example:

i nvoke(nmet hod, args) {}

In addition to the implicit interface definitions described above, BeanShell permits full-blown classes to
be defined. Indeed, almost any Java class definition should work in BeanShell:

class Cons {
/1 Long-live LI SP!
oj ect car;
oj ect cdr;

rplaca(Obj ect car) {
this.car = car;
}

rplacd(Object cdr) {
this.cdr = cdr;
}

}
Debugging Macros

Here are afew techniques that can prove helpful in debugging macros.

ldentifying Exceptions
An exception is a condition reflecting an error or other unusual result of program execution that requires
interruption of normal program flow and some kind of special handling. Java has arich (and extensible)
collection of exception classes which represent such conditions.
jEdit catches exceptions thrown by BeanShell scripts and displays them in adialog box. In addition, the
full traceback iswritten to the activity log (see Appendix B, The Activity Log for more information about
the activity log).

There are two broad categories of errors that will result in exceptions:

* Interpreter errors, which may arise from typing mistakes like mismatched brackets or missing
semicolons, or from BeanShell's failure to find a class corresponding to a particular variable.

Interpreter errors are usually accompanied by the line number in the script, along with the cause of the
error.

» Execution errors, which result from runtime exceptions thrown by the Java platform when macro
code is executed.
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Some exceptions thrown by the Java platform can often seem cryptic. Neverthel ess, examining the
contents of the activity log may reveals clues as to the cause of the error.

Using the Activity Log as a Tracing Tool

Sometimes exception tracebacks will say what kind of error occurred but not where it arose in the
script. In those cases, you can insert calls that log messages to the activity log in your macro. If the
logged messages appear when the macro is run, it means that up to that point the macro isfine; but if an
exception islogged firgt, it means the logging call islocated after the cause of the error.

To write amessage to the activity log, use the following method of the Log class:
* public static void log(int urgency, Object source, Cbject message);
See the documentation for the Log class for information about the method's parameters.

The following code sends atypical debugging message to the activity log:
Log. | og(Log. DEBUG, BeanShell.cl ass, "counter =" + counter);

The corresponding activity log entry might read as follows:

[ debug] BeanShell: counter = 15

Using message dialog boxes as a tracing tool

If you would prefer not having to deal with the activity log, you can use the
Macr os. nessage() method as atracing tool. Just insert calls like the following in the macro
code:

Macr os. nessage(vi ew, "t raci ng") ;

Execution of the macro is halted until the message dialog box is closed. When you have
finished debugging the macro, you should delete or comment out the debugging callsto
Macr os. nessage( ) inyour final source code.
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Chapter 16. BeanShell Commands

BeanShell includes a set of commands; subroutines that can be called from any script or macro. The
following is a summary of those commands which may be useful within jEdit.

Note

Java classes in plugins cannot make use of BeanShell commands directly. However, these
commands can be called from BeanShell code that is part of a plugin, for example the snippets
inacti ons. xm , or any BeanShell scripts shipped with the plugin and loaded on startup.

Output Commands

void cat(String fil enanme);

Writes the contents of f i | enane to the activity log.

void javap(String | Object | Class target);

Writes the public fields and methods of the specified class to the output stream of the current process.
void print(arg);

Writes the string value of the argument to the activity log, or if run from the Console plugin, to the
current output window. If ar g isan array, pri nt runsitself recursively on the array's elements.

File Management Commands

void cd(String dirnane);

Changes the working directory of the BeanShell interpreter to di r nare.
void cp(String fronFile, String toFile);
CopyfronFil etotoFil e.

void dir(String dirnane);

Displays the contents of directory di r name. The format of the display issimilar tothe Unix | s -1
command.

void mv(String fronFile, String toFile);
Movesthefilenamed by fronFi |l etot oFi | e.
File pathToFile(String fil enane);

CreateaFi | e object correspondingtof i | enamne. Relative paths are resolved with reference to the
BeanShell interpreter's working directory.

voi d pwd(void);

Writes the current working directory of the BeanShell interpreter to the output stream of the current
process.
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e void rm(String pathnane);

Deletes the file name by pat hnane.

Component Commands

* JFrane frane(Conponent frane);
Displays the component in atop-level JFr ane, centered and packed. Returns the JFr anme object.
e Object load(String fil enane);
Loads and returns a serialized Java object fromf i | enane.
» voi d save(Conmponent conponent, String fil enane);
Savesconponent inseridized formtofi | enamne.
* Font set Font (Conponent conp, int ptsize);

Set the font size of conponent to pt si ze and returns the new font.

Resource Management Commands

* URL getResource(String path);

Returns the resource specified by pat h. An absolute path must be used to return any resource
available in the current classpath.

Script Execution Commands

e Thread bg(String fil enane);

Run the BeanShell script named by f i | enamne in acopy of the existing namespace and in a separate
thread. Returnsthe Thr ead object so created.

 void exec(String cndline);

Start the external process by calling Runt i ne. exec() oncndl i ne. Any output is directed to the
output stream of the calling process.

 Object eval (String expression);

Evaluatesthe string expr essi on as aBeanShell script in the interpreter's current namespace.
Returns the result of the evaluation of nul | .

e org.gjt.sp.jedit.bsh. This run(String fil enane);

Run the BeanShell script named by f i | ename in acopy of the existing namespace. The return value
represent the object context of the script, allowing you to access its variables and methods.

e void setAccessibility(boolean flag);

Ifflagistrue, BeanShell scripts are alowed to change and modify private variables, and call
private methods. The default isf al se.
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void setStrictJava(bool ean flag);

If flagistrue, BeanShell scripts must follow a much more strict, Java-like syntax, and are not able
to use the convenience features described in the section called “BeanShell's Convenience Syntax”.

voi d source(String fil enane);

Evaluates the contents of f i | enane asaBeanShell script in the interpreter's current namespace.

BeanShell Object Management Commands

bind(org.gjt.sp.jedit.bsh.This ths, org.gjt.sp.jedit.bsh. Nanespace
nanespace) ;

Binds the scripted object t hs to namespace.
void clear(void);

Clear dl variables, methods, and imports from this namespace. If this namespace is the root, it will be
reset to the default imports.

org.gjt.sp.jedit.bsh. This extend(org.gjt.sp.jedit.bsh. This object);
Creates anew BeanShell Thi s scripted object that is a child of the parameter obj ect .
voi d i nport Obj ect (Obj ect object);

Import an object into this namespace. Thisis somewhat similar to Java 1.5 static class imports, except
you can import the methods and fields of a Java object instance into a BeanShell namespace, for
example:

Map map = new HashMap();

i mport Cbj ect( map );

put ("foo", "bar");

print( get("foo") ); // "bar"
org.gjt.sp.jedit.bsh. This object(void);

Creates anew BeanShell Thi s scripted object which can hold data members. Y ou can use thisto
create an object for storing miscellaneous crufties, like so:

crufties = object();
crufties.foo = "hello world";
crufties.counter = 5;

set NameSpace(org. gjt.sp.jedit.bsh. Namespace namespace);
Set the namespace of the current scopeto nanmespace.
org.gjt.sp.jedit.bsh. This super(String scopenane);

Returns areference to the BeanShell Thi s object representing the enclosing method scope specified
by scopenane. This method work similar to the super keyword but can refer to enclosing scope at
higher levelsin a hierarchy of scopes.

void unset(String nane);
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Removes the variable named by nanme from the current interpreter namespace. This has the effect of
“undefining” the variable.

Other Commands

* voi d debug(void);

Toggles BeanShell's internal debug reporting to the output stream of the current process.

» get Sour ceFil el nfo(void);

Returns the name of the file or other source from which the BeanShell interpreter is reading.
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Part IV. Writing Plugins

This part of the user's guide covers writing plugins for jEdit.

Like jEdit itself, plugins are written primarily in Java. While this guide assumes some working knowledge of the

language, you are not required to be a Javawizard. If you can write a useful application of any size in Java, you can
write aplugin.

Where applicable, this section will also explain how jEdit's source code is similar. Therefore, thisis also agood
introduction to to jEdit development.




Chapter 17. Introducing the Plugin API

ThejEdit Plugin API provides a framework for hosting plugin applications without imposing any
requirements on the design or function of the plugin itself. Y ou could write an application that performs
spell checking, displays aclock or plays chess and turn it into a jEdit plugin. There are currently over 50
released plugins for jEdit. While none of them play chess, they perform awide variety of editing and file
management tasks.

A detailed listing of available pluginsis available at plugins.jedit.org. Y ou can aso find beta versions of
new pluginsin the “Downloads’ area of community.jedit.org.

Using the “Plugin Manager” feature of jEdit, users with an Internet connection can check for new or
updated plugins and install and remove them without leaving jEdit. See Chapter 9, Installing and Using
Pluginsfor details.

Requirements for “plugging in” to jEdit are asfollows:

 This plugin must supply information about itself, such as its name, version, author, and compatibility
with versions of jEdit.

» The plugin must provide for activating, displaying and deactivating itself upon direction from jEdit,
typically in response to user inputl. Make sure you can continue to use both your plugin and the editor
after it has been reloaded.

» Each Plugin has an ActionSet defined by jEdit, which is added to the main ActionContext. The
ActionSet is a container for EditAction instances. The plugin may define actionsin anumber of ways.
Oneway is explicitly, with an action definition file known asact i ons. xm . Another isimplicitly,
by defining dockable windowsin dockabl es. xm .

Most EditActions are small blocks of BeanShell code that jEdit will perform on behalf of the plugin
upon user request. They provide the “glue” between user input and specific plugin routines.

By convention, plugins display their available actions in submenus of jEdit's Plugins menu; each
menu item corresponds to an action. Plugin authors do not define specific shortcuts - the user can/will
assign EditActions to keyboard shortcuts, toolbar buttons, or entries in the text area's Context menu
(right-click menu).

* The plugin may, but need not, provide auser interface.

If the plugin has avisible interface, it can be shown in any object derived from one of Java top-level
container classes: JW ndow, JDi al og, or JFr ane. jEdit also provides a dockable window API,
which allows plugin windows derived from the JConponent classto be docked into views or
shown in top-level frames, at the user's request.

Plugins can also act directly upon jEdit's text area. They can add graphical elements to the text display
(like error highlighting in the case of the ErrorList plugin) or decorations surrounding the text area
(like the JDiff plugin's summary views). These plugins are dependent on the JEditTextArea class,
which is currently getting refactored.

» Plugins may provide arange of options that the user can modify to alter their configuration.

If a plugin provides configuration options in accordance with the plugin AP, jEdit will make them
available in the Global Options diaog box.

Ly ou should test your plugin by loading and unloading it from both the Plugin Manager, as well as the Activator Plugin.
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« Whileit isnot required, plugins are encouraged to provide documentation.

As noted, many of these features are optional; it is possible to write a plugin that does not provide
actions, configuration options, or dockable windows. The magjority of plugins, however, provide most of
these services.

Plugins and different jEdit versions

As|jEdit continues to evolve and improve, el ements of the APl may change with a new jEdit
release.

On occasion an API change will break code used by plugins, athough efforts are made to
maintain or deprecate plugin-related code on atransitional basis. While the majority of plugins
are unaffected by most changes and will continue working, it isagood ideato monitor the jEdit
changelog, and jointhej edi t - devel mailing list, to keep updated on changes and bug
reports, so that you will know when your plugin needs to be updated. If you allow the source code
to be managed by the jEdit project, then other plugin developers can help fix things when they
break more easily.
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Chapter 18. Implementing a Simple
Plugin

There are many applications for the leading operating systems that provide a“ scratch-pad” or “ sticky
note” facility for the desktop display. A similar type of facility operating within the jEdit display would
be a convenience. The use of dockable windows would allow the notepad to be displayed or hidden
with asingle mouse click or keypress (if a keyboard shortcut were defined). The contents of the notepad
could be saved at program exit (or, if earlier, deactivation of the plugin) and retrieved at program startup
or plugin activation.

We will keep the capabilities of this plugin modest, but afew other features would be worthwhile. The
user should be able to write the contents of the notepad to storage on demand. It should also be possible
to choose the name and location of the file that will be used to hold the notepad text. Thiswould allow
the user to load other filesinto the notepad display. The path of the notepad file should be displayed in
the plugin window, but will give the user the option to hide the file name. Finaly, there should be an
action by which asingle click or keypress would cause the contents of the notepad to be written to the
new text buffer for further processing.

The full source code for QuickNotepad is contained in jEdit's source code distribution. We will provide
excerptsin this discussion where it is helpful to illustrate specific points. Y ou are invited to obtain the
source code for further study or to use as a starting point for your own plugin.

How Plugins are Loaded

We will discuss the implementation of the QuickNotepad plugin, along with the jEdit APIs it makes use
of. But first, we describe how plugins are loaded.

As part of its startup routine, jEdit's mai n method calls various methods to load and initialize plugins.

Additionally, plugins using the jEdit 4.2 plugin API can be loaded and unloaded at any time. Thisis
agreat help when developing your own plugins -- there is no need to restart the editor after making
changes (see the section called “ Reloading the Plugin” ).

Plugins are loaded from fileswith the . j ar filename extension located inthej ar s subdirectories of
the jEdit installation and user settings directories (see the section called “ The jEdit Settings Directory”).

For each JAR archive fileit finds, jEdit scansits entries and performs the following tasks:

» Addsto acollection maintained by jEdit a new object of type Pl ugi nJAR. Thisis adata structure
holding the name of the JAR archivefile, areference to the JARC assLoader , and a collection of
plugins found in the archivefile.

 Loads any properties defined in files ending with the extension . pr ops that are contained in the
archive. See the section called “The Property Files'.

» Reads action definitions from any filenamed act i ons. xm in the archive (the file need not be at
the top level). See the section called “ The Actions.xml Catalog”.

 Parses and loads the contents of any file named dockabl es. xm inthe archive (the file need not be
at the top level). Thisfile contains BeanShell code for creating docking or floating windows that will
contain the visible components of the plugin. Not al plugins define dockable windows, but those that
doneed adockabl es. xm file. See the section called “The dockables.xml Window Catalog”.
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e Checksfor aclass name with aname ending with Pl ugi n. cl ass.
Such aclassis known as aplugin core class and must extend jEdit's abstract Edi t Pl ugi n class.

The initialization routine checks the plugin's properties to see if it is subject to any dependencies. For
example, aplugin may require that the version of the Java runtime environment or of jEdit itself be
equal to or above some threshold version. A plugin can also require the presence of another plugin.

If any dependency is not satisfied, the loader marks the plugin as “broken” and logs an error message.

After scanning the plugin JAR file and loading any resources, a new instance of the plugin core class
is created and added to the collection maintained by the appropriate Pl ugi nJAR. jEdit then calls
thest art () method of the plugin coreclass. Thest art () method can perform initialization of
the object's data members. Because this method is defined as an empty “no-op” inthe Edi t Pl ugi n
abstract class, a plugin need not provide an implementation if no unique initialization is required.

The QuickNotepadPlugin Class

The major issues encountered when writing a plugin core class arise from the developer's decisions on
what features the plugin will make available. These issues have implications for other plugin elements as
well.

* Will the plugin provide for actions that the user can trigger using jEdit's menu items, toolbar buttons
and keyboard shortcuts?

 Will the plugin have its own visible interface?

» Will the plugin have settings that the user can configure?

» Will the plugin respond to any messages reflecting changes in the host application's state?
« Should the plugin do something special when it gets focus?

Recall that the plugin core class must extend Edi t Pl ugi n. In QuickNotepad's plugin core class, there
are no special initialization or shutdown chores to perform, so we will not need ast art () or st op()
method.

The resulting plugin core classis lightweight and straightforward to implement:

e public class Qui ckNotepadPl ugi n extends EditPlugin {
public static final String NAME = "qui cknot epad”;
public static final String OPTION_PREFI X = "options. qui cknot epad. ";

}

The class has been simplified since 4.1, and al we defined here were acouple of St ri ng data
members to enforce consistent syntax for the name of properties we will use throughout the plugin.

» Thesenamesareusedinact i ons. xml for each of the menu choices. Thisfileis discussed in more
detail in the section called “ The Actions.xml Catalog”. Each action is a beanshell script.

<! DOCTYPE ACTI ONS SYSTEM "actions. dtd">
<ACTI ONS>
<ACTI ON NAME="qui cknot epad. choose-file">
<CCDE>
wm addDockabl eW ndow( Qui ckNot epadPl ugi n. NAVE) ;
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wm get Dockabl eW ndow( Qui ckNot epadPl ugi n. NAME) . chooseFi | e();
</ CCDE>
</ ACTI ON>

<ACTI ON NAME="qui cknot epad. save-fil e">
<CCDE>
wm addDockabl eW ndow( Qui ckNot epadPl ugi n. NAVE)
wm get Dockabl eW ndow( Qui ckNot epadPl ugi n. NAVE) . saveFi | e();
</ CODE>
</ ACTI ON>

<ACTI ON NAME="qui cknot epad. copy-t o- buffer">
<CCDE>
wm addDockabl eW ndow( Qui ckNot epadPl ugi n. NAME)
wm get Dockabl eW ndow( Qui ckNot epadPl ugi n. NAME) . copyToBuffer();
</ CODE>
</ ACTI ON>
</ ACTI ONS>

The names also come up in the propertiesfile, Qui ckNot ePad. pr ops file. The properties define
option panes and strings used by the plugin. It is explained in more detail in the section called “ The
Property Files” and the Edi t Pl ugi n API docs.

# jEdit only needs to load the plugin the first tine the user accesses it
# the presence of this property also tells jEdit the plugin is using the new AP
pl ugi n. Qui ckNot epadPl ugi n. acti vat e=def er

# Even if you don't store additional files, this is a good idea to set:
pl ugi n. Qui ckNot epadPl ugi n. usePl ugi nHome=t r ue

# Required for all plugins:
pl ugi n. Qui ckNot epadPl ugi n. nane=Qui ckNot epad
pl ugi n. Qui ckNot epadPl ugi n. aut hor =John Cel | ene

# version nunber == jEdit version nunber
pl ugi n. Qui ckNot epadPl ugi n. versi on=4.5

# online help
pl ugi n. Qui ckNot epadPl ugi n. docs=i ndex. ht m

# we only have one dependency, jEdit 4.5
# See jEdit.getBuild() to understand version nunbering schene.
pl ugi n. Qui ckNot epadPl ugi n. depend. O=j edit 4. 05.99. 00

# qui cknotepad's plugin nenu - a list of actions or separators
pl ugi n. Qui ckNot epadPl ugi n. menu=qui cknot epad \

-\

qui cknot epad. choose-file \

qui cknot epad. save-file \

qui cknot epad. copy-t o- buffer

# action | abels for actions supplied by dockabl es. xm
qui cknot epad. | abel =Qui ckNot epad
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# action | abels for actions supplied by actions.xm

qui cknot epad. choose-fil e. | abel =Choose notepad file

qui cknot epad. save-fil e. |l abel =Save notepad file

qui cknot epad. copy-to- buffer.|abel =Copy notepad to buffer

# plugin option pane
pl ugi n. Qui ckNot epadPl ugi n. opti on- pane=qui cknot epad

# Option pane activation BeanShel |l snippet
options. qui cknot epad. code=new Qui ckNot epadOpt i onPane() ;

# Option pane | abels

options. qui cknot epad. | abel =Qui ckNot epad

options. qui cknotepad.file=File:

options. qui cknot epad. choose-fi |l e=Choose

options. qui cknot epad. choose-file.titl e=Choose a notepad file
options. qui cknot epad. choose- f ont =Font :

options. qui cknot epad. show-fil epath.title=D splay notepad file path

# window title
qui cknot epad. titl e=Qui ckNot epad

# w ndow t ool bar buttons

qui cknot epad. choose-fil e. i con=Cpen. png

qui cknot epad. save-fil e.i con=Save. png

qui cknot epad. copy-t o- buffer.i con=CopyToBuffer. png

# default settings

options. qui cknot epad. show-fil epat h=true
options. qui cknot epad. f ont =Monospaced
options. qui cknot epad. f ont styl e=0
options. qui cknot epad. font si ze=14

# Setting not defined but supplied for conpl et eness
options. qui cknot epad. fil epat h=

The Property Files

jEdit maintains alist of “properties’, which are name/value pairs used to store human-readable strings,
user settings, and various other forms of meta-data. During startup, jEdit loads the default set of
properties, followed by plugin properties stored in plugin JAR files, finally followed by user properties.

Some properties are used by the plugin API itself. Others are accessed by the plugin using methods in
the j Edi t class. Others are accessed by the scripts used by plugin packagers .

Property files contained in plugin JARs must end with the filename extension . pr ops, and have avery
simple syntax, which the following example illustrates:

# Lines starting with "# are ignored.
nane=val ue
anot her . nane=anot her val ue

Isee the M acr os/Properties/Create Plugin Announcement macro for an example.
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| ong. property=Long property value, split over \
several lines
escape. property=Newl i nes and tabs can be inserted \
using the \'t and \n escapes
backsl ash. property=A backsl ash can be inserted by witing \\.

Now we look at afragment from the Qui ckNot epad. pr ops file 2 which contains properties for the
QuickNotepad plugin. Thefirst type of property dataisinformation about the plugin itself; these are the
only properties that must be specified in order for the plugin to load:

# general

pl ugi
pl ugi
pl ugi
pl ugi
pl ugi
pl ugi

n
n
n
n
n

n

. Qui
. Qui
. Qui
. Qui
. Qui
. Qui

# depends
pl ugi n. Qui
pl ugi n. Qui
pl ugi n. Qui

pl ugi n information

ckNot epadP! ugi
ckNot epadP! ugi
ckNot epadP! ugi
ckNot epadP! ugi
ckNot epadP! ugi
ckNot epadP! ugi
on jEdit 4.5

ckNot epadP! ugi
ckNot epadP! ugi
ckNot epadP! ugi

n
. usePl ugi nHome=t r ue

. nane=Qui ckNot epad
.aut hor =John Cel | ene
.version=4.5

. docs=Qui ckNot epad. ht n

> 3 3 3 35

acti vat e=def er

. depend. O=j edit 04. 05.99. 00
.description=A denpo jEdit plugin that
.l ongdescri pti on=descri ption. htm

provi des a not epad

These properties are each described in detail in the documentation for the Edi t Pl ugi n classand do
not require further discussion here.

Next in the file comes a property that sets the title of the plugin's dockable window. Dockable windows
are discussed in detail in the section called “ The dockables.xml Window Catalog”.

# dockabl e wi ndow nane
qui cknot epad. tit| e=Qui ckNot epad

Next, we see menu item labels for the plugin's actions. All of these but the first are defined in

actions. xm file, and that is because the dockable itself has its own actions. Actions are discussed
further in the section called “ The Actions.xml Catalog”.

# action | abel s
# Dockabl e | abel
qui cknot epad. | abel =Qui ckNot epad

# Addi tional

qui cknot epad.
qui cknot epad.
qui cknot epad.

strings extracted fromthe plugin java source
choose-fil e. | abel =Choose notepad file
save-file.l abel =Save notepad file
copy-to-buffer.|abel =Copy notepad to buffer

Next, the plugin's menu is defined. See the section called “ The QuickNotepadPlugin Class’.

# application menu itens

gui cknot epad. nmenu. | abel =Qui ckNot epad
qui cknot epad. menu=qui cknot epad - qui cknot epad. choose-file \
qui cknot epad. save-fil e qui cknot epad. copy-t o-buffer

We have created a small toolbar as a component of QuickNotepad, so file names for the button icons

follow:

# plugin tool bar

but t ons

gui cknot epad. choose-fil e.i con=Cpen. png

2Examine the actual file for amore complete example
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gui cknot epad. save-fil e.icon=Save. png
qgui cknot epad. copy-to-buffer.icon=Edit. png

The menu item labels corresponding to these icons will also serve as tooltip text.
Finally, the properties file set forth the labels and settings used by the option pane:

# Option pane | abels

options. qui cknot epad. | abel =Qui ckNot epad

options. qui cknotepad.file=File:

options. qui cknot epad. choose-fi | e=Choose

options. qui cknot epad. choose-file.titl e=Choose a notepad file
options. qui cknot epad. choose- f ont =Font :

options. qui cknot epad. showfilepath.titl e=Di splay notepad file path

# Initial default font settings
options. qui cknot epad. show-fi | epat h=true
opti ons. qui cknot epad. f ont =Monospaced
options. qui cknot epad. font styl e=0
options. qui cknot epad. font si ze=14

# Setting not defined but supplied for conpleteness
options. qui cknot epad. fil epat h=

PropertySideKick

Thereisa SideKick for Property files, provided in the JavaSideKick plugin. This givesyou a
compact and sorted tree view of property files.

Localization Files

In addition to property filesending in. pr ops, you will find property files with the nameslike

| ang_de. properti es. Each of thesefiles provides localized strings for a particular locale. In the
example above, it isfor the German locale. These files are loaded by jEdit automatically when that
localeisin use. They need to have a different filename extension from the other property files so they
can be treated differently from the regular properties.

The EditBus

jEdit (and some plugins) generate several kinds of messages to alert plugins and other components
of jedit-specific events. The message classes, all derived from EBMessage cover the opening and
closing of the application, changes in the status of buffers and views, changes in user settings, as
well as changes in the state of other program features. A full list of messages can be found in the

org.gjt.sp.jedit.msg package.

For example, the ViewUpdate messages are al related to the jEdit View, or the top-level window. If the
user creates multiple Views, a plugin may need to know when they are created or destroyed, so it would
monitor ViewUpdate messages.

BufferUpdate messages are all related to jEdit buffers. They let plugins know when a buffer has become
dirty, when it is about to be closed, after it is closed, created, loaded, or saved. Each of these messages
are described in further detail in the API docs.

As another example, The Navigator plugin monitors an EBMessage of the kind BufferChanging.
The BufferChanging event provides Navigator enough advance notice to save the TextArea's caret
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just before the current EditPane changes its active Buffer. The Buf f er Changed event, another
Edi t PaneUpdat e message, isthrown shortly afterward. Thisis not used by Navigator, but it is used
by SideKick to determine when it is time to reparse the buffer.

Pluginsregister EBConponent instances with the Edi t Bus to receive messages reflecting changes
in jEdit's state.

EBCornponent s are added and removed with the Edi t Bus. addToBus() and
Edi t Bus. r enoveFr onBus() methods.

Typically, the EBConponent . handl eMessage() method isimplemented with one or morei f
blocks that test whether the message is an instance of a derived message class in which the component
has an interest.

i f(nmeg instanceof BufferUpdate) {
/1 a buffer's state has changed!

el se if(nmsg instanceof ViewUpdate) {
/1 a view s state has changed!

}

// ... and so on

If aplugin core class will respond to EditBus messages, it can be derived from EBPI ugi n, in which
case no explicitaddToBus () call is necessary. Otherwise, Edi t Pl ugi n will suffice as aplugin base
class. Note that QuickNotepad uses the latter.

Using the Activity Log to seethe EditBus

To determine precisely which EditBus messages are being sent by jEdit or the plugins, start up
jEdit with an additional argument, - | 0g=5. Y ou can set an even lower log level to see further
details (the default is 7). With alog level of 5 or lower, the Activity Log will include [notice]s,
which will show us exactly which EditBus message is sent and when. See Appendix B, The
Activity Log for more details.

The Actions.xml Catalog

In jEdit aswell asin Plugins, actions define procedures that can be bound to a menu item, a tool bar
button or a keyboard shortcut. Most plugin Actions 3 are short scri pts written in BeanShell, jEdit's macro
scripting language. These scripts either direct the action themselves, delegate to a method in one of the
plugin's classes that encapsulates the action, or do alittle of both. The scripts are usually short; elaborate
action protocols are usually contained in compiled code, rather than an interpreted macro script, to speed
execution.

Actions are defined by creating an XML fileentitled act i ons. xm and placing it in the plugin JAR
file.

Theact i ons. xm file from the QuickNotepad plugin looks as follows:

<ACTI ONS>
<ACTI ON NAME="qui cknot epad. choose-file">
<CODE>
wm addDockabl eW ndow( Qui ckNot epadPl ugi n. NAVE) ;
wm get Dockabl eW ndow( Qui ckNot epadPl ugi n. NAVE) . chooseFi | e();

3Some plugins, such as Sidekick, Console, and ProjectViewer, create pure Java EditAction-derived Actions, based which services are available,
or which files are found in a certain path. However, thisis an advanced topic you can explore further in the source and API docs of those plugins.
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</ CODE>
</ ACTI ON>

<ACTI ON NAME="qui cknot epad. save-file">
<CODE>
wm addDockabl eW ndow( Qui ckNot epadPl ugi n. NAVE) ;
wm get Dockabl eW ndow( Qui ckNot epadPl ugi n. NAVE) . saveFi | e();
</ CCDE>
</ ACTI ON>

<ACTI ON NAME="qui cknot epad. copy-to-buffer">
<CODE>
wm addDockabl eW ndow( Qui ckNot epadPl ugi n. NAVE) ;
wm get Dockabl eW ndow( Qui ckNot epadPl ugi n. NAVE) . copyToBuf fer();
</ CCDE>
</ ACTI ON>
</ ACTI ONS>

Actionsin jEdit core

Y ou can see how each action in jEdit core isimplemented by inspecting theact i ons. xmi
filethat isthere.

Thisfile defines three actions. They each use a built-in variable wm which refersto the current view's
Dockabl eW ndowvanager . Whenever you need to obtain a reference to the current dockable, or
create anew one, thisisthe class to use. We use the method addDockabl e() fol | owed by
get Dockabl e() to createif necessary, and then bring up the QuickNotepad plugin dockable. This
will be docked or floating, depending on how it was last used.

When an action is invoked, the BeanShell scripts address the plugin through static methods, or if
instance datais needed, the current Vi ew, its Dockabl eW ndowianager , and the plugin object
return by the get Dockabl e() method.

If you are unfamiliar with BeanShell code, you may nevertheless notice that the code statements bear a
strong resemblance to Java code, with one exception: the variable vi ewis never assigned any value.

For complete answersto this and other BeanShell mysteries, see Part 111, “Writing Macros’; two
observations will suffice here. First, the variable vi ewis predefined by jEdit's implementation of
BeanShell to refer to the current Vi ew object. Second, the BeanShell scripting language is based upon
Java syntax, but allows variablesto be typed at run time, so explicit types for variables need not be
declared.

A formal description of each element of theact i ons. xm file can be found in the documentation of
the Acti onSet class.

The dockables.xml Window Catalog

A Dockableisawindow that can float like adialog, or dock into jEdit's docking area. Each dockable
needs alabel (for display in menus, and on small buttons) and atitle (for display in the floating
window's title bar).

The jEdit API uses BeanShell to create the top-level visible container of aplugin'sinterface. The
BeanShell codeis contained in afile named dockabl es. xmi . It usually is quite short, providing only
asingle BeanShell expression used to create a visible plugin window.

The following example from the QuickNotepad plugin illustrates the requirements of the datafile:
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<?xnml version="1.0"7?>
<! DOCTYPE DOCKABLES SYSTEM "dockabl es. dtd" >

<DOCKABLES>
<DOCKABLE NAME="(qui cknot epad" >
new Qui ckNot epad(vi ew, position);
</ DOCKABLE>
</ DOCKABLES>

In this example, the <DOCKABLE> element has a single attribute, the dockable window's identifier. This
attribute is used to key a property where the window titleis stored; see the section called “ The Property
Files'.

For each dockable, jedit defines an action with the same name. This means you do not need to define
an explicit action to create your dockable - in fact, jEdit defines three actions: "toggle", "get" and "new
floating instance” for each.

The contents of the <DOCKABLE> element itself is a BeanShell expression that constructs a new

Qui ckNot epad object. Thevi ewand posi t i on are predefined by the plugin API asthe view in
which the plugin window will reside, and the docking position of the plugin. You can use posi ti on to
customize the layout of your plugin depending on whether it appears on the sides, or the top/bottom, or
as afloating dockable.

A formal description of each element of thedockabl es. xni file can be found in the documentation
of the Dockabl eW ndowiVanager class. This class also contains the public interface you should use
for getting, showing, hiding, and other interactions with the plugin's top-level windows.

jEdit'sdockables

jEdit hasitsown dockabl es. xmi file that you can inspect to see how jEdit createsits own
dockables.

The services.xml file

A "service" is amechanism by which one plugin can work with other plugins and avoid a bidirectional
build-dependency. For example, the XML plugin "depends’ on Sidekick, but in fact, it is SideKick
which creates and operates on an object (aSi deKi ckPar ser , in fact) defined in the XML plugin. Ina
way, the dependency is bidirectional.

Similarly, the SshConsole plugin defines but does not instantiate a Shel | object. It isthe Console
plugin which creates a specific shell for each available service. SideKick and Console use the
Ser vi ceManager to search for services offered by other plugins.

Here is an example of a service from the XML plugin, which extends Sidekick:

<! DOCTYPE SERVI CES SYSTEM "servi ces. dtd">
<SERVI CES>
<SERVI CE CLASS="si deki ck. Si deKi ckParser"” NAME="htni ">
new si dekick. html . H m Parser();
</ SERVI CE>

[...]
</ SERVI CES>
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The value of the CLASS= should be a base-class or interface of the object that is returned by executing
the beanshell factory method enclosed in the <SERVI CE> tag.

In the case above, the returned object tells Sidekick how it can parse files of a specific type (HTML).
The API docsfor Si deKi ckPar ser should indicate precisely which methods must be implemented in
aplugin which offersthis service.

For more information about services, refer to the ServiceManager class APl documentation. There, you
can find out what the tags and attributes mean, as well as how to register and use services. You can also
inspect theser vi ces. xnl file of jEdit core to see what services are offered by jEdit itself.

The QuickNotepad Class

Here is where most of the features of the plugin will be implemented. To work with the dockable
window API, the top level window will be aJPanel . The visible components reflect a simple layout.
Inside the top-level panel we will place ascroll pane with atext area. Above the scroll pane we will
place a panel containing a small tool bar and alabel displaying the path of the current notepad file.

We have identified three user actions that need implementation here: chooseFi | e(),saveFil e(),
and copyToBuf f er () . Asnoted earlier, we also want the text areato change its appearancein
immediate response to a change in user options settings. In order to do that, the window class must
respond to aPr oper t i esChanged message from the EditBus.

Unlike the EBPI ugi n class, the EBConponent interface does not deal with the component's actual
subscribing and unsubscribing to the EditBus. To accomplish this, we use a pair of methods inherited
from the Java platform's JConponent classthat are called when the window is made visible, and when
it is hidden. These two methods, addNot i fy() andr enoveNot i fy(), are overridden to add and
remove the visible window from the list of EditBus subscribers.

We will provide for two minor features when the notepad is displayed in the floating window. First,
when afloating plugin window is created, we will give the notepad text areainput focus. Second, when
the notepad if floating and has input focus, we will have the Escape key dismiss the notepad window.
AnAncest or Li st ener and aKeyLi st ener will implement these details.

Here isthe listing for the data members, the constructor, and the implementation of the EBConponent
interface:

public class Qui ckNotepad extends JPanel
i mpl enent s EBConponent

{
private String fil enane;
private String defaultFilenane;
private View view,
private bool ean fl oating;

private Qui ckNot epadText Area text Area;
private Qui ckNot epadTool Panel t ool Panel ;

/1
/1 Constructor
/1

public Qui ckNotepad(View view, String position)
{

super (new Bor der Layout () );
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this.view = view,
this.floating = position.equal s(
Dockabl eW ndowivanager . FLOATI NG) ;

this.filenane = jEdit.getProperty(
Qui ckNot epadP! ugi n. OPTI ON_PREFI X
+ "filepath");
if(this.filename == null || this.filenane.length() == 0)
{
this.filename = new String(jEdit.getSettingsDirectory()
+ File.separator + "gn.txt");
j Edit.set Property(Qui ckNot epadPl ugi n. OPTI ON_PREFI X
+ "filepath",this.filenane);

this.defaul tFilename = new String(this.filenane);

t hi s.tool Panel = new Qui ckNot epadTool Panel (this);
add( Bor der Layout . NORTH, this.tool Panel);

i f(floating)
this.setPreferredSi ze( new D mensi on(500, 250));

text Area = new Qui ckNot epadText Area() ;

t ext Ar ea. set Font ( Qui ckNot epadOpt i onPane. makeFont () ) ;
t ext Ar ea. addKeyLi st ener (new KeyHandl er ());

t ext Ar ea. addAncest or Li st ener (new Ancest or Handl er () ) ;
JScrol | Pane pane = new JScrol | Pane(text Area);

add( Bor der Layout . CENTER, pane);

readFil e();
}
/1
/[l Attribute nethods
/1

/1 for tool Bar display
public String getFil enane()

{
return fil enane;
}
/1
/1 EBConponent inplementation
/1
public void handl eMessage( EBMessage nessage)
{
i f (message instanceof PropertiesChanged)
{
properti esChanged();
}
}
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private void propertiesChanged()

{
String propertyFilename = j Edit.getProperty(
Qui ckNot epadPl ugi n. OPTI ON_PREFI X + "fil epath");
i f(!defaultFilenane.equal s(propertyFil enane))
{
saveFil e();
t ool Panel . properti esChanged() ;
defaul t Fi |l ename = propertyFil enane. cl one();
filenane = defaul tFil enane.clone();
readFil e();
}
Font newFont = Qui ckNot epadOpti onPane. makeFont () ;
i f(!newFont. equal s(textArea. getFont()))
{
t ext Ar ea. set Font ( newFont ) ;
text Area.invalidate();
}
}

/1 These JConponent mnethods provide the appropriate points
/1 to subscribe and unsubscribe this object to the EditBus

public void addNotify()

{
super . addNoti fy();

Edi t Bus. addToBus(t hi s);

public void renpveNotify()

{
saveFil e();
super.removeNotify();
Edi t Bus. r enoveFr onBus(t hi s);
}

}

Thislisting refersto a Qui ckNot ebook Text Ar ea object. It is currently implemented as a
JText Ar ea with word wrap and tab sizes hard-coded. Placing the object in a separate class will simply
future modifications.

The QuickNotepadToolBar Class

There is nothing remarkable about the toolbar panel that is placed inside the Qui ckNot epad object.
The constructor shows the continued use of items from the plugin's propertiesfile.

public class Qui ckNot epadTool Panel extends JPanel
{
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private Qui ckNot epad pad;
private JLabel | abel;

publ i c Qui ckNot epadTool Panel ( Qui ckNot epad gnpad)

{
pad = gnpad;
JTool Bar tool Bar = new JTool Bar () ;
t ool Bar . set Fl oat abl e(f al se);
t ool Bar . add( makeCust onBut t on( " qui cknot epad. choose-file",
new Acti onLi stener() {
public void actionPerformed(Acti onEvent evt) ({
Qui ckNot epadTool Panel . t hi s. pad. chooseFi |l e();
}
1)
t ool Bar . add( makeCust onBut t on( " qui cknot epad. save-file",
new Acti onLi stener () {
public void actionPerformed(Acti onEvent evt) ({
Qui ckNot epadTool Panel . t hi s. pad. saveFil e();
}
1)
t ool Bar . add( makeCust onBut t on( " qui cknot epad. copy-to-buffer”,
new Acti onLi stener() {
public void actionPerformed(Acti onEvent evt) ({
Qui ckNot epadTool Panel . t hi s. pad. copyToBuffer();
}
1)
| abel = new JLabel (pad. get Fi | ename(),
Swi ngConst ants. Rl GHT) ;
| abel . set For egr ound( Col or. bl ack) ;
| abel . set Vi si bl e(j Edit. get Property(
Qui ckNot epadP! ugi n. OPTI ON_PREFI X
+ "show-filepath").equal s("true"));
t hi s. set Layout (new Bor der Layout (10, 0));
t hi s. add( Bor der Layout . WEST, t ool Bar);
t hi s. add( Bor der Layout . CENTER, | abel);
t hi s. set Bor der ( Bor der Fact ory. cr eat eEnpt yBorder (0, 0, 3, 10));
}

}

The method makeCust onBut t on() provides uniform attributes for the three toolbar buttons
corresponding to three of the plugin's use actions. The menu titles for the user actions serve double duty
astooltip text for the buttons. Thereisaso apr operti esChanged() method for the toolbar that
sets the text and visibility of the label containing the notepad file path.

The QuickNotepadOptionPane Class

Using the default implementation provided by Abst r act Opt i onPane reduces the preparation
of an option paneto two principal tasks: writinga _i ni t () method to layout and initialize the
pane, and writinga_save() method to commit any settings changed by user input. If a button on
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the option pane should trigger another dialog, such asaJFi | eChooser or jEdit's own enhanced
VFSFi | eChooser Di al og, the option pane will also have to implement the Act i onLi st ener
interface to display additional components.

The QuickNotepad plugin has only three options to set: the path name of the file that will store the
notepad text, the visibility of the path name on the tool bar, and the notepad's display font. Using the
shortcut methods of the plugin API, the implementation of _i ni t () lookslikethis:

public class Qui ckNot epadOpti onPane extends Abstract Opti onPane
i mpl enents Acti onLi st ener
{

private JTextFi el d pat hNane;
private JButton pickPat h;
private FontSel ector font;

public void _init()
{
showPat h = new JCheckBox(j Edit. get Property(
Qui ckNot epadPI ugi n. OPTI ON_PREFI X
+ "showfilepath.title"),
j Edit. get Property(
Qui ckNot epadPI ugi n. OPTI ON_PREFI X + "show-fil epath")
.equal s("true"));
addConponent ( showPat h) ;

pat hNanme = new JText Fi el d(j Edit. get Property(
Qui ckNot epadPI ugi n. OPTI ON_PREFI X
+ "filepath"));
JButton pickPath = new JButton(j Edit.getProperty(
Qui ckNot epadPI ugi n. OPTI ON_PREFI X
+ "choose-file"));
pi ckPat h. addAct i onLi st ener (thi s);

JPanel pat hPanel = new JPanel (new Border Layout (0, 0));
pat hPanel . add( pat hNane, Bor der Layout. CENTER);
pat hPanel . add( pi ckPat h, Bor der Layout . EAST) ;

addConponent (j Edi t. get Propert y(
Qui ckNot epadPl ugi n. OPTI ON_PREFI X + "file"),
pat hPanel ) ;

font = new Font Sel ect or (nakeFont ());

addConponent (j Edi t. get Propert y(
Qui ckNot epadPI ugi n. OPTI ON_PREFI X + "choose-font"),
font);

}

Here we adopt the vertical arrangement offered by use of the addConponent () method with one
embellishment. We want the first “row” of the option pane to contain a text field with the current
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notepad file path and a button that will trigger a file chooser dialog when pressed. To place both of them
on the same line (along with an identifying label for the file option), we create aJPanel to contain
both components and pass the configured panel to addCornrponent () .

The _i ni t () method uses properties from the plugin's property file to provide the names of

label for the components placed in the option pane. It also uses a property whose name begins with
PROPERTY_PREFI| X as a persistent data item - the path of the current notepad file. The elements of the
notepad's font are also extracted from properties using a static method of the option pane class.

The _save() method extracts data from the user input components and assigns them to the plugin's
properties. The implementation is straightforward:

public void _save()
{
j Edit.set Property(Qui ckNot epadPl ugi n. OPTI ON_PREFI X
+ "filepath", pathNane.getText());
Font _font = font.getFont();

j Edit.set Property(Qui ckNot epadPl ugi n. OPTI ON_PREFI X
+ "font", _font.getFamly());
j Edit.set Property(Qui ckNot epadPl ugi n. OPTI ON_PREFI X
+ "fontsize", String.valueO (_font.getSize()));
j Edit.set Property(Qui ckNot epadPl ugi n. OPTI ON_PREFI X
+ "fontstyle", String.valueO(_font.getStyle()));
j Edit.set Property(Qui ckNot epadPl ugi n. OPTI ON_PREFI X
+ "showfilepath", String.valueO (showPath.isSelected()));

}

The class has only two other methods, one to display afile chooser dialog in response to user action, and
the other to construct a Font object from the plugin's font properties. They do not require discussion
here.

Plugin Documentation

While not required by the plugin API, ahelp fileisan essential element of any plugin written for public
release. A single web page is often all that is required. There are no specific requirements on layout, but
because of the design of jEdit's help viewer, the use of frames should be avoided. Topics that would be
useful include the following:

» adescription of the purpose of the plugin;

 an explanation of the type of input the user can supply through its visible interface (such as mouse
action or text entry in controls);

« alisting of available user actions that can be taken when the plugin does not have input focus;
e asummary of configuration options;

« information on development of the plugin (such as achange log, alist of “to do” items, and contact
information for the plugin's author); and

« licensing information, including acknowledgments for any library software used by the plugin.

Thelocation of the plugin's help fileis stored in the pl ugi n. Qui ckNot epad. docs property; see
the section called “ The Property Files’.
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The build.xml Ant build file

We have aready outlined the contents of the user action catal og, the properties file and the
documentation file in our earlier discussion. The final step isto compile the source file and build the
archivefile that will hold the class files and the plugin's other resources.

Publicly released plugins include with their source a makefilein XML format for the Ant utility. The
format for thisfile requires few changes from plugin to plugin. Hereisaversion of bui | d. xm that
could be used by QuickNotepad:

<proj ect name="Qui ckNot epad" defaul t="build">
<descri pti on>
This is an ant build.xm file for building the Qui ckNotepad plugin for jEdit.
</ descri ption>

<property file="build. properties"/>

<property file="../build.properties"/>

<property nane="user-doc.xm " |ocation = "users-guide.xm"/>
<inport file="${build.support}/plugin-build. xm" />

<!-- Extra files that should be included in the jar -->
<sel ector id="packageFil es">
<or >
<fil enane name="*.txt" />
</ or>

</ sel ect or>
</ proj ect >

This build file imports another modular build file, pl ugi n- bui | d. xm fromthebui | d- support
project. It is available as a package you can check out from subversion, or found online in the jEdit's
SVN repository. It contains the common build steps used to build the core jEdit plugins, and some
examplebui | d. properti es. sanpl e fileswhich you can adapt for use with your development
environment.

Customizing this build file for a different plugin will likely only require three changes to build.xml file:
* the name of the project

« the dependencies of the plugin

» Theextrafilesthat need to be copied into the jar.

Because this build file and those used by most pluginsimport abui | d. properti es filefrom the
current and the parent directories, it is possible to build most of jEdit's pluginsin a uniform way by
setting the common propertiesin asinglebui | d. properti es file, placed in the plugin source's
parent directory.

Tip

For afull discussion of the Ant file format and command syntax, you should consult the Ant
documentation, also available through jEdit's help system if you installed the Ant Plugin.
When editing Ant build files, the XML plugin gives you completion tips for both elements
and attributes. The Console plugin provides you with an ANT button which you can bind to
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keyboard actions. In addition, there are the AntFarm and Antelope plugins which also proivde
you with alternate means to execute Ant targets through the Console.

Reloading the Plugin

Once you have compiled your plugin, you will need to test its behavior when it is reloaded. Follow these
steps to reload your plugin without restarting jEdit:

» From the Plugins menu open the Plugin Manager.
» On the Manage tab uncheck Hide libraries. Thiswill allow you to see plugins that are not |oaded.
» Recheck the plugin to reload it.

Tip

The Activator plugin provides avery convenient (dockable) way to test the activating and
reloading behavior of your plugin. Be sureto test your plugin's reloading behavior with both
the Activator and the Reloader tabs.

If you have reached this point in the text, you are probably serious about writing a plugin for jEdit. Good
luck with your efforts, and thank you for contributing to the jEdit project.

Tips for debugging plugins
BeanShell

jEdit includes a Beanshell interface into its currently running VM at all times. Y ou can accessit a
variety of ways, but oneway isfromPl ugi ns - Console - Shells - BeanShel | . From
here, you can interactively inspect the values of any object in memory, call any of its member functions,
or create new instances of any classthat is currently loaded by jEdit or any of its plugins. All this,
without setting any breakpoints!

If you're too lazy to type each Beanshell statement interactively, you can aso create debugging

code snippets as macros and invokethem fromutiliti es - beanshell - eval uate

sel ection,orMacros - Msc - Evaluate Buffer in Beanshell,orplacethefilein
your own macros directory and bind it to its own keyboard shortcut.

Other useful tips

This section is new but will be expanded shortly. Please post suggestionsto thej edi t - devel mailing
list.
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Utility Classes

If you need to check what the current running platform is, see
org.gjt.sp.jedit. OperatingSystem

If you need to compare file names and don't want to worry about whether you are on a case-sensitive
filesystemor not,useM scUti liti es. pat hsEqual () . Seethat class for other useful path
manipul ation routines.

There are other helpful classesin org.gjt.sp.util, suchasH i Utilities,StandardUtilities,
IOUtilities,andLog. Inparticular, thelLog classisrecommended for reporting errors and also
logging debug information.

If your plugin needs to "find aword" (using word boundaries) somewhere in the buffer, you might want
toreusetheorg. gjt.sp.jedit. Text tilities class

Bundling Additional Class Libraries

Recall that any class whose name ends with Pl ugi n. cl ass iscaled aplugin core class. JAR files
with no plugin core classes are also loaded by jEdit; the classes they contain are made available to
other plugins. Many pluginsthat rely on third-party class libraries ship them as separate JAR files. The
libraries will be available inside the jEdit environment but are not part of agenera classpath or library
collection when running other Java applications.

A plugin that bundles extra JAR files must list theminthe pl ugi n. cl ass nane. j ar s property.
See the documentation for the Edi t Pl ugi n classfor details.

Bundling Additional Non-Java Libraries

If your plugin bundles non-Javafiles, like native libraries, you need to list them in the pl ugi n. cl ass
name. fi | es property. If you don't do so, they don't get deleted if the plugin is uninstalled. See the
documentation for the Edi t Pl ugi n classfor details.

Storing plugin data

If your plugin needs to create files and store data in the filesystem, you should use the

get Pl ugi nHorre() API of theEdi t Pl ugi n class. To signal that you use the plugin home APl you
haveto set the pl ugi n. cl ass nane. usePl ugi nHone property tot r ue. Even if your plugin
doesn't create any files, you should set the property to t r ue, so that e. g. the plugin manager knows that
there is actually no datain favor of not knowing if there is any data and thus displaying that it doesn't
know the data size. See the documentation for the Edi t Pl ugi n classfor details.

Plugin colors

There are anumber of colors used by the View that should also be used by plugins where possible. This
helps promote a consistent color scheme throughout jEdit.
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The main color properties are:

* vi ew. bgCol or - the background color of the main text area

» vi ew. f gCol or - the base foreground color for text in the main text area

e vi ew. | i neHi ghl i ght Col or - color of the current line highlight

» vi ew. sel ecti onCol or -thecolor of selected text in the main text area
* vi ew. car et Col or - the color of the caret in the main text area

* vi ew. eol Mar ker Col or - the color of the end-of-line marker

To use these colorsin your plugin, use

j Edi t. get Col or Property("vi ew. whatever", default _col or)

For example, the QuickNotepad example should have lines like this:

t ext ar ea. set Backgr ound(j Edi t . get Col or Property("vi ew. bgCol or", Col or. VW TE)
t ext ar ea. set For eground(j Edi t . get Col or Property("vi ew. fgCol or", Col or.BLACK)
This sets the foreground and background colors of QuickNotepad to be the same as those in the View.
There are other color properties that may be useful, depending on what your plugin displays.

Gutter colors:

* view. gutter.bgCol or

e view. gutter. currentLineCol or

* view. gutter.fgCol or

* view gutter.focusBorder Col or

e view gutter.fol dCol or

* view. gutter. highlightCol or

e view. gutter. marker Col or

* view. gutter.noFocusBor der Col or

e view. gutter.registerCol or

* view. gutter.structureH ghlight Col or
Status bar colors:
e vi ew. st at us. backgr ound

* vi ew. st atus. f oreground

e vi ew. status. menory. backgr ound
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e vi ew. status. menory. f oreground

Structure highlight colors:
e vi ew. structureHi ghlight Col or
* view. structureHi ghlight Col or

Stylecolors. UseGUI Ut i lities. parseStyl e for these.

* view style.coment 1

* view. styl e. conment 2

e view styl e.conment 3

e view style.coment 4

e view style.digit

e view. style.foldLine.0O
e view. style.foldLine. 1
* view style.fol dLi ne. 2
* view. style.fol dLine. 3
* view. style.function

e view. style.invalid

* view styl e. keywordl

* view. styl e. keywor d2

e view. styl e. keywor d3

e view. styl e. keyword4

* view styl e. | abel

e viewstyle.literall

e view. style.literal 2

* view.style.literal 3

s view.style.literal 4

* view. styl e. markup

* view. styl e. operator

e vi ew. w apCui deCol or

For example, hereis a setting for afold line color:
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vi ew. styl e. fol dLi ne. O=col or\:\#000000 bgCol or\:\#f 5deb8 style\:Db

Passing thevalueto GUI Ut i | i ti es. par seStyl e will return a SyntaxStyle object, which you can
query for background color, foreground color, and font.
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